indicator-applet fails to bring pidgin to foreground

Bug #346554 reported by Christoph Korn
48
This bug affects 9 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Invalid
Undecided
Unassigned
indicator-applet (Ubuntu)
Invalid
Undecided
Unassigned
pidgin (Ubuntu)
Confirmed
Low
Unassigned

Bug Description

Binary package hint: indicator-applet

The indicator-applet cannot bring pidgin to the front sometimes
when another program is focused. I have created a capture video to explain it.
First you see that the applet can bring up pidgin fine.
But when I open a new tab in opera and then click the applet the
contact list of pidgin is not opened in the foreground. But you can see
it appear in the bar at the bottom.

Description: Ubuntu jaunty (development branch)
Release: 9.04

indicator-applet:
  Installed: 0.1.3-0ubuntu1
  Candidate: 0.1.3-0ubuntu1
  Version table:
 *** 0.1.3-0ubuntu1 0
        500 http://de.archive.ubuntu.com jaunty/main Packages
        100 /var/lib/dpkg/status

Revision history for this message
Christoph Korn (c-korn) wrote :
Revision history for this message
Christoph Korn (c-korn) wrote :

I have pidgin 1:2.5.5-1ubuntu2 installed.

The issue should have been fixed in bug 341142 but it is not.

Revision history for this message
Andreas Moog (ampelbein) wrote :

Ted, can you have a look into this, thanks.

Changed in indicator-applet (Ubuntu):
assignee: nobody → ted-gould
Changed in pidgin (Ubuntu):
importance: Undecided → Low
Revision history for this message
Christoph Korn (c-korn) wrote :

It is odd that this issue disappears when I run pidgin from terminal or with Ctrl+F2->pidgin.
But it appears again when I run pidgin from Gnome menu or the icon on the gnome panel.

Revision history for this message
Christoph Korn (c-korn) wrote :

This screen capture shows the oddness.

When I start pidgin from gnome-panel icon it does not get to foreground.
But when I start pidgin from terminal it gets to foreground.

Revision history for this message
Ricardo Pérez López (ricardo) wrote :

I can confirm this strange behavior. For example:

0. Start without buddy list (close the buddy list if it's opened).

1. Open a terminal (Applications->Accesories->Terminal).

2. Click on Indicator Applet icon and then select Pidgin.

Expected behavior: The buddy list is displayed IN FRONT OF the terminal window.

Actual behavior: The buddy list is displayed BEHIND the terminal window.

3. Click again on Indicator Applet icon and select Pidgin. Result: the buddy list is again incorrectly displayed behind the terminal window.

4. Click on the buddy list to bring it to the front.and select Indicator Applet icon -> Pidgin. Result: the buddy list is correctly hidden.

5. Click again on Indicator Applet icon -> Pidgin. Result: the buddy list is incorrectly displayed behind the terminal window.

6. Close the buddy list clicking on the X icon in its title bar, and then click on Indicator Applet -> Pidgin. Result: the buddy list is correctly displayed IN FRONT OF the terminal window.

7. Click again on Indicator Applet -> Pidgin. Result: the buddy list is correctly hidden.

8. Bring the buddy list back again clicking on Indicator Applet -> Pidgin. Result: the buddy list is correctly displayed in front of the terminal window.

9. Click on the terminal window to bring it to the front, and then click on Indicator Applet -> Pidgin. Result: the buddy list keeps incorrectly behind the terminal window, instead of get hidden.

Changed in pidgin (Ubuntu):
status: New → Confirmed
Changed in indicator-applet (Ubuntu):
status: New → Confirmed
Revision history for this message
Ted Gould (ted) wrote :

Indicator applet has nothing to do with this. It just sends a DBus signal to pidgin-libnotify, which just calls the purple function to present the buddy list.

Changed in indicator-applet (Ubuntu):
status: Confirmed → Invalid
Changed in pidgin (Ubuntu):
assignee: Ted Gould (ted-gould) → nobody
Revision history for this message
Alessio "Spinus" Moscatello (spinus) wrote :

Which version of Pidgin are you using? I'm using version 2.5.5-1ubuntu8 and buddy list is always displayed in foreground.

Revision history for this message
Ken VanDine (ken-vandine) wrote :

This looks like bug 354026 that I filed with a patch. The current pidgin-libnotify toggles show for the buddy list, which generally doesn't focus the window the first time you select it in the message indicator. I have a patch that set visibility to true so it always presents it, noted in that bug.

Revision history for this message
Ricardo Pérez López (ricardo) wrote :

@Ted:
Thanks for the explanation, and sorry for opening an invalid task.

@Alessio:
I'm using the latest one I can find on Jaunty (same as yours):

$ apt-cache policy pidgin
pidgin:
  Installed: 1:2.5.5-1ubuntu8
  Candidate: 1:2.5.5-1ubuntu8
  Version table:
 *** 1:2.5.5-1ubuntu8 0
        500 http://archive.ubuntu.com jaunty/main Packages
        100 /var/lib/dpkg/status

@Ken:
Your patch seems to be good, although I have not tested it yet. Ted, can I know what do you think? Thanks!

Revision history for this message
Ted Gould (ted) wrote : Re: [Bug 346554] Re: indicator-applet fails to bring pidgin to foreground

On Thu, 2009-04-16 at 21:56 +0000, Ricardo Pérez López wrote:
> @Ken:
> Your patch seems to be good, although I have not tested it yet. Ted,
> can I know what do you think? Thanks!

I don't remember where the discussion happened, but the issue was that
we were trying to model the behavior of the status icon. So we're
calling the same function as the status icon. It seems non-ideal as the
code to detect if the window is visible in Pidgin seems to not detect
that case very well.

So, I don't think for Jaunty, it makes sense to change this. But, we're
discussing it with regards to the MessageingMenu spec on the Ubuntu wiki
so that all applications have the same behavior, which is the most
important thing.

Revision history for this message
Ricardo Pérez López (ricardo) wrote :

Curiously, when you click on the Indicator Applet icon and select Pidgin, the buddy list appears just BEHIND the window having the focus. Try to following:

1. Open Firefox, full maximized.
2. Open a Terminal.
3. Click on Indicator Applet -> Pidgin.

Result: the buddy list is displayed BEHIND the terminal window, but IN FRONT of the Firefox window.

4. Click on the buddy list to give it the focus. The buddy list goes in front of the terminal window.
5. Click on X button to close the buddy list.
6. Click on Indicator Applet -> Pidgin.

Result: the buddy list is displayed IN FRONT of all windows, because there's no another window focused.

7. Click on X button to close the buddy list.
8. Click on the Terminal window, even it already has the focus (this is very important).
9. Click on Indicator Applet -> Pidgin.

Result: the buddy list is displayed BEHIND the terminal window, but IN FRONT of the Firefox window.

If you skip the step #8, then the buddy list is displayed IN FRONT of all windows. It seems that Pidgin tries to remember what window had the focus when the buddy list closed.

Revision history for this message
Alessio "Spinus" Moscatello (spinus) wrote :

I've just realized that in my system this issue occurs only when compiz is disabled...

Revision history for this message
Paul Natsuo Kishimoto (khaeru) wrote :

I don't think I'm experiencing this bug, but while it's being fixed, I should note that the *default behaviour* is odd.

Intuitively, I think of the act of clicking the indicator-applet icon as "deal with messages." When the buddy list is not show, this necessitates showing it. When the buddy list is shown, but not visible (under other windows), this means bringing it to the front.

Instead, the click hides the buddy list, and I must click twice more (on the applet, then on "Pidgin Internet Messenger") to get the buddy list on top.

I know that Alt+Tab is an alternative, but in itself this behaviour seems wrong. Compare with the behaviour for Evolution.

Revision history for this message
Lionel Dricot (ploum-deactivatedaccount) wrote :

It does work with Empathy which is now the new default. The papercut is then fixed.

Changed in hundredpapercuts:
status: New → Fix Released
Revision history for this message
Matthew Paul Thomas (mpt) wrote :

I don't know whether this bug is fixed for Pidgin, but it should not be marked fixed on the grounds that it is fixed for Empathy. Whether it is fixed for Empathy is bug 442389, not this bug. And we want Pidgin to integrate properly with the messaging menu, regardless of Empathy's status.

Changed in indicator-applet (Ubuntu):
status: Invalid → New
status: New → Invalid
Revision history for this message
Matthew Paul Thomas (mpt) wrote :

Sorry, Lionel, I misunderstood your comment. This bug is fixed in the papercut sense, even if not in Pidgin itself, because Pidgin is no longer the default IM program. So bug 442389 might be the new papercut.

Revision history for this message
David Siegel (djsiegel-deactivatedaccount) wrote :

"This bug is fixed in the papercut sense" -- interesting, Matthew. However, I do not want to count this as a paper cut as the issue was not addressed and Pidgin is not in the default Ubuntu install. Many Ubuntu users will be upgrading to Karmic and they will still experience the issue so I don't want to consider this a fixed paper cut.

Changed in hundredpapercuts:
status: Fix Released → Invalid
status: Invalid → Confirmed
Revision history for this message
Chris Wilson (notgary-deactivatedaccount) wrote :

Thanks a lot for reporting this, however since Pidgin is not a part of the default installation, nor is it a 'Featured Application' in the Software Centre, this cannot be considered as a paper cut.

Changed in hundredpapercuts:
status: Confirmed → Invalid
Revision history for this message
Ali Raeini (aliqasemi) wrote :

email indicator also fails to bring thunderbird to foreground, so does behave other indicators

Revision history for this message
Ali Raeini (aliqasemi) wrote :

I am using ubuntu 12.04

Revision history for this message
Kai Mast (kai-mast) wrote :

Bug still persistent in saucy. 5 years!

Can't we just remove the crappy indicator patches from pidgin? They are horribly broken.

Revision history for this message
Rob Tongue (robtongue) wrote :

This is still a pretty giant problem for me. If you select a new message entry in the indicator applet, the launcher entry just wiggles, demanding attention instead of foregrounding the window. Pidgin isn't the only app to do this, Thunderbird does as well. It all used to work in 12.04 as well, but as "fixes" are rolled into the LTS release, it is slowly breaking there as well.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers