Cannot connect to ICQ ("The client version you are using is too old.") (2009-03-09)

Bug #340075 reported by Hanno Stock (hefe_bia) on 2009-03-09
This bug report is a duplicate of:  Bug #340151: ICQ protocol update [March 2009]. Edit Remove
112
This bug affects 15 people
Affects Status Importance Assigned to Milestone
Kopete
Fix Released
Unknown
pidgin (Ubuntu)
High
Unassigned

Bug Description

Pidgin is no longer able to connect to ICQ. The message is "The client version you are using is too old."

This happened last year, too (see bug #244591).

This bug is for tracking the progress on this new issue which occured first to my knowledge on 2009-03-09.

libpurple0:
  Installiert: 1:2.5.2-0ubuntu1
  Kandidat: 1:2.5.2-0ubuntu1
  Versions-Tabelle:
 *** 1:2.5.2-0ubuntu1 0
        500 http://de.archive.ubuntu.com intrepid/main Packages
        100 /var/lib/dpkg/status

description: updated
pyth (pyth) wrote :

I have same problem. Also since 2009-03-09.

Christian Doczkal (thyrus) wrote :

I can also reproduce the problem.

Tony Manco (trmanco) wrote :

I can also confirm this.

Changed in pidgin:
status: New → Confirmed

This is also the case for hardy which has the version 1:2.4.1-1ubuntu2.2.

Andreas Moog (ampelbein) on 2009-03-09
Changed in pidgin:
importance: Undecided → High

We should ship the latest stable 2.5.5 ASAP in the repository. This has a massive impact.

Andreas Moog (ampelbein) wrote :

Currently building 2.5.5 in my ppa, will announce here when ready.

Is it fixed in 2.5.5? I doubt that - it would mean the Pidgin developers knew about the protocol change in advance.

The PPA https://launchpad.net/~debfx/+archive/ppa/ contains pidgin 2.5.5 and works for me

Christian Doczkal (thyrus) wrote :

Works for me as well.

Vasil Kolev (vasil-ludost) wrote :

Confirmed, works with 2.5.5 from Felix Geyer's ppa (~debfx).

Changed in kopete:
status: Unknown → Invalid
Andreas Moog (ampelbein) wrote :

Version in my ppa for jaunty works fine.

Just a reminder, this needs to be backported to Hearty (LTS) along with any needed dependency upgrades too.

Tony Manco (trmanco) on 2009-03-09
Changed in kopete:
status: Invalid → Unknown
Changed in kopete:
status: Unknown → Confirmed
Andre (ajx) wrote :

We need updates for Hardy and Intrepid. The usual user may not know how to add a PPA.

Thomas Schewe (thosch66) wrote :

@LanceHaverkamp @Andre: Feisty is still in charge and should be also fixed.

It looks like, there is a released fix fpr Jaunty:
https://bugs.launchpad.net/ubuntu/+source/pidgin/+bug/340151

moojix (moojix) wrote :

yes, today pidgin 2.5.2 (intrepid) stopped working with ICQ ("your client version is too old").
we need the upgrade in Intrepid.

Markus Korn (thekorn) wrote :

This bug has been fixed in the latest development version of Ubuntu - the Jaunty Jackalope.
Bug 340151 tracks the status for previous versions of Ubuntu.

Changed in pidgin:
status: Confirmed → Fix Released
sam-c (cohensam) wrote :

Pidgin and ICQ problem still today

jag7720 (milktoast) wrote :

As of 03-10-2009 06:53 CDT I still have this issue. Running Ubuntu 8.10 x86-64 2.6.27-11-generic SMP
I tried updating Pidgin but there doesn't seem to be a newer release.

jag7720 (milktoast) wrote :

I found this
http://www.getdeb.net/app/Pidgin

and installed manually (not the greatest thing) and it resolved the issue.

Now, when will there be packages in the repository?

emerging (anyreg) wrote :

As of 1:21 pm CET March 10, the problem persists.

sam-c (cohensam) wrote :

 jag7720 wrote 1 hour ago: (permalink)

I found this
http://www.getdeb.net/app/Pidgin

and installed manually (not the greatest thing) and it resolved the issue.

Now, when will there be packages in the repository?

Yes this worked thanks

Laszlo Kupcsik (koopac) wrote :

Just tried update-upgrade on Intrepid, but there's no new Pidgin version. I don't think it can be considered fixed as long as it is not possible to connect both Intrepid (stable) and LTS versions. Could it be just patched to report a later client version towards ICQ servers?

Christian Limberg (chli01) wrote :

@Laszlo: I think that should be possible. According to [1] the pidgin developers used this patch [2] in version 2.5.5 to bump the client version reported to the ICQ server to a more current version number. I haven't tested it, but it should be no great deal to apply this fix to an older pidgin version, too.

[1]: http://developer.pidgin.im/viewmtn/revision/info/3224dd8677b28d02b866cce510941fbf67e0fcb7
[2]: http://developer.pidgin.im/viewmtn/revision/rawdiff/1a658bb7a0436b518d65b9b95116915a5511a7d3/with/3224dd8677b28d02b866cce510941fbf67e0fcb7/libpurple/protocols/oscar/oscar.h

I'd try to generate a debdiff but developer.pidgin.im and mtn.pidgin.im
are too overloaded to work with...
Can somebody who has more luck attach the patch here?

Changed in kopete:
status: Confirmed → Fix Released
Vasil Kolev (vasil-ludost) wrote :

The diff from developer.pidgin.im is attached. Afaik, just the second part is needed, the CLIENTINFO_ICQBASIC_14_34_3096 define won't be used anywhere else...

Martin Pitt (pitti) wrote :

Please seee bug 340151, where the package updates in *-proposed are currently being tested.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.