Please merge pidgin 2.5.5 from Debian

Bug #336647 reported by Nicolò Chieffo on 2009-03-02
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
pidgin (Ubuntu)
Wishlist
Unassigned
Nominated for Jaunty by Festor

Bug Description

Binary package hint: pidgin

pidgin (1:2.5.5-1ubuntu1) jaunty; urgency=low

  * Merge from debian, remaining changes: (LP: #316636, #336647)
    - debian/control:
      + Add Build-Deps on liblaunchpad-integration-dev, intltool,
      network-manager-dev
      + Add epoch in dependencies
      + Drop the libpurple0 dependency on libpurple-bin
    - debian/libpurple0.symbols: add epoch to symbol
    - debian/pidgin-dbg.preinst, debian/pidgin-dev.preinst,
      debian/pidgin.preinst: add epoch
    - Update debian/prefs.xml to set the notify plugin prefs
      /plugins/gtk/X11/notify/*, set /pidgin/plugins/loaded to load
      the notify plugin and enable the standard logging options by default
    - debian/rules:
      + remove --disable-nm as nm has been fixed in Ubuntu
      + Add X-Ubuntu-Gettext-Domain to the desktop file and update the
        translation templates in common-install-impl::
    - debian/patches:
      + 02_lpi.patch for LP integration
      + 04_let_crasher_for_apport.patch to stop catching the SIGSEGV signal
        and let apport handle it
      + 05_default_to_irc_ubuntu_com.patch to set the default IRC
        server to irc.ubuntu.com
      + 70_autoconf.patch
      + 60_1024x600_gtkaccount.c.patch: Add scrolled bars into account dialog,
        pounce windows and preference window when screen height is less than 600.
  * Adapt debian/patches/02_lpi.patch
  * Re-generate debian/patches/70_autoconf.patch
  * Remove debian/patches/fix-icons-backport-from-2.5.5mtn.diff as taken
    upstream

------------------

There is a new version of pidgin (2.5.5) available in Debian Sid:
http://packages.debian.org/sid/pidgin

Sources:
http://ftp.de.debian.org/debian/pool/main/p/pidgin/pidgin_2.5.5.orig.tar.gz
http://ftp.de.debian.org/debian/pool/main/p/pidgin/pidgin_2.5.5-1.diff.gz

You can see the changelog here:
http://developer.pidgin.im/wiki/ChangeLog

It is a bugfix release, then lots of bugs and crashes were fixed, so I guess we should upgrade

Chris Coulson (chrisccoulson) wrote :

Where did they get the 2.5.5 tarball from? The Pidgin website is still at 2.5.4.

Changed in pidgin:
status: New → Incomplete
importance: Undecided → Wishlist
Chris Coulson (chrisccoulson) wrote :
Changed in pidgin:
status: Incomplete → Confirmed
Brian Curtis (bcurtiswx) wrote :

2.5.5 shows up on the pidgin site now chris. (just an FYI :D)

description: updated
Chris Coulson (chrisccoulson) wrote :

Surfaz - are you doing the merge then? You've subscribed sponsors, but there isn't anything for them to sponsor yet

Chris Coulson (chrisccoulson) wrote :

As we are passed feature freeze, I believe this will also need a FFe. (https://wiki.ubuntu.com/FreezeExceptionProcess)

2009/3/8 Chris Coulson <email address hidden>:
> As we are passed feature freeze, I believe this will also need a FFe.
> (https://wiki.ubuntu.com/FreezeExceptionProcess)
>

If Surfaz didn't want to handle it (and mislead in the process), I
made the previous pidgin merge and agree to merge it again against
debian if seb128 gives a FFe.
Looking at the changelog, it is mainly a bug fix release, but some new
beta features are also provided.

Chris Coulson (chrisccoulson) wrote :

Thanks Didier :)

Sebastien Bacher (seb128) wrote :

doing the update would be a good idea indeed

Sebastien Bacher (seb128) wrote :

unsubscribing sponsors since there is no nothing to sponsor there yet

Jan (jan-welker) wrote :

Pidgin 2.5.2 does report "The client version you are using is too old. Please upgrade ..."

Confirming 5ketcher message, using Pidgin 2.5.2 (Intrepid): trying to connect to ICQ Network. Interestingly AIM still works.

Didier Roche (didrocks) wrote :

Merging it right now.

Changed in pidgin:
assignee: nobody → didrocks
status: Confirmed → In Progress
Didier Roche (didrocks) wrote :

Done, see the related branch.

Changed in pidgin:
assignee: didrocks → nobody
status: In Progress → Triaged
description: updated
Changed in pidgin:
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pidgin - 1:2.5.5-1ubuntu1

---------------
pidgin (1:2.5.5-1ubuntu1) jaunty; urgency=low

  * Merge from debian, remaining changes: (LP: #316636, #336647)
    - debian/control:
      + Add Build-Deps on liblaunchpad-integration-dev, intltool,
      network-manager-dev
      + Add epoch in dependencies
      + Drop the libpurple0 dependency on libpurple-bin
    - debian/libpurple0.symbols: add epoch to symbol
    - debian/pidgin-dbg.preinst, debian/pidgin-dev.preinst,
      debian/pidgin.preinst: add epoch
    - Update debian/prefs.xml to set the notify plugin prefs
      /plugins/gtk/X11/notify/*, set /pidgin/plugins/loaded to load
      the notify plugin and enable the standard logging options by default
    - debian/rules:
      + remove --disable-nm as nm has been fixed in Ubuntu
      + Add X-Ubuntu-Gettext-Domain to the desktop file and update the
        translation templates in common-install-impl::
    - debian/patches:
      + 02_lpi.patch for LP integration
      + 04_let_crasher_for_apport.patch to stop catching the SIGSEGV signal
        and let apport handle it
      + 05_default_to_irc_ubuntu_com.patch to set the default IRC
        server to irc.ubuntu.com
      + 70_autoconf.patch
      + 60_1024x600_gtk*.c.patch: Add scrolled bars into account dialog,
        pounce windows and preference window when screen height is less than 600.
  * Adapt debian/patches/02_lpi.patch
  * Re-generate debian/patches/70_autoconf.patch
  * Remove debian/patches/fix-icons-backport-from-2.5.5mtn.diff as taken
    upstream

 -- Didier Roche <email address hidden> Mon, 09 Mar 2009 23:25:48 +0100

Changed in pidgin:
status: Fix Committed → Fix Released
Jan K. (jan-launchpad-kantert) wrote :

Could you provide a package for hardy too? ICQ doesnt work anymore with pidgin (at least in germany).

Chris Coulson (chrisccoulson) wrote :

Jan K - please open a separate bug report for a backport, or about the ICQ problem.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers