The version you are using is not supported by ICQ. Download a free authorized ICQ version from ICQ's official website.

Bug #319547 reported by xoco on 2009-01-21
This bug report is a duplicate of:  Bug #340151: ICQ protocol update [March 2009]. Edit Remove
48
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Hardy Backports
Undecided
Unassigned
Pidgin
Invalid
Unknown
pidgin (Ubuntu)
Medium
Unassigned
Nominated for Hardy by Chris Coulson
Nominated for Intrepid by FrozenFire

Bug Description

Binary package hint: pidgin

today - 21 January 2009, pidgin 2.5.3 ... when i try connect to icq server got message from UIN #1 with text:

The version you are using is not supported by ICQ. Download a free authorized ICQ version from ICQ's official website.

Adium client on Mac have same problem today ..

xoco (arthur.ivanov) wrote :

my version is: 2.5.3-0ubuntu2 (jaunty)

Serhio (chabanse) wrote :

The same thing with pidgin 2.5.2
It was working today morning, but then I re-connected Pidgin and the same message as above.
It is happening to other existing ICQ clients as well. Obviously it caused by a new change on ICQ server.

xoco (arthur.ivanov) wrote :

qip (IM Client) have same problem ... looks like this is not pidgin problem - AOL Servers was change protocol or smth.... and all not authorized clients can't connect ..

Chris Coulson (chrisccoulson) wrote :

Thank you for your bug report. this bug has already been reported but please feel free to report any other bugs you find.

Changed in pidgin:
status: New → Invalid
xoco (arthur.ivanov) wrote :

this is not dublicate of #307148 noob! 307148 was fixed in 2008 .. this is new issue!

xoco (arthur.ivanov) wrote :

today, icq.com officialy confirm this issue ..

xoco (arthur.ivanov) wrote :

this patch from last ICQ version change (2008 year)
#
# old_revision [dba36543cdde6db127857b0edfdc3ad1969bbd39]
#
# patch "libpurple/protocols/oscar/oscar.h"
# from [a40e3332eade975c73e344e17bd06d4b99cae751]
# to [7853a27f5f8735092ebefef567aaeeccad2a057c]
#
============================================================
--- libpurple/protocols/oscar/oscar.h a40e3332eade975c73e344e17bd06d4b99cae751
+++ libpurple/protocols/oscar/oscar.h 7853a27f5f8735092ebefef567aaeeccad2a057c
@@ -301,7 +301,7 @@ struct _ClientInfo

 #define CLIENTINFO_PURPLE_ICQ { \
  "Purple/" VERSION, \
- 0x010a, \
+ 0x010b, \
  0x0014, 0x0034, \
  0x0000, 0x0bb8, \
  0x0000043d, \

looks like we must increase this values ..

guys from QIP.ru .. have workaround - they change id to &RQ Client Info

xoco (arthur.ivanov) wrote :

qip have nice feature - change this option online manualy ... pidgin must have this option too ..

2009/1/21 xoco <email address hidden>

> this is not dublicate of #307148 noob! 307148 was fixed in 2008 ..
> this is new issue!
>

What do you mean "noob"? If you are so sure that bug 307148 has been fixed,
then you could have been helpful and actually closed it as such rather than
posting the same "this is not a duplicate of..." comment across 3 different
bug reports. You could have also marked bug 319549 (currently a duplicate of
bug 307148 which you claim is fixed) as a duplicate of this one.

Changed in pidgin:
status: Invalid → New
Changed in pidgin:
importance: Undecided → High
status: New → Confirmed
status: Confirmed → Triaged
Changed in pidgin:
status: Unknown → New
Chris Coulson (chrisccoulson) wrote :

This has already been reported upstream, so I've linked the upstream bug report to this. The upstream bug report can be tracked here: http://developer.pidgin.im/ticket/8198

Chris Coulson (chrisccoulson) wrote :

Adding hardy-backports task as well, as this will need fixing there too

debuger (firekey) wrote :
Nickolay Ihalainen (ihanick) wrote :

It solves the problem for win32 only. This is a link spam.

Misha Bazanov (bmw-) wrote :

Workaround(based on the fact that only exposed Russia's IP): install tor and use it for connection.

apt-get install tor

In pidgin: Manage accounts - Change proxy for ICQ accounts to SOCKS5 ip 127.0.0.1 port 9050
About tor: http://en.wikipedia.org/wiki/Tor_(anonymity_network)

====

Обходное решение -- использовать TOR, запускаем

apt-get install tor

и дальше в свойствах учетной записи ICQ указать прокси типа SOCKS5 с ip адресом 127.0.0.1 и портом 9050
Что такое Tor: http://ru.wikipedia.org/wiki/Tor

discont (discont) wrote :

Same here. Pidgin 2.5.2, Ubuntu 8.10, Russian IP

discont (discont) wrote :

icq.com screenshot from Russian IP: http://persei.miranda.im/files/icq_ru.png and American IP: http://persei.miranda.im/files/icq.png

discont (discont) wrote :

In the Russian text it is said that not authorised clients are not supported any more.

xoco (arthur.ivanov) wrote :

http://qip.ru - (popular russian IM client) found solution and fix thier client ..

zhekanax (zhekanax) wrote :

I've connected and can chat from now.
Nothing was changed and ip still Russian (81.13.100.*)

xoco (arthur.ivanov) wrote :

Agree.

Right now pidgin can connect and chat. looks like AOL change it back.

discont (discont) wrote :

Yes, now it works, without any patch. AOL morons

Ivan Zorin (iaz) wrote :

Confirm.
In 2.5.2 (intrepid) and in 2.5.3 (jaunty) versions I have the same issue.

Chris Coulson (chrisccoulson) wrote :

Closing for now then

Changed in pidgin:
status: Triaged → Invalid
Changed in hardy-backports:
status: New → Invalid
Nickolay Ihalainen (ihanick) wrote :

Still broken for ip 85.140.192.*

Ilya Barygin (randomaction) wrote :

Reopening. Apparently for some IPs the problem disappeared, but for others still present.

Still broken for me, and the upstream discussion is ongoing.

Changed in pidgin:
status: Invalid → Confirmed
Chris Coulson (chrisccoulson) wrote :

Thanks. Yeah, this should stay open for now then although it would be best to keep discussion to the upstream bug report. I'm downgrading the importance as its obvious now that it's not affecting the majority of users

Changed in pidgin:
importance: High → Medium
status: Confirmed → Triaged
Nickolay Ihalainen (ihanick) wrote :

The patch pidgin-NOT-UPSTREAM-2.5.4-icq-russia.patch works for me (Pidgin 2.5.2 from intrepid).

Eugene Savelov (savelov) wrote :

can you point to ubuntu binary package to test?

Ivan Zorin (iaz) wrote :

In my PPA should be available pidgin (2.5.4) packages with icq patch. So, to test it, just add:
deb http://ppa.launchpad.net/iaz/ubuntu jaunty main
deb-src http://ppa.launchpad.net/iaz/ubuntu jaunty main
lines in /etc/apt/source.list and run sudo apt-get update; upgrade your pidgin.
This packages for jaunty, but probably it can be successfully installed in intrepid as well.
Looks like it works well, but, however, just in case, there is no any warranty, so use it at your own risk.

Ilya Barygin (randomaction) wrote :

It seems that ICQ is functioning normally since yesterday. Is anyone still experiencing the problem?

Eugene Savelov (savelov) wrote :

it seems issues started again, as AOL changed protocol one more time

For sure, just some minutes ago I lost connection with messages:
The version you are using is not supported by ICQ. Download a free authorized ICQ version from ICQ's official website.

Feuerfuchs (roman.lagunov) wrote :

Works for me when connected using TOR, as described above in the topic.

Eugene Savelov (savelov) wrote :

the patch /binary at http://www.f4ber.net/?p=185 works for me

Seems that everything's ok today without patching anything.

Joshua Kugler (jkugler) wrote :

Hardy is a supported release, thus this fix needs to be back-ported to Hardy, either via backports, or via an update of the package in hardy.

Changed in hardy-backports:
status: Invalid → Confirmed

On 03/21/2009 02:44 PM, Joshua Kugler wrote:
> Hardy is a supported release, thus this fix needs to be back-ported to
> Hardy, either via backports, or via an update of the package in hardy.
>
> ** Changed in: hardy-backports
> Status: Invalid => Confirmed
>
Doesn't version 2.5.2-0ubuntu1~hardy1 work? I dont seem to have a
problem with it.

--
Sincerely Yours,
    John Vivirito

https://launchpad.net/~gnomefreak
https://wiki.ubuntu.com/JohnVivirito
Linux User# 414246

"How can i get lost, if i have no where to go"
    -- Metallica from Unforgiven III

Chris Coulson (chrisccoulson) wrote :

A patch to fix a similar issue for ICQ was recently backported to all supported Ubuntu versions (bug 340151). However, the version of Pidgin in hardy-backports does not have this patch yet. Bug 340151 still has an open hardy-backports task, so I'm going to mark this bug as a duplicate of bug 340151

John Vivirito (gnomefreak) wrote :

On 03/21/2009 07:45 PM, Chris Coulson wrote:
> *** This bug is a duplicate of bug 340151 ***
> https://bugs.launchpad.net/bugs/340151
>
> A patch to fix a similar issue for ICQ was recently backported to all
> supported Ubuntu versions (bug 340151). However, the version of Pidgin
> in hardy-backports does not have this patch yet. Bug 340151 still has an
> open hardy-backports task, so I'm going to mark this bug as a duplicate
> of bug 340151
>
> ** This bug has been marked a duplicate of bug 340151
> ICQ protocol update [March 2009]
>
Thanks that answered my question

--
Sincerely Yours,
    John Vivirito

https://launchpad.net/~gnomefreak
https://wiki.ubuntu.com/JohnVivirito
Linux User# 414246

"How can i get lost, if i have no where to go"
    -- Metallica from Unforgiven III

Changed in pidgin:
status: New → Unknown
Changed in pidgin:
status: Unknown → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.