Activity log for bug #294547

Date Who What changed Old value New value Message
2008-11-06 05:51:19 Richard Laager bug added bug
2008-11-06 05:51:59 Richard Laager None: bugtargetdisplayname Ubuntu fast-user-switch-applet (Ubuntu)
2008-11-06 05:51:59 Richard Laager None: bugtargetname ubuntu fast-user-switch-applet (Ubuntu)
2008-11-06 05:51:59 Richard Laager None: statusexplanation
2008-11-06 05:51:59 Richard Laager None: title Bug #294547 in Ubuntu: "User Switcher Applet (FUSA) icons do not match Pidgin" Bug #294547 in fast-user-switch-applet (Ubuntu): "User Switcher Applet (FUSA) icons do not match Pidgin"
2008-11-06 05:52:28 Richard Laager bug added subscriber Wiktel
2008-12-02 01:01:21 Endolith fast-user-switch-applet: status New Confirmed
2008-12-02 01:01:21 Endolith fast-user-switch-applet: statusexplanation Yes, this is annoying
2008-12-12 01:26:43 Richard Laager bug assigned to pidgin
2008-12-12 01:34:40 Richard Laager fast-user-switch-applet: status Confirmed Invalid
2008-12-12 01:34:40 Richard Laager fast-user-switch-applet: statusexplanation Yes, this is annoying I spoke with Ted Gould today and he said this was because Pidgin doesn't follow the Freedesktop.org Icon Naming Spec: http://standards.freedesktop.org/icon-naming-spec/icon-naming-spec-latest.html Pidgin needs to rename the icons it installs to match the names in the icon-naming-spec. Then, it should use gtk_icon_theme_append_search_path() to append its directory to the end of the path (on GTK+ 2.4 and above) to provide the default icons if the user's theme doesn't define them. Then icons should be loaded with gtk_icon_theme_lookup_icon() on GTK+ 2.4 and above. (The fallback code can just load the icons from Pidgin's own directory.) On the Ubuntu side, once that is done, we'll want to ensure that the Human theme ships the nice Pidgin icons. ;)
2008-12-12 01:34:59 Richard Laager bug assigned to pidgin (Ubuntu)
2008-12-12 18:07:58 Richard Laager bug added subscriber Kenneth Wimer
2009-02-21 21:43:23 Luke Faraone fast-user-switch-applet: status Invalid Won't Fix
2009-02-21 21:43:23 Luke Faraone fast-user-switch-applet: statusexplanation I spoke with Ted Gould today and he said this was because Pidgin doesn't follow the Freedesktop.org Icon Naming Spec: http://standards.freedesktop.org/icon-naming-spec/icon-naming-spec-latest.html Pidgin needs to rename the icons it installs to match the names in the icon-naming-spec. Then, it should use gtk_icon_theme_append_search_path() to append its directory to the end of the path (on GTK+ 2.4 and above) to provide the default icons if the user's theme doesn't define them. Then icons should be loaded with gtk_icon_theme_lookup_icon() on GTK+ 2.4 and above. (The fallback code can just load the icons from Pidgin's own directory.) On the Ubuntu side, once that is done, we'll want to ensure that the Human theme ships the nice Pidgin icons. ;) These icons will not be changed in FUSA, we're using the official empathy icons from GNOME.
2009-12-22 14:02:19 Przemek K. bug watch added http://developer.pidgin.im/ticket/11031
2009-12-22 14:02:19 Przemek K. pidgin: importance Undecided Unknown
2009-12-22 14:02:19 Przemek K. pidgin: status New Unknown
2009-12-22 14:02:19 Przemek K. pidgin: remote watch Pidgin Trac #11031
2009-12-22 14:03:14 Przemek K. pidgin (Ubuntu): status New Fix Released
2009-12-22 14:03:19 Przemek K. pidgin (Ubuntu): status Fix Released Confirmed
2009-12-22 14:11:47 Bug Watch Updater pidgin: status Unknown New
2009-12-23 13:11:58 Bug Watch Updater pidgin: status New Confirmed
2014-07-31 15:38:24 Adolfo Jayme bug watch added http://developer.pidgin.im/ticket/856
2014-07-31 15:38:24 Adolfo Jayme pidgin: status Confirmed Unknown
2014-07-31 15:38:24 Adolfo Jayme pidgin: remote watch Pidgin Trac #11031 Pidgin Trac #856
2014-07-31 15:38:41 Adolfo Jayme pidgin (Ubuntu): importance Undecided Low
2014-07-31 15:38:46 Adolfo Jayme pidgin (Ubuntu): status Confirmed Triaged
2014-07-31 15:38:52 Adolfo Jayme bug task deleted fast-user-switch-applet (Ubuntu)
2014-07-31 15:39:10 Adolfo Jayme bug watch removed http://developer.pidgin.im/ticket/11031