[intrepid] pidgin doesn't save new contacts into the remote server (msn)

Bug #282683 reported by Daniel Queirolo
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Pidgin
Fix Released
Unknown
pidgin (Ubuntu)
Low
Unassigned
Declined for Intrepid by Sebastien Bacher

Bug Description

Binary package hint: pidgin

When adding a new buddy using the msn protocol, pidgin doesn't save the new contact to the msn server, so the next time you start up pidgin a dialog popups saying:

---------->
Buddy list synchronization issue in <email address hidden> (MSN)

<email address hidden> on the local list is inside the group "SomeGroup" but not on the server list. Do you want this buddy to be added?
<----------

Answering yes results in no synchronization done. Next time the same dialog popups.

Revision history for this message
Fernando Miguel (fernandomiguel) wrote :

This has been fixed uptream.
http://developer.pidgin.im/wiki/ChangeLog

    * MSN
          o Operations (such as moving to a new group) on contacts that were added in the same session should now complete correctly, and not cause synchronization errors at next login.
          o Minor fixes to login process during a server transfer.
          o Restored the "Has You" feature to the MSN protocol tooltips.
          o ADL 205/214/etc errors should no longer prevent login.

Can some dev get the patch and add it before release?

Thanks in advance

Revision history for this message
StefanPotyra (sistpoty) wrote :

unsubscribing motu-release. pidgin is in main.

Revision history for this message
Fernando Miguel (fernandomiguel) wrote :

Yes I noticed that right after I subscribed the team, but I dont have the privileges to remove a team.

Revision history for this message
Steve Langasek (vorlon) wrote :

if you've subscribed ubuntu-release to this in order to request a freeze exception, please provide the information requested by <https://wiki.ubuntu.com/FreezeExceptionProcess>.

Note that it is unlikely that this will be accepted prior to release; this is more likely a candidate for an SRU instead.

Changed in pidgin:
status: New → Incomplete
Revision history for this message
Fernando Miguel (fernandomiguel) wrote :

I dont have the skills do to it, but since there is a LP team to manage Pidgin, I suppose they are more than capable of doing so.
At least I expect that from them, since this is a nasty bug, that is now fixed upstream.

Revision history for this message
Frantique (undernetangel) wrote :

In 2.5.2 version the problem remained the same.

Revision history for this message
Fernando Miguel (fernandomiguel) wrote :

Olá Frantique e a todos.

On Friday 31 October 2008 12:50:57 Frantique wrote:
> In 2.5.2 version the problem remained the same.

Yes it does.... quite annoying.
But even the windows version as the same problem.

--
BUGabundo :o)
(``-_-´´) http://LinuxNoDEI.BUGabundo.net
Linux user #443786 GPG key 1024D/A1784EBB
My new micro-blog @ http://BUGabundo.net

Revision history for this message
Frantique (undernetangel) wrote :

Some progress, folks? I have a huge list of contacts, and it is not funny to start every day with clicking 100 times that OK button...

Revision history for this message
Daniel Queirolo (danf-1979) wrote :

 I think you can use this workaround: close pidgin, delete ~/.purple/blist.xml, install amsn, synchronize using amsn, close amsn, open pidgin.

Revision history for this message
Matias (falle) wrote :

Hi Everyone,

I was able to get rid of this quite annoying problem by following the workaround provided on the Pidgin developer website ( http://developer.pidgin.im/wiki/Protocol%20Specific%20Questions#WhydoIkeepgettingaBuddyListSynchronizationerror ):

"In order to fix this, you need to login to your account via Hotmail or similar (not the web messenger), go to your address book, edit the contact that matches, and check the box for "Use this address with Windows Live Messenger".

More discussion on this bug can be found in Pidgin ticket #6808: http://developer.pidgin.im/ticket/6808

Matias

Revision history for this message
Fernando Miguel (fernandomiguel) wrote :

Matias, you do know that many of us dont have an email on Hotmail, right?
I dont even have and MSN/Hotmail address.

That is no fix.

Revision history for this message
Frantique (undernetangel) wrote : How I fixed this...

I know that it is annoying to use an another IM client, but:

0. I have installed aMSN.
1. I started aMSN,
2. I made the modifications, after
3. I closed aMSN,
4. I have deleted the ~/.purple/blist.xml file.
5. Finally I have started Pidgin, and everything was just fine.

Additional information:
In my case the list got corrupted when I tried to move the contacts from
one group to another: I've got the sync error.

Regards: Frantique

Revision history for this message
Daniel Queirolo (danf-1979) wrote : Re: [Bug 282683] Re: [intrepid] pidgin doesn't save new contacts into the remote server (msn)

Is this bug known upstream? Maybe not...

2008/12/15 BUGabundo <email address hidden>

> Matias, you do know that many of us dont have an email on Hotmail, right?
> I dont even have and MSN/Hotmail address.
>
> That is no fix.
>
> --
> [intrepid] pidgin doesn't save new contacts into the remote server (msn)
> https://bugs.launchpad.net/bugs/282683
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in "pidgin" source package in Ubuntu: Incomplete
>
> Bug description:
> Binary package hint: pidgin
>
> When adding a new buddy using the msn protocol, pidgin doesn't save the new
> contact to the msn server, so the next time you start up pidgin a dialog
> popups saying:
>
> ---------->
> Buddy list synchronization issue in <email address hidden> (MSN)
>
> <email address hidden> on the local list is inside the group "SomeGroup" but
> not on the server list. Do you want this buddy to be added?
> <----------
>
> Answering yes results in no synchronization done. Next time the same dialog
> popups.
>

Changed in pidgin:
status: Unknown → New
Changed in pidgin (Ubuntu):
importance: Undecided → Low
status: Incomplete → Triaged
Changed in pidgin:
status: New → Unknown
Changed in pidgin:
status: Unknown → Fix Released
Revision history for this message
Simone Donadello (simone-donadello) wrote :

This is not fixed: I updated Pidgin to the 2.5.8 version trough PPA http://ppa.launchpad.net/pidgin-developers/ppa/ubuntu in Ubuntu 9.04, but the problem is still present... And it's quite annoying...
Regards

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.