Pidgin spell checker underlines every word if no dictionary is found

Bug #281842 reported by Jonathan Ernst on 2008-10-11
30
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Pidgin
Fix Released
Unknown
pidgin (Ubuntu)
Wishlist
Unassigned

Bug Description

Steps to reproduce :

1) Run pidgin with a locale where there is no dictionnary installed
2) Chat with a friend

Expected result :

Spell checking is disabled as no dictionnary is found

Actual result :

Every single word is underlined in red

Changed in pidgin:
status: Unknown → New
Matthew Lye (matthew.lye) wrote :

Confirmed on Ubuntu 8.10

Connor Imes (ckimes) wrote :

Thank you both for reporting and confirming this bug. According to the upstream comment
   "GtkSpell doesn't provide a way for us to distinguish when no dictionary is found. We can keep this ticket open, but there isn't a whole lot we can do about it."
it seems clear that this is a Wishlist bug since the functionality isn't actually there to begin with (to detect when dictionaries aren't present). I will mark it as so.

Changed in pidgin:
importance: Undecided → Wishlist
status: New → Triaged
Matthew Lye (matthew.lye) wrote :

Ahh well, not much can be done

Changed in pidgin:
status: New → Fix Released
Lars (brett) wrote :

Ha ha, the ironic thing here, is the sentence that describes the problem has poor spelling too.
Dictionary, LOL

So this problem is unfixable, I can't work it out, can we just install a dictionary?

summary: - Pidgin spell checker underlines every word if no dictionnary is found
+ Pidgin spell checker underlines every word if no dictionary is found
Lars (brett) wrote :

Fixed the comment, thats me done

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.