Pidgin crashed when adding a new contact

Bug #275629 reported by Miles Prower on 2008-09-28
38
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Pidgin
Fix Released
Unknown
pidgin (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: pidgin

Two configured accounts : WLM and XMPP. A new buddy using a @gmail adress added me - as I had no way of telling if he was using Jabber or Windows Live, I added him to the most popular protocol out there (WLM). Pidgin crashed. the same when adding a buddies with yahoo account

ProblemType: Crash
Architecture: i386
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/pidgin
NonfreeKernelModules: nvidia
Package: pidgin 1:2.5.0-0ubuntu2~hardy1
ProcAttrCurrent: unconfined
ProcCmdline: pidgin
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: pidgin
StacktraceTop:
 g_str_hash () from /usr/lib/libglib-2.0.so.0
 ?? () from /usr/lib/libglib-2.0.so.0
 pecan_contact_set_passport ()
 ?? () from /usr/lib/purple-2/libmsn-pecan.so
 msn_cmdproc_process_cmd ()
Title: pidgin crashed with SIGSEGV in g_str_hash()
Uname: Linux 2.6.24-21-generic i686
UserGroups: adm admin audio cdrom dialout dip floppy fuse lpadmin plugdev sambashare vboxusers video

Miles Prower (mprower) wrote :

StacktraceTop:?? ()
?? ()
?? ()
?? ()
?? ()

Thanks for your bug report. Please try to obtain a backtrace http://wiki.ubuntu.com/DebuggingProgramCrash and attach the file to the bug report. This will greatly help us in tracking down your problem.

Changed in pidgin:
importance: Undecided → Medium
status: New → Incomplete
Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to New. Thanks again!.

Changed in pidgin:
status: Incomplete → Invalid

it crashed when I'm adding a contact into my msn.

matthew@Priapus:~$ lsb_release -rd
Description: Ubuntu 8.10
Release: 8.10
matthew@Priapus:~$ LANG="C" apt-cache policy pidgin
pidgin:
  Installed: 1:2.5.2-0ubuntu1
  Candidate: 1:2.5.2-0ubuntu1
  Version table:
 *** 1:2.5.2-0ubuntu1 0
        500 http://ftp.twaren.net intrepid/main Packages
        100 /var/lib/dpkg/status

Changed in pidgin:
status: Invalid → New
Magnus S (magnuss) on 2009-01-26
Changed in pidgin:
status: New → Confirmed
Sebastien Bacher (seb128) wrote :
Changed in pidgin (Ubuntu):
status: Confirmed → Triaged
Changed in pidgin:
status: Unknown → New
Changed in pidgin:
status: New → Fix Released
david (eaaeduph) on 2009-09-09
description: updated
david (eaaeduph) wrote :

Hi,,, I am using a Pidgin 2.6.1 and Ubuntu 8.04. when my friend is adding me and as I authorize her and add some details about her then putting her email to a certain group after clicking Add pidgin crashes down (I'm pertaining to yahoo account) the same problem even of I did not put it in a group. I also try that I am the one adding a friend but the pidgin still crashes. Need a immediate reply. Thank you

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.