sametime most online contacts marked offline

Bug #272108 reported by arturj on 2008-09-19
40
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Pidgin
New
Unknown
pidgin (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: pidgin

I sometimes use Pidgins Sametime Plugin to connect to our corperate sametime server. Using original sametime client I subscribed to some user-GROUPS. All contacts within this groups do automatically show up when online in original sametime client. Now using Pidgin all subscribed groups also do show up, but MOST contacts do show up as offline / do not show up when offline contacts are disabled (I have verified with original client that this people indeed are online). Over time more and more people get displayed correctly as online (I guess when their clients update their online status or when they generate any messages). It seems that Pidgin does not actively get the stati of people but rely on beeing notified by the server.

ProblemType: Bug
Architecture: i386
Date: Fri Sep 19 13:59:06 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/pidgin
Package: pidgin 1:2.5.0-0ubuntu2~hardy1
PackageArchitecture: i386
ProcEnviron:
 PATH=/home/username/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: pidgin
Uname: Linux 2.6.24-19-generic i686

arturj (arturj-freenet) wrote :

Same thing happening here. Some online users appear offline. As time goes on, the already online contacts go appearing online to me. This bug comes since gaim.

Magnus S (magnuss) on 2008-12-24
Changed in pidgin:
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

There is a similar bug on http://developer.pidgin.im/ticket/8134

Changed in pidgin (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
Changed in pidgin:
status: Unknown → New
EclipseAgent (ben-kevan) wrote :

I can also confirm this bug. If they change their status, then they will come back online so it has something to do with status changing..

Can we move this from low to medium? It's quite cumbersome especially if you expect to have a strong Enterprise client.

Changed in pidgin:
status: New → Unknown
Changed in pidgin:
status: Unknown → New
EclipseAgent (ben-kevan) wrote :

This works for me in

Pidgin 2.6.1 with meanwhile 1.0.2

Dilkington (dilkington) wrote :

This is still an issue for me
Jaunty
Pidgin 2.6.2
meanwhile 1.0.2-3

Incidently I also get the same issue with Kopete 0.70.2

EclipseAgent (ben-kevan) wrote :

Dilkington:

The reason it is in both is because libpurple-meanwhile is shared between Pidgin and Kopete..

When I say it works for me.. I should have noted that it's with openSUSE 11.2 Milestone 7 / 8

Dilkington (dilkington) wrote :

ok - thanks for that.

One thing I can see is that it looks as though pidgin is using libmeanwhile1 - (open implementation) to connect to sametime. You reference libpurple-meanwhile - I am assuming these are not one in the same thing ?

From what I can make out libpurple-meanwhile is now part of the core pidgin install and the open source Meanwhile library is used by this. Am guessing you are saying that Kopete uses the same approach ?

EclipseAgent (ben-kevan) wrote :

I'm irritated that the developers haven't implemented this fix in pidgin for Ubuntu yet..

264752 < I've updated that bug report with the patch which was taken from the SUSE RPM's..

Jim Hodapp (jhodapp) wrote :

This is still a bug for me as well. Is there a fix for this yet? I'm using Ubuntu 10.04 against my corporate SameTime server.

EclipseAgent (ben-kevan) wrote :

Jim,

Sadly the Ubuntu bug squashing team decides not to fix the issue. Which is hard to understanding since they do so many downstream changes anyways.

The best fix is to either move to openSUSE or Fedora, where both work just fine for me.

I've even attached the following patch:

http://launchpadlibrarian.net/44591577/meanwhile-status.diff

That fixes the issue (I think that was made against early 2.6 versions).. It's just sad..

Gregory Youtz (greg-youtz) wrote :

Hi,

Am having the same problem..... was this bug ever fixed?

Thanks.

Jim Hodapp (jhodapp) wrote :

No, it is not fixed in 11.04 of Ubuntu. What I've done is compiled the source version of libmeanwhile and copied the .so over the one installed by the Ubuntu package. This fixes it for your local box, but of course needs to be reapplied every time the Ubuntu libmeanwhile package gets updated.

David Young (dove-young) wrote :

Seems this method fixed this problem.

http://b1mmer.com/linux/fix-for-sametime-pidgin-linux

Eugene Crosser (crosser) wrote :

This problem needs to be fixed in the 'meanwhile' package, reported as bug #264752

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.