Ubuntu

Pidgin description in Add/Remove Applications is overly geeky

Reported by Matthew Paul Thomas on 2008-08-20
32
This bug affects 4 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Low
Vish
pidgin (Debian)
New
Unknown
pidgin (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: pidgin

Ubuntu Intrepid alpha 3

1. Open Add/Remove Applications.
2. Search for "pidgin".
3. Read Pidgin's description.

What you see:

    Pidgin Internet Messenger
    graphical multi-protocol instant messaging client for X

    Pidgin is a graphical, modular Instant Messaging client capable of using AIM/ICQ, Yahoo!, MSN, IRC, Jabber, Napster, Zephyr, Gadu-Gadu, Bonjour, Groupwise, Sametime, SILC, and SIMPLE all at once.

    Some extra packages are recommended to use the core functionality present in most pidgin installations:
    * gstreamer0.10-plugins-base, gstreamer0.10-plugins-good
      - Sound support.

    More extra packages are suggested to use increased functionality:
    * gnome-panel | kicker | docker:
      - To use the system tray icon functionality (minimizing to an icon, having the icon blink when there are new messages, etc.)
    * evolution-data-server:
      - For interfacing with an Evolution address book
    * libsqlite3-0:
      - To use Contact Availability Prediction plugin

What you should see: A description that
* helps end users decide whether they want to install the program
* does not refer to "the core functionality present in most pidgin installations" (how am I supposed to know what that means?)
* does not use the phrase "more extra"
* does not refer to other packages by name, because searching Add/Remove Applications for those other packages does not find them, and because that's what Suggests and Recommends are for;
* does not use the phrase "system tray" (there's no such thing in Ubuntu).

A useful description might mention features Pidgin has that other IM programs do not, such as buddy pounces and plug-ins.

[Suggested description change]

Multi-protocol instant messaging client

Instant message all your friends in one place.

Pidgin is an easy to use and free chat client used by millions. Connect to AIM, MSN, Yahoo, and more chat networks all at once.

Supported chat networks:

    * AIM
    * Bonjour
    * Gadu-Gadu
    * Google Talk
    * Groupwise
    * ICQ
    * IRC
    * MSN
    * MySpaceIM
    * QQ
    * SILC
    * SIMPLE
    * Sametime
    * XMPP
    * Yahoo!
    * Zephyr

Changed in pidgin:
importance: Undecided → Wishlist
status: New → Confirmed
Nathan Handler (nhandler) wrote :

Thank you for reporting this bug Matthew. Would you mind suggesting a better description that should be used for the package? It will make it much easier on the developer that decides to patch this bug. Thanks in advance.

Changed in pidgin:
assignee: nobody → mpt
status: Confirmed → Incomplete
Changed in pidgin:
status: Incomplete → New
Sebastien Bacher (seb128) wrote :

did you get any suggestion there?

Greg (rylar22) wrote :

Several options:
"Exchange messages with friends, family, and colleagues online."
"Pidgen lets you talk online and in real-time with friends and family."
"Pidgen is easy to use free chat software used by millions"

Or from pidgin's website:
"A free chat client used by millions. Connect easily to MSN, Google Talk, Yahoo, AIM and other chat networks all at once."

Or

Instant message all your friends in one place.

Pidgin is an easy to use and free chat client used by millions. Connect to AIM, MSN, Yahoo, and more chat networks all at once.

Supported chat networks:

    * AIM
    * Bonjour
    * Gadu-Gadu
    * Google Talk
    * Groupwise
    * ICQ
    * IRC
    * MSN
    * MySpaceIM
    * QQ
    * SILC
    * SIMPLE
    * Sametime
    * XMPP
    * Yahoo!
    * Zephyr

Matthew Paul Thomas (mpt) wrote :

Greg's last suggestion looks great. Any volunteers to implement it? :-)

(One small point: the list should include "MSN / Windows Live Messenger", not just "MSN", to cater for people who search for it by its new name or by the previous "Windows Messenger" name.)

Changed in pidgin (Ubuntu):
assignee: Matthew Paul Thomas (mpt) → nobody
Josh Holland (jshholland) wrote :

I'll take this one on.

Changed in pidgin (Ubuntu):
status: New → In Progress
assignee: nobody → Josh Holland (jshholland)
tags: added: metadata
Josh Holland (jshholland) wrote :

Unassigning myself and forwarding upstream

Changed in pidgin (Ubuntu):
assignee: Josh Holland (jshholland) → nobody
Changed in pidgin (Debian):
status: Unknown → New
Vish (vish) on 2010-06-22
Changed in hundredpapercuts:
importance: Undecided → Low
milestone: none → maverick-round-9-sc-metadata
status: New → Triaged

If I read the patch to upstream right, this part is still left in on the first line: "graphical multi-protocol instant messaging client for X", which is still a geeky and hard to understand description, especially since I think some tools will use just this line (don't know about software center).

simple patch attached that greatly simplifies the package description based upon what pidgin's website says.

Vish (vish) on 2010-07-11
description: updated
tags: added: patch
Matthew Paul Thomas (mpt) wrote :

That patch is a great improvement. It would be even better if it eliminated the word "graphical", since that goes without saying.

Vish (vish) wrote :

@Spike Burch :
Could you forward the patch to debian? http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=561624

description: updated
Changed in hundredpapercuts:
status: Triaged → In Progress
Vish (vish) wrote :

Updated branch for maverick, as mentioned by Benjamin Drung on the previous merge.

Changed in hundredpapercuts:
assignee: nobody → Vish (vish)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pidgin - 1:2.7.3-1ubuntu2

---------------
pidgin (1:2.7.3-1ubuntu2) maverick; urgency=low

  [ K. Vishnoo Charan Reddy ]
  * debian/control:
   - Improve package description for pidgin (LP: #259793)
 -- Robert Ancell <email address hidden> Thu, 02 Sep 2010 17:29:43 +1000

Changed in pidgin (Ubuntu):
status: In Progress → Fix Released
Changed in hundredpapercuts:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.