Ubuntu

Nick changing in jabber chatrooms behaves weirdly

Reported by Edoardo on 2008-04-08
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
pidgin (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: pidgin

Ubuntu release: 7.10
Package: pidgin
Pidgin version: 1:2.2.1-1ubuntu4.1
Protocol: Jabber (XMPP)

The scene is:
- I've created and joined a new chatroom
- I've invited a contact in it and he got inside

Now, when I attempt to change my nick using the /nick command, I got my nick changed twice: first I got the nick I typed and then it switches back to the old one (my user name, the portion before the @ of my contact), like this:

miriam1904: /nick miriam
* miriam1904 is now known as miriam
* miriam is now known as miriam1904

This is what happens whenever I type "/nick miriam". I tried several times. Then, I tried with another nick, and this time I got:

miriam1904: /nick miri
* miriam1904 is now known as miri
* miri is now known as miriam1904
* miriam1904 is now known as miriam

My nick got changed first in "miri", then it got changed back in my user name (just like before) and then it got changed again in "miriam", the old nick I was trying to get!

I don't know if this cares: the chatroom was on a foreing server (i.e. not the one in wich I registered my contact).

ProblemType: Bug
Architecture: i386
Date: Wed Apr 9 00:02:02 2008
DistroRelease: Ubuntu 7.10
NonfreeKernelModules: nvidia
Uname: Linux shumenta 2.6.22-14-generic #1 SMP Tue Feb 12 07:42:25 UTC 2008 i686 GNU/Linux

Daniel T Chen (crimsun) wrote :

Is this symptom still reproducible in 8.10 or 9.04?

Changed in pidgin:
status: New → Incomplete
Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to New. Thanks again!.

Changed in pidgin:
status: Incomplete → Invalid
Chris H. (ahmshaegar) wrote :

Hello, I am experiencing this same exact bug right now. I have not tested with Ubuntu 9.04 yet, but as I am experiencing this bug on Windows XP with Pidgin 2.5.8, this leads me to believe that this is not Ubuntu-related, but rather something with Pidgin itself.

This is happening in a password-protected chatroom that I created a few hours ago on conference.jabber.org. My friend, who is on the same version of Pidgin on Windows Vista, is also experiencing this bug. It is intermittent, and there seems to be no trigger.

I realize that this is the launchpad for Ubuntu, but I was not able to find other reports of this bug through various search engines, so I'm posting this information here in hopes that the upstream devs get more info (since this seems to be a bug with Pidgin and not Ubuntu's build of Pidgin.)

In any case, I will test in Ubuntu 9.04 as soon as I can.

Vladimir Makhnychev (makhnich) wrote :

The same behavior in 10.04, Pidgin 2.6.6. Updated Pidgin to 2.7.9 and still the same bug.

nukul (nukulorrr) wrote :

Still present in Pidgin 2.10.0 (Debian unstable). Since Oneiric uses the same pidgin version, it is highly likely that the bug is present there, too.

Changed in pidgin (Ubuntu):
status: Invalid → New

can the other reporters of this bug verify if they are either using a google talk account (<email address hidden> or a google apps account) when this bug appears, or are you using an account on any other jabber server?

nukul (nukulorrr) wrote :

Yes I am using a Google account as XMPP account. I just tried with a jabber.ccc.de account and everything works great there. Seems to be a problem with Google XMPP...

Thomas Hotz (thotz) wrote :

Edoardo, could you please file a bug in the Pidgin bug tracker and then we resolve the bug upstream. Thank you!

Changed in pidgin (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers