pidgin 2.4 cannot resize text entry window

Bug #209553 reported by dfszb on 2008-03-31
44
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Pidgin
Won't Fix
Unknown
pidgin (Debian)
Invalid
Undecided
Unassigned
pidgin (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: pidgin

New pidgin, 2.4 has an ugly chat text entry window - it is 'dynamic', i.e resizes itself when 'it's needed', cannot be set by hand, seems to be limited to rows, etc. This is an unneded 'improvement' that should be fixed or made optional.

ProblemType: Bug
Architecture: i386
Date: Mon Mar 31 10:00:17 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/pidgin
NonfreeKernelModules: nvidia
Package: pidgin 1:2.4.0-1ubuntu1
PackageArchitecture: i386
ProcEnviron:
 PATH=/opt/home/username/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: pidgin
Uname: Linux 2.6.24-12-generic i686

dfszb (dnotob) wrote :

My pidgin doesn't have this issue under hardy. Although I have heard a number of people complaining about this in #ubuntu. So I will mark as confirmed

Changed in pidgin:
status: New → Confirmed
Sitsofe Wheeler (sitsofe) wrote :

Murat Güneş:
When you are duping bugs is it possible to avoid forward duping? I have to admit that this bug contained the links to other bug systems but I still think it's nicer to go back and "credit" the first reporter...

Murat Gunes (mgunes) wrote :

Sitsofe, that's the regular procedure, but with exceptions: if a newer report has a better description, that can be a reason to make it the master bug. Also note that the old duplicate was filed at a time when Pidgin 2.4 wasn't in Ubuntu and is actually not a legitimate report as such, as I noted in my comment.

Changed in pidgin:
status: Unknown → New
imjustabill (imjustabill) wrote :

I've noticed the same thing, just happened with a update this week.

LGB [Gábor Lénárt] (lgb) wrote :

I have this issue too. It's quite annoying, eg there is only a few pixel wide area for input till I start typing (reported as bug #201134 too, it seems), confirmed.

lgb@oxygene:~$ dpkg-query -W pidgin
pidgin 1:2.4.1-1ubuntu1

Changed in pidgin:
status: New → Won't Fix
DaveAbrahams (boostpro) wrote :

confirmed still a problem in the latest hardy beta updates

Andreas Berger (andreas-berger) wrote :

Still an issue in Hardy final. The text input area is 2 lines big and cannot be resized.

mat (toth-poczta) wrote :

I have the same problem, after upgrading from Gutsy to Hardy (final release).

This is intentional. Pidgin has been forked due to this issue.

Gustavo Veloso (gjmveloso) wrote :

Bad improvement!

Changed in pidgin:
status: Unknown → Confirmed
pranith (bobby-prani) wrote :

bring back the resize option. It is very problematic to use pidgin in its current form after updating to hardy.

Where are the developers and what is the further course of action???

Richard Laager (rlaager) wrote :

Some reports about this are really reports about a bug where the input area is basically zero pixels high. See bug #201134. Hopefully this is fixed in 2.4.1. If it's not, please let me know on that bug report.

Most objections we've seem upstream seem to deal with the text area being "too small". Some people have objected to the input area not being easily clickable. They don't realize (because it's non-obvious, but there's not much we can do about it) that clicking the message history area and typing will automatically move them to the input area. A few object to it resizing automatically at all.

To address this, an option for the minimum size of the text area has been added upstream. That should be in the next release and hopefully Ubuntu can pick up either the whole release or at least that patch. If you don't feel that option would be sufficient, please let me know *why* (explain your use case).

Changed in pidgin:
status: Confirmed → Fix Committed
Gustavo Veloso (gjmveloso) wrote :

But Ubuntu never upgrade applications version in your repositories. We can expect this fix when Intrepid comes out, in october... :-(

> an option for the minimum size of the text area

This does not address the underlying problem, which is that sometimes one wants to set the size manually. I cannot comprehend why this should not be an option, as it was before. Have it dynamically change size, that's great, but allow me to drag it bigger if I want, and then respect that choice. Regardless of whether this is truly considered a "bug", it's a severe behavior regression that should be fixed.

Richard Laager (rlaager) wrote :

Gustavo Veloso: I'm looking at doing a PPA with updated Pidgin packages soon.

Greg Sabino Mullane: Do you have an example of a use case where setting the minimum size is insufficient?

Leonid Romanov (agent-couper) wrote :

Richard Laager: for me, typing into such small area feels very uncomfortable. Its psychological thing: I feel restricted and want to enlarge the typing area to get some free space, even if I'm not going to use it. Its like having big rooms in your flat: of course, you can live in small and cramped flat assuming that you don't have much furniture, but is much more pleasing to live in flat that has big rooms and lot of free space.

Greg (greg-turnstep) wrote :

To expand on what Leonid said, I also like it larger because it controls the bottom of the main chat window above it, which I don't like to be too low. Having a larger area for my typing helps to visually distinguish the top area from the bottom area as well. I can understand if this was done for a security reason or something, but changing a program from offering an option to no longer offering it at all, is not the way to write software. It's a shame: I really like Pidgin and have been willing to overlook some of its other minor flaws and limitations, but this one just might cause me to abandon it in search of something else.

Alex Yurchenko (ayurchen) wrote :

Really, guys, get us back the old behaviour? Please? Pretty please?
Or, at least, explain, why was it changed?

Kari Scott (kari-scott) wrote :

This new feature looks and feels like a bug and is driving me crazy. I'd also like to have the old resize option back, please.

Didier Roche (didrocks) wrote :

Reading upstream, it's more a feature, and so, they Won't Fix this bug.
Change the status from Fix Commited to Won't Fix.

Changed in pidgin:
status: Fix Committed → Won't Fix
pranith (bobby-prani) on 2009-05-26
Changed in pidgin (Debian):
importance: Unknown → Undecided
status: Confirmed → New
status: New → Invalid
status: Invalid → Confirmed
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.