Ubuntu

Clicking notification panel icon doesn't switch desktops

Reported by Iain Lane on 2008-03-27
14
Affects Status Importance Assigned to Milestone
Gaim
Invalid
Unknown
Pidgin
Invalid
Unknown
metacity
Fix Released
Medium
metacity (Fedora)
Fix Released
Unknown
metacity (Ubuntu)
Low
Ubuntu Desktop Bugs
pidgin (Fedora)
Won't Fix
Unknown
pidgin (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: pidgin

laney@chicken:~$ lsb_release -rd
Description: Ubuntu hardy (development branch)
Release: 8.04

laney@chicken:~$ apt-cache policy pidgin
pidgin:
  Installed: 1:2.3.1-2ubuntu1
  Candidate: 1:2.3.1-2ubuntu1
  Version table:
 *** 1:2.3.1-2ubuntu1 0
        800 http://archive.ubuntu.com hardy/main Packages
        100 /var/lib/dpkg/status

When a message is received in Pidgin, the notification area icon flashes as expected. Clicking this icon in Gutsy always used to switch to the desktop with the IM window on and activate it. Clicking it now only shows the IM window in the window list. It does not switch to the desktop with it on, nor does it cancel the unread status.

Steps to repro:

1. Start a conversation with somebody
2. Switch to another desktop
3. When a message is received and the notification area icon is flashing, click it
4. The desktop is not switched to the one with the IM window, but the IM window now appears in window list.

Expected behaviour:

At 4, the desktop should switch and activate the IM window.

This is a regression from Gutsy.

Iain Lane (laney) on 2008-03-28
description: updated
Pedro Fragoso (ember) wrote :

Have you tried to reproduce this on pidgin 2.4 ?

pidgin:
  Installed: 1:2.4.0-1ubuntu1
  Candidate: 1:2.4.0-1ubuntu1
  Version table:
 *** 1:2.4.0-1ubuntu1 0
        500 http://archive.ubuntu.com hardy/main Packages
        100 /var/lib/dpkg/status

Iain Lane (laney) wrote :

Yes, I just did and it's still there. I'm wondering whether this is a problem in GNOME/Compiz, however; from reading this: http://developer.pidgin.im/ticket/2968

Nicholas J Kreucher (kreucher) wrote :

Similar here...

Now, in hardy, clicking on the icon doesn't move pidgin to the current desktop nor does it switch to the desktop pidgin is on (as the previous poster noted). Same for buddy list or flashing icon to show chat window.

So, to find a new message in an existing chat window, I now have to manually switch to the desktop the chat window is on; same for the buddy list. Quite annoying and frustrating :(

Seems to be a side effect of an Ubuntu added patch to metacity: 011_gnome_482354_attachment_104591.patch ... see: http://bugzilla.gnome.org/show_bug.cgi?id=482354#c46

Also, this got filtered to Pidgin's own tickets, in a bit of a heated argument:
http://developer.pidgin.im/ticket/5521

IMHO, the patch was a mistake, but not everyone will agree :)

To recompile metacity w/o the patch:
$ sudo apt-get install build-essential devscripts fakeroot
$ sudo apt-get build-dep metacity
$ apt-get source metacity
$ cd metacity-2.*/debian/patches
$ rm 011_gnome_482354_attachment_104591.patch
$ cd ../..
$ debchange --nmu "remove 011_gnome_482354_attachment_104591.patch"
$ dpkg-buildpackage -b -us -uc -rfakeroot
$ cd ..
$ sudo dpkg -i metacity*.deb

Restart GNOME, and volla, pidgin window focusing and workspace switching works again.

Changed in metacity:
status: Unknown → Confirmed
Changed in gaim:
status: Unknown → Fix Released
Changed in pidgin:
status: Unknown → Fix Released
Nicholas J Kreucher (kreucher) wrote :

Another option is to patch Pidgin to hack around the changes made to metacity... Pidgin bug 5521, above, has an example patch on how to do this with the Buddy List (assume a similar patch is needed for the chat window).

I think if Ubuntu keeps the metacity patch intact, it should then patch Pidgin to avoid this regression.

Iain Lane (laney) wrote :

FWIW, since the Ubuntu patch was released I've just modified my behaviour to click on the pulsing entry in the task bar instead of the tray icon. I agree with the arguments on the Pidgin bug about not fighting the DE, and it not really being an issue with Pidgin per se.

I guess what we want is for Metacity to provide for applications to say "Yes, I really do want to warp workspace/move my window here", which Pidgin could then implement/pref as necessary. For my particular use case - switching when someone messages me - I'm pacified by the patch as is to not consider this a major usability issue.

That's not to say that I don't see the value in modifying Metacity. Often I want to click on a tray icon to (say) switch to Rhythmbox which is up in another workspace, but this doesn't work, as an irritating side-effect of this patch. The current behaviour is OK, but IMHO it should only last for as long as absolutely necessary until a better solution can be found.

Changed in metacity:
status: Unknown → Invalid
Changed in pidgin:
status: Unknown → In Progress
Changed in gaim:
status: Fix Released → Invalid
Changed in pidgin:
status: Fix Released → Invalid
wheezer (mrnoblestone) wrote :

I realize this thread a bit stale, but this very topic is now being discussed at bugzilla.gnome by both metacity and pidgin devs. As one of those pidgin users that absolutely hates this new behavior, and wishes it worked in Ubuntu as it always did, I would be most grateful if someone from here could be there, to see if there is not some reasonable way to restore that behavior (so clicking on a buddy, warps the conversation window to the Buddy list's workstation and activates it)

The discussion is toward the bottom of this thread at gnome:
http://bugzilla.gnome.org/show_bug.cgi?id=482354

And my original discussion with pidgin people here:
http://www.nabble.com/Lost-workspace-function-with-Ubuntu-Hardy-tt18352855.html#a18462577

Changed in metacity:
status: Confirmed → In Progress
Biji (biji) wrote :

i experience this issue on intrepid also
(using compiz, gnome)

Nicholas J Kreucher (kreucher) wrote :

Removing the patch to metacity (see above) works only if you are not using compiz. The same annoying behavior now effects compiz (intrepid). I really don't understand the logic here. We have a blinking notification saying "click here! click me!" so you do, and seemingly nothing happens. For tomboy, you click the always present tomboy icon, select a note, and expect it to appear, always, period. This is enough to make newbies think Linux is totally broken and go back to Windows. *** sigh ***

Related bugs:
https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/217462
https://bugs.launchpad.net/tomboy/+bug/263656

PLEASE BRING BACK THE SANE BEHAVIOR OF ALLOWING WINDOWS TO SWITCH TO THE CURRENT DESKTOP!!!!!!!!!!!!!!!!

Nicholas J Kreucher (kreucher) wrote :

For an excellent overview of this issue (w/metacity), see:
http://blogs.gnome.org/metacity/2008/10/20/by-these-presents/

Changed in metacity:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Triaged
Changed in pidgin:
importance: Undecided → Low
status: New → Triaged
Changed in metacity:
status: In Progress → Fix Released
Pedro Villavicencio (pedro) wrote :

the metacity package containing the fix is already in jaunty, marking the task as fixed, thanks.

Changed in metacity:
status: Triaged → Fix Released
Changed in metacity:
status: Invalid → Fix Released
Changed in pidgin (Fedora):
status: In Progress → Won't Fix
Changed in metacity:
importance: Unknown → Medium
Mörgæs (moergaes) on 2013-11-24
Changed in pidgin (Ubuntu):
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.