Ubuntu

Pidgin Evolution Integration plugin should allow opt-out per-contact

Reported by Kent Nyberg on 2005-05-20
30
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Pidgin
New
Unknown
pidgin (Ubuntu)
Wishlist
Unassigned

Bug Description

I wanted to save contact-information for my self on evolutions contact (Well, it
might seem strange, but I wanted to have a simple vcard to attach to the mails
and for other reasons ). I added the information and save it. Then suddenly gaim
wanted to add my self to my contact list. I have the evolution plugin for gaim
loaded so it might not be so surprising, but shouldn't it then be possible to at
least mark the contact "dont add to Instant Messanger" or something, or mark it
"My self".
Its a very good thing to integrate desktop applications so its not that the
contact got added that I consider a bug, its that it seems impossible to add my
self to the contacts in evolution and not get it to be added to the instant
messanger (gaim). I can always remove my self manually from gaim, but then
everytime i edit my information in evolution, i get re-added.

Sebastien Bacher (seb128) wrote :

seems to be a gaim issue, reassigning.

Uphaar Agrawalla (uphaar) wrote :

I can confirm this behaviour. I got the same thing when adding myself to
Evolution's contact book. I specified Yahoo & AIM, and Gaim added me to both.

The real annoyance is that gaim keeps re-adding me whenever I edit the info.

Sebastien Bacher (seb128) wrote :

how does it feature work? It's supposed to open a gaim dialog when changing the
addressbook?

Uphaar Agrawalla (uphaar) wrote :

(In reply to comment #3)
> how does it feature work? It's supposed to open a gaim dialog when changing the
> addressbook?

Make sure you have the evolution integration plugin enabled in gaim
(tools->prefs->plugins)
after that, in evolution add a contact in the address book and specify your own
yim/aim id (the one which you are using in gaim).
save the entry - (a gaim dialog pops up the first time you do this) you can see
yourself online in your gaim buddy list :p

Uphaar Agrawalla (uphaar) wrote :

Perhaps it should be a more generic thing with gaim, that it should not add the
accounts that gaim is itself configured to use. That makes sense, as why would
someone add himself/herself to his/her own buddy list...

An upstream issue I guess?

Luke Schierer (lschiere) wrote :

adding yourself to your buddy list is a very reasonable thing to do in 1.x and
lower as it is the only way to display what state you are in. This will change
with 2.0.0, but there is no eta yet on that release.

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with latest updates or latest Ubuntu release? Thanks in advance.

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in gaim:
status: New → Invalid
Richard Laager (rlaager) on 2008-01-02
Changed in gaim:
status: Invalid → Confirmed
Richard Laager (rlaager) wrote :

Could someone please set the priority to wishlist?

William Grant (wgrant) on 2008-01-02
Changed in pidgin:
importance: Low → Wishlist
Changed in pidgin:
status: Unknown → New
Changed in pidgin:
assignee: seb128 → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.