pidgin keeps stealing focus from its own password dialog

Bug #157666 reported by Fergal Daly
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Gaim
Won't Fix
Undecided
Unassigned
Pidgin
Fix Released
Unknown
pidgin (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: pidgin

This can happen in many ways but a simple example is to have 2 accounts, #1 requires a password, #2 doesn't. While you're still typing in the password for #1, #2 logs in and pops up the chat window. Now your password is not being typed into the password box anymore. If you're really unlucky, #2 auto-joined a channel and you're sending the last half of your password to your IRC buddies.

I don't see a reason to ever steal the focus but especially not from the password dialogue.

Revision history for this message
Fergal Daly (fergal) wrote :

Since this bug has not been touched, I filed an upstream bug

http://developer.pidgin.im/ticket/4032

Changed in gaim:
status: Unknown → New
Richard Laager (rlaager)
Changed in pidgin:
importance: Undecided → Unknown
status: New → Unknown
Richard Laager (rlaager)
Changed in gaim:
status: New → Won't Fix
Changed in pidgin:
status: Unknown → New
Changed in pidgin:
status: New → Fix Released
Revision history for this message
Andreas Moog (ampelbein) wrote :

Is this still an issue? Upstream reports this as fixed.

Changed in pidgin:
status: New → Incomplete
Revision history for this message
Fergal Daly (fergal) wrote :

Kind of, the IRC window doesn't grab focus but now the Buddy List window does :(.

I'll go ping my upstream bug.

Revision history for this message
Andreas Moog (ampelbein) wrote :

Do you still experience this issue? I know that there was 6 months of silence here but as hundreds of bugs are filed every week, please forgive me for not following up.

Changed in pidgin (Ubuntu):
importance: Undecided → Low
Revision history for this message
Fergal Daly (fergal) wrote : Re: [Bug 157666] Re: pidgin keeps stealing focus from its own password dialog

Thanks for asking. I'm still stuck on dapper (!) for the next few
weeks and then will be on hardy. I'll let you know then.

Revision history for this message
Sebastien Bacher (seb128) wrote :

could you try on jaunty?

Revision history for this message
Fergal Daly (fergal) wrote :

Jaunty, no sadly I can't however I've finally got onto Hardy and it
seems that while the password box may disappear mid-typing, focus is
not shifted to an auto-login IRC channel which is the main problem.

Revision history for this message
Alex Mauer (hawke) wrote :

This is still a problem in Karmic, though for me the problem is one password dialog stealing focus from another.

Revision history for this message
rusivi2 (rusivi2-deactivatedaccount) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The package your reporting is updated and the issue should be reproducible with the live environment of the Desktop CD development release - Maverick Meerkat. It would help us greatly if you could test with it so we can work on getting it fixed in the next release of Ubuntu. You can find more about the development release at http://www.ubuntu.com/testing/. Thanks again and we appreciate your help.

Revision history for this message
Alex Mauer (hawke) wrote :

Yes, this is still a problem in Maverick.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.