Pidgin 2.2.0 Forgets Plugin Selections (Ubuntu Gusty x86 Tribe 5)

Bug #144122 reported by Ron Adams on 2007-09-22
28
Affects Status Importance Assigned to Milestone
pidgin (Ubuntu)
Undecided
Amanda
Nominated for Hardy by Manuel Bärenz
Gutsy
Undecided
Unassigned

Bug Description

Binary package hint: pidgin

1) Open Pidgin
2) Select Plugins
3) Close Pidgin
4) Open Pidgin. Plugin selections are forgotten, preferences remembered.

Additionally:
-My prefs.xml: http://pastebin.org/3072
-When I select additional plugins, they correctly appear in prefs.xml under "loaded"

This seems to occur whether Pidgin crashes or is closed correctly.

Related branches

soul4arg (soul4arg) wrote :

Also in Ubuntu Gutsy 20070919 built.
Plugins appears to be in /usr/lib/purple-2/ and not in ~/.purple/plugins as I thought.

Ron Adams (tohuw) wrote :

!confirm location of plugins: /usr/lib/purple-2/

This does not seem to occur under Gusty amd64 Tribe 4-5 (tested previously, confirmed independently).

Can anyone confirm this, and perhaps show a compdiff of the prefs.xml, or some of the source?

soul4arg (soul4arg) wrote :

Unlikely to you confirmation, I am using Ubuntu Gutsy amd64 20070919 built. (Was it an older version of Pidgin in Tribe 4-5?)

I tried to copy /usr/lib/purple-2/*.so to ~/.purple/plugins

and also

edited the prefs.xml with the following lines under loaded:

<item value='usr/lib/purple-2/offlinemsg.so'/>
<item value='usr/lib/purple-2/autoaccept.so'/>

either way doesn't seem work anyways.

Ron Adams (tohuw) wrote :

A fix has been located. However, I am hesitant to call this issue closed. Let me explain:

I found a Tribe 5 x86 user with a working prefs.xml ("rsk" in #ubuntu+1). Checking his vs. mine, there was a very important difference:
  <pref name='plugins'>
   <pref name='loaded' type='pathlist'>
    <item value='/usr/lib/purple-2/autoaccept.so'/>
    <item value='/usr/lib/pidgin/notify.so'/>
    <item value='/usr/lib/purple-2/ssl-nss.so'/>
    <item value='/usr/lib/pidgin/pidginrc.so'/>
    <item value='/usr/lib/purple-2/ssl.so'/>
   </pref>
  </pref>

Versus mine:
                <pref name='plugins'>
                        <pref name='loaded' type='stringlist'>
                                <item value='/usr/lib/pidgin/docklet.so'/>
                                <item value='/usr/lib/pidgin/notify.so'/>
                        </pref>
                </pref>

Note that when I used his, new plugins would appear as loaded whenever I added some, or would be removed from the list when deselected. With mine, the list always appeared as above. Changing my type to pathlist would only make it revert, as would adding any plugins. What I finally had to do was change it to:

                <pref name='plugins'>
                        <pref name='loaded' type='pathlist'>

                        </pref>
                </pref>

After relaunching Pidgin, I could re-add the two items, and any plugins would automatically move in/out of the list as expected.

This fix was confirmed *to an extent* by a Fedora Core 7 user, Joseph Adams. He did NOT have docklet automatically added to his prefs. It is our suspicion that docklet.so may be the offending lib. Perhaps it was still being utilized/looked for after the closing of Pidgin, thus the forceful reversion to the non-working "stringlist" type? But why would that happen initially at all?

Keep in mind the second time I tested this was on a fresh install with no additional packages loaded.
What is this docklet.so? dpkg -S docklet.so returns no results, and with good reason: /usr/lib/Pidgin/docklet.so does not exist! There is some discussion on developer.pidgin.im about making Pidgin more aware and able to utilize X11's docklet. Can anyone provide more information about docklet.so, and any possible role it played in this issue?

Ron Adams (tohuw) wrote :

Talking with deryni in #pidgin on freenode, he indicated the root of the issue: /etc/purple/prefs.xml

The file there is the default prefs, and it's faulty. It needs to be fixed. Here is the pidgin-developer approved patch. This should replace that file. Note that docklet.so was an old plugin for the tray icon; it has been deprecated and should not appear in the prefs.xml at all.

I have included a patched pidgin-data.deb. The only file changed is the /etc/purple/prefs.xml.

The real question is: who else has this bad prefs, and why don't all Gusty users have it?

soul4arg (soul4arg) wrote :

Well done! Ron Adams. Thanks a lot for your help, though I think your newly-made deb pack doesn't work.

I've just changed "stringlist" to "pathlist" in both prefs.xml

Ron Adams (tohuw) wrote :

Odd... can someone verify? I'm not at home at the moment. If it doesn't work, then at least the prefs.xml is solid, and should be repackaged with pidgin-data..

Note that you should also remove the item "docklet.so".

A few last clarifying points:
The prefs.xml in /etc/purple/prefs.xml is just a template for default prefs (like when you create a new user, or delete your own prefs.xml in your home folder). Pidgin writes preference changes on a per-account basis, in ~/.purple/prefs.xml when the program closes. This is why I was initially so confused about the problem, because I thought the prefs.xml was changing correctly, but it was not. You can not change the prefs.xml with Pidgin open; it will revert. Also, this bug DOES affect ALL Gusty users: I believe those this did not happen to were users who had manually installed Pidgin or grabbed a .deb of it before upgrading to Gusty (when I was on amd64, this is what I had done). I believe this bug only affects those who will be installing Pidgin for the first time with Gusty.

This patch should be immediately applied to the appropriate repository.

Gelke (gbroersma-orange) wrote :

I had the same problem here (Gutsy tribe 5 with al the latest updates). I followed the instructions to change stringlist to pathlist and remove the existing items ( .purple/prefs.xml in the user home directory of course).

Problem is solved now!

Ron Adams (tohuw) wrote :

Glad it worked for you, Gelke. Don't forget to re-add notify.so; that plugin is still in active use.

Kalpik Nigam (kalpik) wrote :

Hmm.. Same problem exists in gutsy beta. Fix works though (changing "stringlist" to "pathlist"). I think this should be fixed before gutsy final!

Ron Adams (tohuw) wrote :

The attached .deb contains a patched .xml that should be used for Gusty final... don't forget to remove docklet.so... leaving deprecated plugins in "loaded" is bad code!

Whoopie (whoopie79) wrote :

here a patch for debian/prefs.xml

btw, thanks for the bug inverstigation, Ron.

Sebastien Bacher (seb128) wrote :

pidgin (1:2.2.1-1ubuntu2) gutsy; urgency=low

  * debian/prefs.xml:
    - changes from "Whoopie", don't load docklet.so and use
      "pathlist" rather than "stringlist", fix plugins selections (LP: #144122)

 -- Sebastien Bacher <email address hidden> Tue, 02 Oct 2007 14:43:30 +0200

Changed in pidgin:
status: New → Fix Released
Mikhail (mikhail.kalkov) wrote :

Thank you very much, for this bugreport and its solution. I've faced the same issue on Gutsy, and it got solved the way described above!

Dirk van Eß (moqwai) wrote :

Yes, solved, thanks a lot. Lets hope, it will be fixed until the release of Gutsy-final...

Ron Adams (tohuw) wrote :

This has already been patched successfully. Confirmed on a fresh Gusty install, fully updated. This bug report can be closed.

Justin Helgerson (ek0nomik) wrote :

Ron: I installed Gutsy Beta two days ago, and I just ran an update, and dist-upgrade, but my Pidgin plug-ins still aren't activate on load.

I haven't done the fix yet, but I don't think this has been completely resolved as my updates don't seem to have done the trick.

bb10 (bb10-10) wrote :

I can confirm this bug is still present in pidgin 1:2.2.1-1ubuntu3
Gonna install pidgin 1:2.2.1-1ubuntu4 now, but i don't expect it to be fixed in that version either, because it isn't mentioned in the changelog.

spec10 (spectator) wrote :

you're right bb10, ubuntu4 doesn't fix it. got it installed here, still got stringlist instead of pathlist in the prefs.xml

bb10 (bb10-10) on 2007-10-14
Changed in pidgin:
status: Fix Released → Incomplete
bb10 (bb10-10) on 2007-10-14
Changed in pidgin:
status: Incomplete → New
status: New → Confirmed
Will Thompson (wjt) wrote :

If a user already has a broken prefs.xml in ~/.purple, they'll still have problems even after a fixed default prefs.xml is installed.

Perhaps Gutsy's libpurple should be patched to check if prefs.xml is broken and fix it if so?

Whoopie (whoopie79) wrote :

You used a development version. If someone updated from feisty to gutsy when the final release was released or if you did a clean install, all is fine.

Changed in pidgin:
status: Confirmed → Fix Released
status: Confirmed → Fix Released
Colsta (colin-templeman) wrote :

I had installed Gutsy tribe 5 and can confirm I had this problem until I manually edited prefs.xml in accordance with instructions provided above. Now all settings are retained on reboot.

seqizz (gurkanGur) (seqizz) wrote :

2.2.2 and hardy.. same problem :\ weird..

fixed : "string" to "path"..

Manuel Bärenz (turion) wrote :

I have 2.4.1 on Hardy with updates, and the problem appears again, reproducable.
I applied the patch given in this thread, effectless. In my prefs.xml, it already says "pathlist", so this can't be it either. I think the bug should be reopened.

Changed in pidgin (Ubuntu):
assignee: nobody → Amanda (butterflystar212)
Edrihan Esc (edrian2009) wrote :

Quisiera que alguien me ayudara a saber... ¿porque no guarda la configuracion el editor de temas de pidgin? Utilizo Windows XP y Pidgin 2.7.11 me parece que es un error de certificado perooo... ¿cual es? lo agradecere infinitamente.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers