Pidgin Crashes when opened from Application Launcher Menu

Bug #1429796 reported by Clon on 2015-03-09
62
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Torchat
New
Undecided
Unassigned
pidgin (Ubuntu)
High
Unassigned

Bug Description

STEPS TO REPRODUCE
-------------------

1. Open Pidgin from the Application Launcher Menu.

EXPECTED RESULT
----------------

Pidgin starts without any problems.

ACTUAL RESULT
----------------

Pidgin Crashes.

NOTES
------

Lubuntu 15.04
Pidgin 2.10.9 (libpurple 2.10.9)

ProblemType: Crash
DistroRelease: Ubuntu 15.04
Package: pidgin 1:2.10.9-0ubuntu8
ProcVersionSignature: Ubuntu 3.19.0-7.7-generic 3.19.0
Uname: Linux 3.19.0-7-generic i686
ApportVersion: 2.16.2-0ubuntu1
Architecture: i386
CrashCounter: 1
CurrentDesktop: LXDE
Date: Mon Mar 9 12:02:45 2015
ExecutablePath: /usr/bin/pidgin
InstallationDate: Installed on 2013-03-16 (723 days ago)
InstallationMedia: Lubuntu 12.10 "Quantal Quetzal" - Release i386 (20121017.1)
ProcCmdline: pidgin
SegvAnalysis: Skipped: missing required field "Disassembly"
Signal: 11
SourcePackage: pidgin
UpgradeStatus: Upgraded to vivid on 2015-02-27 (9 days ago)
UserGroups: adm audio cdrom dialout dip disk fax floppy fuse lpadmin netdev plugdev sambashare scanner sudo tape video
---
ApportVersion: 2.17.2-0ubuntu1
Architecture: i386
CurrentDesktop: LXDE
DistroRelease: Ubuntu 15.04
InstallationDate: Installed on 2013-03-16 (786 days ago)
InstallationMedia: Lubuntu 12.10 "Quantal Quetzal" - Release i386 (20121017.1)
Package: pidgin 1:2.10.9-0ubuntu8
PackageArchitecture: i386
ProcVersionSignature: Ubuntu 3.19.0-16.16-generic 3.19.3
Tags: vivid
Uname: Linux 3.19.0-16-generic i686
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm audio cdrom dialout dip disk fax floppy fuse lpadmin netdev plugdev sambashare scanner sudo tape video
_MarkForUpload: True

Clon (fillip1) wrote :

StacktraceTop:
 ?? ()
 ?? ()
 ?? ()
 call_init (l=0xb935dd08, argc=8388608, argc@entry=1, argv=argv@entry=0xbfa28e44, env=env@entry=0xbfa28e4c) at dl-init.c:64
 call_init (env=0xbfa28e4c, argv=0xbfa28e44, argc=1, l=<optimized out>) at dl-init.c:36

Changed in pidgin (Ubuntu):
status: New → Invalid

Thank you for your report!

However, processing it in order to get sufficient information for the
developers failed (it does not generate a useful symbolic stack trace). This
might be caused by some outdated packages which were installed on your system
at the time of the report:

no debug symbol package found for gcc-5-base
no debug symbol package found for dmsetup
no debug symbol package found for libisc-export95
no debug symbol package found for gconf-service
sysvinit-utils version 2.88dsf-53.2ubuntu10 required, but 2.88dsf-53.2ubuntu11 is available
no debug symbol package found for multiarch-support
no debug symbol package found for libflac8
no debug symbol package found for libdevmapper1.02.1
no debug symbol package found for libirs-export91
no debug symbol package found for libperl5.20
no debug symbol package found for perl-base
sysv-rc version 2.88dsf-53.2ubuntu10 required, but 2.88dsf-53.2ubuntu11 is available
no debug symbol package found for xdg-user-dirs
no debug symbol package found for libgtkspell0
no debug symbol package found for debianutils
no debug symbol package found for libisccfg-export90
initscripts version 2.88dsf-53.2ubuntu10 required, but 2.88dsf-53.2ubuntu11 is available
no debug symbol package found for libdns-export100
no debug symbol package found for sed
no debug symbol package found for libtag1c2a
ca-certificates version 20141019ubuntu0.14.10.1 required, but 20141019 is available
no debug symbol package found for iproute2
no debug symbol package found for libgtkspell0

Please upgrade your system to the latest package versions. If you still
encounter the crash, please file a new report.

Thank you for your understanding, and sorry for the inconvenience!

tags: removed: need-i386-retrace

Sorry but i don't see any upgrades in up Synaptic or apt-get.
What i am do wrong?

Clon (fillip1) on 2015-03-17
information type: Private → Public
Clon (fillip1) on 2015-03-19
Changed in pidgin (Ubuntu):
status: Invalid → New

apport information

tags: added: apport-collected
description: updated

apport information

apport information

From terminal:
May 17 08:12:56.817 [W] plugin has been compiled with -dDebugToConsole. Not recommended.
May 17 08:12:57.004 [M] plugin loaded

(Pidgin:3211): Json-CRITICAL **: json_object_get_array_member: assertion 'node != NULL' failed

(Pidgin:3211): Json-CRITICAL **: json_array_get_length: assertion 'array != NULL' failed

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in pidgin (Ubuntu):
status: New → Confirmed
Courtenay (hdsheena) wrote :

home@home:~$ pidgin
/usr/share/themes/Lubuntu-default/gtk-2.0/apps/thunar.rc:55: error: invalid string constant "thunar-statusbar", expected valid string constant
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started
AL lib: (WW) alc_initconfig: Failed to initialize backend "pulse"
AL lib: (EE) UpdateDeviceParams: Failed to set 22050hz, got 48000hz instead
*** Error in `pidgin': free(): invalid pointer: 0x00007f6f1dfb7f50 ***
Aborted (core dumped)

Clon (fillip1) wrote :

After removing of torchat plug-in Pidgin start normal.

affects: torchat (Ubuntu) → torchat
Changed in pidgin (Ubuntu):
importance: Undecided → High
Gwendal (uqatkhti) wrote :

Hello,

I encounter a similar problem on Fedora 24:

$ pidgin

(Pidgin:4513): Json-CRITICAL **: json_array_get_length: assertion 'array != NULL' failed
Pidgin 2.11.0-1.fc24 has segfaulted and attempted to dump a core file.
This is a bug in the software and has happened through
no fault of your own.

If you can reproduce the crash, please notify the developers
by reporting a bug at:
http://developer.pidgin.im/simpleticket/

Please make sure to specify what you were doing at the time
and post the backtrace from the core file. If you do not know
how to get the backtrace, please read the instructions at
http://developer.pidgin.im/wiki/GetABacktrace
[1] 4513 abort (core dumped) pidgin

description: updated
summary: - Pidgin crash on start
+ Pidgin Crashes when opened from Application Launcher Menu
Qazi Omair Ahmed (omairqazi) wrote :

Thanks for the bug! I reported this bug to the Pidgin Upstream Bug Tracker (https://developer.pidgin.im/ticket/17279#ticket)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.