Pidgin IRC Color/Bold Codes Broken

Bug #141201 reported by Jason Smith on 2007-09-20
6
Affects Status Importance Assigned to Milestone
pidgin (Ubuntu)
Low
Unassigned
Declined for Gutsy by Sebastien Bacher

Bug Description

Binary package hint: pidgin

I'm sorry, but I don't know where else to report this. Some gutsy update in the past week or so has broken the IRC color and bold codes in Pidgin so that, for example, something in bold appears as NickServ and color codes come out similarly. It is broken in both Pidgin 2.1.1 and 2.2.0, but I don't know what broke it. Thanks.

Related branches

Same problem here. I've tried to enable/disable the "Conversation Colours" plugin (perhaps that's not the exact name in english, as I'm running an spanish localized system) without any improvement. I'm getting lines like:

(09:58:27) CIA-3: 03koen 07org.oe.dev * rcffa4cb4... 10/ (17 files in 5 dirs): packages/gnome: sync with poky, while maintaining OE tweaks like avahi and gnutls

Glyph Lefkowitz (glyph) wrote :

I just upgraded to gutsy and I see the same symptoms described here.

Russell Smith (mr-russ) on 2007-10-05
Changed in pidgin:
status: New → Confirmed
Jason Smith (sddfdds) wrote :

http://developer.pidgin.im/ticket/3467

Fixed upstream. Hopefully either the patch or the next version of Pidgin that comes out with the patch gets into Gutsy.

Jason Smith (sddfdds) wrote :

Sorry if assigning this is bad, but it looks like you might be the Pidgin maintainer. Thanks.

Changed in pidgin:
assignee: nobody → seb128
Sebastien Bacher (seb128) wrote :

Don't assign work to other people, that's not your job to decide what should be done by who, you can subscribe somebody though

Changed in pidgin:
assignee: seb128 → nobody
Sebastien Bacher (seb128) wrote :

That doesn't look like a gutsy blocker, piding is not really an IRC client and nobody else complained about that, doing a stable update fix after gutsy should be good enough

Changed in pidgin:
importance: Undecided → Low
Jason Smith (sddfdds) wrote :

Has Pidgin/Gaim ever been updated once the distro went stable? My fear that it hasn't or very infrequently hasn't is why I thought maybe it could/should sneak into Gutsy before it's final. Sorry about assigning it to you.

Sebastien Bacher (seb128) wrote :

If it has not been updated in stable that's probably because there was no bug wortha stable update which has been reported, not sure this one is one of those

Jason Smith (sddfdds) wrote :

Pidgin may not be a great IRC client, but unless I'm mistaken, it's the only one that ships by default with Ubuntu. It isn't really my place to say, but that does seem like it warrants a fix.

Sebastien Bacher (seb128) wrote :

pidgin (1:2.2.1-1ubuntu4) gutsy; urgency=low

  * debian/patches/80_from_upstream_fix_irc_formatting_issue.patch:
    - patch from upstream, fix an IRC formatting issue
      (LP: #141201)

 -- Sebastien Bacher <email address hidden> Wed, 10 Oct 2007 12:18:06 +0200

Changed in pidgin:
status: Confirmed → Fix Released
Jason Smith (sddfdds) wrote :

Thank you Sebastien

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.