Enable compilation of Unity messaging menu integration

Bug #1362368 reported by TomasHnyk on 2014-08-28
44
This bug affects 8 people
Affects Status Importance Assigned to Milestone
pidgin (Ubuntu)
Undecided
Unassigned

Bug Description

Pidgin has messaging menu integration since several releases, but it seems it is not compiled by default.

Please compile with --enable-unity

 libunity-dev and libmessaging-menu-dev are build dependencies then.

TomasHnyk (sup) wrote :

The code is well documented here for the curious and is over a year old! http://nevitus.com/2013/05/unity-integration-for-pidgin/

This plugin should be probably also turned on by default.

TomasHnyk (sup) wrote :

So, this line need s to be added to debian/prefs.xml under <pref name='plugins'> :
 <item value='/usr/lib/pidgin/unity.so'/>

TomasHnyk (sup) wrote :
TomasHnyk (sup) wrote :

bzr pulled a na out-of-date branch, so I am attaching a debdiff as per https://lists.ubuntu.com/archives/ubuntu-motu/2012-August/007318.html

The attachment "debdiff fixing the issue" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
TomasHnyk (sup) wrote :

Ah, build-depends need to be added to control file, not to .dcs file. Now it should actually build-depend on unity and messaging menu.

Daniel Holbach (dholbach) wrote :

You're missing a changelog entry in debian/changelog (use dch to create it for you), or use something like this:

pidgin (1:2.10.9-0ubuntu6) utopic; urgency=medium

  * d/control, d/rules, d/prefs.xml: Build with --enable-unity. (LP: #1362368)

 -- Tomas Hnyk (sup) <email address hidden> Tue, 02 Sep 2014 09:34:14 +0200

I noticed that no notify.so file is installed in any of the packages. Is this intentional? It's mentioned in debian/prefs.xml.

Changed in pidgin (Ubuntu):
status: New → Incomplete
TomasHnyk (sup) wrote :

Well, I tried to include changelog but apparently I run dch -i at the wrong moment. Anyway, it should be fixed now.

As for notify.so, it is provided by pidgin_2.10.9-0ubuntu6_amd64.deb:
$ apt-file search /usr/lib/pidgin/notify.so
pidgin: /usr/lib/pidgin/notify.so
pidgin-dbg: /usr/lib/debug/usr/lib/pidgin/notify.so

Also, it was there originally, I did not touch that line. True, it was meant to be turned on by default but it was not (that is what the line <pref name='loaded' type='pathlist'> does). It provides notifications about new messages, I think, quite a sensible thing to have turned on by default.

Changed in pidgin (Ubuntu):
status: Incomplete → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pidgin - 1:2.10.9-0ubuntu6

---------------
pidgin (1:2.10.9-0ubuntu6) utopic; urgency=medium

  * debian/control, debian/rules, debian/prefs.xml:
    Build with --enable-unity. (LP: #1362368)
 -- Tomas Hnyk (sup) <email address hidden> Tue, 02 Sep 2014 11:37:59 +0200

Changed in pidgin (Ubuntu):
status: Confirmed → Fix Released
Jorge Suárez de Lis (ys) wrote :

Sorry, I see what happened. It's only released for Utopic. Can this be backported to Trusty? Since it's a LTS, I think this fix should hit the repos.

Amr Ibrahim (amribrahim1987) wrote :

Could this be pushed as SRU to trusty?

tags: added: trusty
Amr Ibrahim (amribrahim1987) wrote :

Could someone from the Desktop team have a look at this for trusty? It needs only a re-compilation. Is it applicable for an SRU for trusty?

Amr Ibrahim (amribrahim1987) wrote :

Could this be SRUed to Trusty, please?

Amr Ibrahim (amribrahim1987) wrote :

Dear Dimitri John Ledkov,

Could you have a look at this and see if it can be SRUed to Trusty?

TomasHnyk (sup) wrote :

I do not think it qualifies for a SRU (it would be a new feature technically) and Pidgin is not installed by

TomasHnyk (sup) wrote :

installed by default.

Amr Ibrahim (amribrahim1987) wrote :

@TomasHnyk, in principle, yes, it would be a new feature, but it's not new code. The code already exists in the source. The feature just has to be enabled at compile time. Please correct me if I'm wrong.

Plus, the package is in main. That means it's maintained by the Desktop team.

Khurshid Alam (khurshid-alam) wrote :

It does not work on 16.04. By default, "hide chat" is set to never in preference. And it alaways bypasses messaging menu....openning new chat message directly.

 If I set it to "always",then again it makes the indicator blue, but fails to bring chat window focus when I click chat messages in messsging menu.

Compiz focus prevent comes into play if any fullscreen app running....then again it makes the indicator blue, but fails to bring chat window focus when I click chat messages in messsging menu. Naturally it doesn't work if I turn off focus prevention.

Btw, is it related to pidgin-libnotify plugin which provides similar function?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers