IRC Plugin unable to load

Bug #1128273 reported by Gary Allpike on 2013-02-17
30
This bug affects 4 people
Affects Status Importance Assigned to Milestone
pidgin (Ubuntu)
Undecided
Unassigned
Raring
Undecided
Unassigned

Bug Description

(01:58:27) plugins: /usr/lib/purple-2/libirc.so is not loadable: undefined symbol: sasl_client_step

IRC plugin is unable to load due to error above.

Seems to be related to this:

https://hg.pidgin.im/pidgin/main/rev/bbd52f93184e

Gary Allpike (garyallpike) wrote :

Sorry - forgot package version.

Version: 1:2.10.7-0ubuntu1

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in pidgin (Ubuntu):
status: New → Confirmed
Robbie Williamson (robbiew) wrote :

There appears to be a fix documented upstream:
   https://developer.pidgin.im/ticket/15517
"When building with SASL support, the IRC plugin needs to link against libsasl2, otherwise it will fail to load with the following error:
(03:20:54) plugins: probing /usr/lib/purple-2/libirc.so
(03:20:54) plugins: /usr/lib/purple-2/libirc.so is not loadable: undefined symbol: sasl_client_step
This is a new issue in Pidgin 2.10.7 since it's the first release that adds SASL support for IRC (​https://hg.pidgin.im/pidgin/main/rev/bbd52f93184e)."

Robbie Williamson (robbiew) wrote :

Attaching the patch from the upstream bug.

The attachment "Patch attached to the upstream bug filed for this problem" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Didier Roche (didrocks) wrote :

@Robbie: seems you didn't attach the patch (xml file? ;)), but thanks for the pointer to the upstream bug, stole the good patch, and confirmed, it fixes it on raring :)

Robbie Williamson (robbiew) wrote :

@Didier: Whoops...I blame Chrome Browser, cause it's easier than saying I messed up ;-). I've verified the fix as well, Thanks!!

Changed in pidgin (Ubuntu Raring):
status: Confirmed → Fix Released
status: Fix Released → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pidgin - 1:2.10.7-0ubuntu2

---------------
pidgin (1:2.10.7-0ubuntu2) raring; urgency=low

  * debian/patches/git_pidgin-fix-irc.patch:
    - upstream patch for being able to use IRC with pidgin for those kind
      of users… (LP: #1128273)
 -- Didier Roche <email address hidden> Thu, 21 Feb 2013 11:31:08 +0000

Changed in pidgin (Ubuntu Raring):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.