fetching URLs freezes pidgin

Bug #1108056 reported by Fernando Miguel on 2013-01-28
260
This bug affects 90 people
Affects Status Importance Assigned to Milestone
GLib
Fix Released
Medium
Pidgin
Unknown
Unknown
glib2.0 (Ubuntu)
Undecided
Unassigned
pidgin (Ubuntu)
Undecided
Unassigned

Bug Description

[Impact]

 * Pidgin in 13.04 is not working with our newer glib, startup is racy and hangs ~75% of the time.
   An explination of why is available here on the upstream bug https://developer.pidgin.im/ticket/15493#comment:27

[Test Case]

 * Boot 13.04
 * Add an AIM account in pidgin (most likely works for others but this is tested) and set it to auto connect
 * Close and start pidgin 10 times (be sure to use the buddies -> quit menu option)
 * If it does not hang even once it is fixed, if it does it is not.

[Original Message]

after about two weeks with Pidgin freezing on two different laptops, I made a brand new clean profile and this is what i get

$ pidgin -nddddddddddddm
(16:52:37) prefs: Reading /home/fernando/.purple/prefs.xml
(16:52:37) prefs: Reading /etc/purple/prefs.xml
(16:52:37) prefs: /pidgin/browsers/manual_command changed, scheduling save.
(16:52:37) prefs: removing pref /pidgin/browsers/command
(16:52:37) dbus: okkk
(16:52:37) plugins: probing /usr/lib/pidgin/ticker.so
(16:52:37) plugins: probing /usr/lib/pidgin/switchspell.so
(16:52:37) plugins: probing /usr/lib/pidgin/mystatusbox.so
(16:52:37) plugins: probing /usr/lib/pidgin/gestures.so
(16:52:37) plugins: probing /usr/lib/pidgin/convcolors.so
(16:52:37) plugins: probing /usr/lib/pidgin/listlog.so
(16:52:37) plugins: probing /usr/lib/pidgin/xmppconsole.so
(16:52:37) plugins: probing /usr/lib/pidgin/timestamp_format.so
(16:52:37) plugins: probing /usr/lib/pidgin/cap.so
(16:52:37) plugins: probing /usr/lib/pidgin/history.so
(16:52:37) plugins: probing /usr/lib/pidgin/xmppdisco.so
(16:52:37) plugins: probing /usr/lib/pidgin/vvconfig.so
(16:52:37) plugins: probing /usr/lib/pidgin/markerline.so
(16:52:37) plugins: probing /usr/lib/pidgin/libpidgin_pp.so
(16:52:37) plugins: probing /usr/lib/pidgin/pidgin-twitter.so
(16:52:37) plugins: probing /usr/lib/pidgin/irssi.so
(16:52:37) plugins: probing /usr/lib/pidgin/pidginrc.so
(16:52:37) plugins: probing /usr/lib/pidgin/themeedit.so
(16:52:37) plugins: probing /usr/lib/pidgin/enhancedhist.so
(16:52:37) plugins: probing /usr/lib/pidgin/notify.so
(16:52:37) plugins: probing /usr/lib/pidgin/expand.so
(16:52:37) plugins: probing /usr/lib/pidgin/pidgin-otr.so
(16:52:37) plugins: probing /usr/lib/pidgin/musicmessaging.so
(16:52:37) plugins: probing /usr/lib/pidgin/icon_override.so
(16:52:37) plugins: probing /usr/lib/pidgin/timelog.so
(16:52:37) plugins: probing /usr/lib/pidgin/extplacement.so
(16:52:37) plugins: probing /usr/lib/pidgin/iconaway.so
(16:52:37) plugins: probing /usr/lib/pidgin/difftopic.so
(16:52:37) plugins: probing /usr/lib/pidgin/plonkers.so
(16:52:37) plugins: probing /usr/lib/pidgin/xchat-chats.so
(16:52:37) plugins: probing /usr/lib/pidgin/nicksaid.so
(16:52:37) plugins: probing /usr/lib/pidgin/sepandtab.so
(16:52:37) plugins: probing /usr/lib/pidgin/pidgin-schedule.so
(16:52:37) plugins: probing /usr/lib/pidgin/album.so
(16:52:37) plugins: probing /usr/lib/pidgin/lastseen.so
(16:52:37) plugins: probing /usr/lib/pidgin/gtkbuddynote.so
(16:52:37) plugins: probing /usr/lib/pidgin/blistops.so
(16:52:37) plugins: probing /usr/lib/pidgin/gRIM.so
(16:52:37) plugins: probing /usr/lib/pidgin/spellchk.so
(16:52:37) plugins: probing /usr/lib/pidgin/convbadger.so
(16:52:37) plugins: probing /usr/lib/pidgin/sendbutton.so
(16:52:37) plugins: probing /usr/lib/pidgin/infopane.so
(16:52:37) plugins: probing /usr/lib/pidgin/timestamp.so
(16:52:37) plugins: probing /usr/lib/purple-2/groupmsg.so
(16:52:37) plugins: probing /usr/lib/purple-2/idle.so
(16:52:37) plugins: probing /usr/lib/purple-2/liboldtwitter.so
(16:52:37) plugins: probing /usr/lib/purple-2/buddynote.so
(16:52:37) plugins: probing /usr/lib/purple-2/libirc.so
(16:52:37) plugins: probing /usr/lib/purple-2/libjabber.so
(16:52:37) plugins: /usr/lib/purple-2/libjabber.so is not usable because the 'purple_init_plugin' symbol could not be found. Does the plugin call the PURPLE_INIT_PLUGIN() macro?
(16:52:37) plugins: probing /usr/lib/purple-2/libxmpp.so
(16:52:37) plugins: probing /usr/lib/purple-2/libgg.so
(16:52:37) plugins: probing /usr/lib/purple-2/listhandler.so
(16:52:37) plugins: probing /usr/lib/purple-2/libbonjour.so
(16:52:37) plugins: probing /usr/lib/purple-2/google.so
(16:52:37) plugins: probing /usr/lib/purple-2/capsnot.so
(16:52:37) plugins: probing /usr/lib/purple-2/libicq.so
(16:52:37) plugins: probing /usr/lib/purple-2/dice.so
(16:52:37) plugins: probing /usr/lib/purple-2/dewysiwygification.so
(16:52:37) plugins: probing /usr/lib/purple-2/simfix.so
(16:52:37) plugins: probing /usr/lib/purple-2/libstatusnet.so
(16:52:37) twitterim: plugin_init
(16:52:37) twitterim: plugin = 0x7f658884bd30
(16:52:37) plugins: probing /usr/lib/purple-2/oldlogger.so
(16:52:37) plugins: probing /usr/lib/purple-2/autoprofile.so
(16:52:37) autoprofile: general: Initializing AutoProfile
(16:52:37) autoprofile: general: Initializing preference defaults if necessary
(16:52:37) plugins: probing /usr/lib/purple-2/pidgin-libnotify.so
(16:52:37) plugins: probing /usr/lib/purple-2/libzephyr.so
(16:52:37) plugins: probing /usr/lib/purple-2/ssl.so
(16:52:37) plugins: probing /usr/lib/purple-2/libsnpp.so
(16:52:37) plugins: probing /usr/lib/purple-2/libmyspace.so
(16:52:37) plugins: probing /usr/lib/purple-2/perl.so
(16:52:37) plugins: probing /usr/lib/purple-2/libymsg.so
(16:52:38) plugins: /usr/lib/purple-2/libymsg.so is not usable because the 'purple_init_plugin' symbol could not be found. Does the plugin call the PURPLE_INIT_PLUGIN() macro?
(16:52:38) plugins: probing /usr/lib/purple-2/libaim.so
(16:52:38) plugins: probing /usr/lib/purple-2/irc-more.so
(16:52:38) plugins: probing /usr/lib/purple-2/ignore.so
(16:52:38) plugins: probing /usr/lib/purple-2/flip.so
(16:52:38) plugins: probing /usr/lib/purple-2/dbus-example.so
(16:52:38) plugins: probing /usr/lib/purple-2/autoaccept.so
(16:52:38) plugins: probing /usr/lib/purple-2/bash.so
(16:52:38) plugins: probing /usr/lib/purple-2/sslinfo.so
(16:52:38) plugins: probing /usr/lib/purple-2/libsimple.so
(16:52:38) plugins: probing /usr/lib/purple-2/newline.so
(16:52:38) plugins: probing /usr/lib/purple-2/libyahoojp.so
(16:52:38) plugins: probing /usr/lib/purple-2/tcl.so
(16:52:38) plugins: probing /usr/lib/purple-2/highlight.so
(16:52:38) plugins: probing /usr/lib/purple-2/libmxit.so
(16:52:38) prpl-loubserp-mxit: Loading MXit libPurple plugin...
(16:52:38) plugins: probing /usr/lib/purple-2/xmppprio.so
(16:52:38) plugins: probing /usr/lib/purple-2/libidentica.so
(16:52:38) twitterim: plugin_init
(16:52:38) twitterim: plugin = 0x7f6588877ef0
(16:52:38) plugins: probing /usr/lib/purple-2/offlinemsg.so
(16:52:38) plugins: probing /usr/lib/purple-2/libfacebook.so
(16:52:38) plugins: probing /usr/lib/purple-2/slashexec.so
(16:52:38) plugins: probing /usr/lib/purple-2/ssl-nss.so
(16:52:38) plugins: probing /usr/lib/purple-2/libnovell.so
(16:52:38) plugins: probing /usr/lib/purple-2/napster.so
(16:52:38) plugins: probing /usr/lib/purple-2/colorize.so
(16:52:38) plugins: probing /usr/lib/purple-2/twitgin.so
(16:52:38) plugins: probing /usr/lib/purple-2/joinpart.so
(16:52:38) plugins: probing /usr/lib/purple-2/libtwitter.so
(16:52:38) twitterim: plugin_init
(16:52:38) twitterim: plugin = 0x7f65888826d0
(16:52:38) plugins: probing /usr/lib/purple-2/autoreply.so
(16:52:38) plugins: probing /usr/lib/purple-2/libmsn.so
(16:52:38) plugins: probing /usr/lib/purple-2/log_reader.so
(16:52:38) plugins: probing /usr/lib/purple-2/libsametime.so
(16:52:38) plugins: /usr/lib/purple-2/libsametime.so has a prefs_info, but is a prpl. This is no longer supported.
(16:52:38) plugins: probing /usr/lib/purple-2/splitter.so
(16:52:38) plugins: probing /usr/lib/purple-2/libyahoo.so
(16:52:38) plugins: probing /usr/lib/purple-2/irchelper.so
(16:52:38) plugins: probing /usr/lib/purple-2/translate.so
(16:52:38) plugins: probing /usr/lib/purple-2/statenotify.so
(16:52:38) plugins: probing /usr/lib/purple-2/eight_ball.so
(16:52:38) plugins: probing /usr/lib/purple-2/liboscar.so
(16:52:38) plugins: /usr/lib/purple-2/liboscar.so is not usable because the 'purple_init_plugin' symbol could not be found. Does the plugin call the PURPLE_INIT_PLUGIN() macro?
(16:52:38) plugins: probing /usr/lib/purple-2/psychic.so
(16:52:38) util: Reading file xmpp-caps.xml from directory /home/fernando/.purple
(16:52:38) util: File /home/fernando/.purple/xmpp-caps.xml does not exist (this is not necessarily an error)
(16:52:38) jabber: creating hash tables for data objects
(16:52:38) status.net: plugin_load
(16:52:38) idcim: plugin_load
(16:52:38) twitterim: plugin_load
(16:52:38) tw_cmd: tw_cmd_init called
(16:52:38) tw_cmd: command replies registered
(16:52:38) tw_cmd: command refresh registered
(16:52:38) tw_cmd: command refresh_rate registered
(16:52:38) tw_cmd: command tag registered
(16:52:38) tw_cmd: command btag registered
(16:52:38) tw_cmd: command untag registered
(16:52:38) tw_cmd: command get registered
(16:52:38) prefs: /purple/status/scores/offline changed, scheduling save.
(16:52:38) prefs: /purple/status/scores/available changed, scheduling save.
(16:52:38) prefs: /purple/status/scores/invisible changed, scheduling save.
(16:52:38) prefs: /purple/status/scores/away changed, scheduling save.
(16:52:38) prefs: /purple/status/scores/extended_away changed, scheduling save.
(16:52:38) prefs: /purple/status/scores/idle changed, scheduling save.
(16:52:38) prefs: /purple/status/scores/offline_msg changed, scheduling save.
(16:52:38) util: Reading file accounts.xml from directory /home/fernando/.purple
(16:52:38) util: File /home/fernando/.purple/accounts.xml does not exist (this is not necessarily an error)
(16:52:38) util: Reading file status.xml from directory /home/fernando/.purple
(16:52:38) util: File /home/fernando/.purple/status.xml does not exist (this is not necessarily an error)
(16:52:38) certificate: CertificateVerifier x509, singleuse requested but not found.
(16:52:38) certificate: CertificateVerifier singleuse registered
(16:52:38) certificate: CertificatePool x509, ca requested but not found.
(16:52:38) certificate: CertificateScheme x509 requested but not found.
(16:52:38) certificate/x509/ca: Lazy init failed because an X.509 Scheme is not yet registered. Maybe it will be better later.
(16:52:38) certificate/x509/ca: Init failed, probably because a dependency is not yet registered. It has been deferred to later.
(16:52:38) certificate: CertificatePool ca registered
(16:52:38) certificate: CertificatePool x509, tls_peers requested but not found.
(16:52:38) certificate: CertificatePool tls_peers registered
(16:52:38) certificate: CertificateVerifier x509, tls_cached requested but not found.
(16:52:38) certificate: CertificateVerifier tls_cached registered
(16:52:38) prefs: /purple/logging/format changed, scheduling save.
(16:52:38) prefs: /purple/logging/format changed, scheduling save.
(16:52:38) prefs: /purple/proxy/type changed, scheduling save.
(16:52:38) prefs: /purple/proxy/host changed, scheduling save.
(16:52:38) prefs: /purple/proxy/port changed, scheduling save.
(16:52:38) prefs: /purple/proxy/username changed, scheduling save.
(16:52:38) prefs: /purple/proxy/password changed, scheduling save.
(16:52:38) certificate: CertificateScheme x509 requested but not found.
(16:52:38) certificate: CertificateScheme x509 registered
(16:52:38) util: Reading file smileys.xml from directory /home/fernando/.purple
(16:52:38) util: File /home/fernando/.purple/smileys.xml does not exist (this is not necessarily an error)
(16:52:38) stun: using server
(16:52:38) sound: Initializing sound output drivers.
(16:52:38) prefs: /pidgin/conversations/placement changed, scheduling save.
(16:52:38) prefs: purple_prefs_get_bool: Unknown pref /pidgin/docklet/x11/embedded
(16:52:38) gtkmedia: Registering media element types
(16:52:38) util: Reading file blist.xml from directory /home/fernando/.purple
(16:52:38) util: File /home/fernando/.purple/blist.xml does not exist (this is not necessarily an error)
(16:52:38) pounce: Error reading pounces: Failed to open file '/home/fernando/.purple/pounces.xml': No such file or directory
(16:52:38) Session Management: ICE initialized.
(16:52:38) Session Management: Connecting with no previous ID
(16:52:38) Session Management: Handling new ICE connection...
(16:52:38) done.
(16:52:38) Session Management: Connected to manager (gnome-session) with client ID 1055793915dc9a3fce135939195858211200000018230048
(16:52:38) Session Management: Using pidgin as command
(16:52:38) GLib-GObject: value "-2028232332" of type `gint' is invalid or out of range for property `weight' of type `gint'
(16:52:38) prefs: /purple/savedstatus/default changed, scheduling save.
(16:52:38) prefs: /purple/savedstatus/default changed, scheduling save.
(16:52:38) prefs: /pidgin/blist/list_visible changed, scheduling save.
(16:52:38) util: requesting to fetch a URL
Killed

s$ apt-cache policy pidgin
pidgin:
  Installed: 1:2.10.6-0ubuntu4
  Candidate: 1:2.10.6-0ubuntu4
  Version table:
 *** 1:2.10.6-0ubuntu4 0
        500 http://mirrors.fe.up.pt/pub/ubuntu/ raring/main amd64 Packages
        500 http://archive.ubuntu.com/ubuntu/ raring/main amd64 Packages
        100 /var/lib/dpkg/status

$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=13.04
DISTRIB_CODENAME=raring
DISTRIB_DESCRIPTION="Ubuntu Raring Ringtail (development branch)"

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: pidgin 1:2.10.6-0ubuntu4
ProcVersionSignature: Ubuntu 3.8.0-1.5-generic 3.8.0-rc4
Uname: Linux 3.8.0-1-generic x86_64
ApportVersion: 2.8-0ubuntu2
Architecture: amd64
Date: Mon Jan 28 17:00:47 2013
InstallationDate: Installed on 2012-06-10 (231 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120606.2)
MarkForUpload: True
SourcePackage: pidgin
UpgradeStatus: No upgrade log present (probably fresh install)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in pidgin (Ubuntu):
status: New → Confirmed

(29-01-2013 23:17:06) QuLogic: does ubuntu 13 use gtk3 yet?
(29-01-2013 23:18:16) freenode: QuLogic: seems both engines are available
(29-01-2013 23:19:11) QuLogic: but is it based on it primarily? then we may want to go directly to gsettings instead of through gconftool-2

Robert Bruce Park (robru) wrote :

Raring is definitely based primarily on Gtk3. There is a huge push to port all apps to Gtk3 and also to Python3. Gtk2 is deprecated, please stop using it in new code. You should definitely be using gsettings.

Thank you Robert.
I've passed the info to pidgin devs

(29-01-2013 23:59:56) datallah: FernandoMiguel: you may want to point them at http://hg.pidgin.im/pidgin/main/rev/98a6cc751323
(30-01-2013 00:00:15) datallah: hmm... actually that patch is in 2.10.6

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gconf2 (Ubuntu):
status: New → Confirmed

as per pidgin developers comments https://developer.pidgin.im/ticket/15493#comment:23
this seems to be a deeper issue in gsettings
$ ps -elf | grep -E "gsettings|gconftool-2"
0 Z fernando 9479 9443 0 80 0 - 0 exit 16:08 pts/4 00:00:00 [gsettings] <defunct>
0 S fernando 9567 9481 0 80 0 - 2361 pipe_w 16:08 pts/7 00:00:00 grep --color=auto -E gsettings|gconftool-2

Robert Hooker (sarvatt) wrote :

#0 0xb7fdd424 in __kernel_vsyscall ()
#1 0xb72b3dcb in poll () from /lib/i386-linux-gnu/libc.so.6
#2 0xb756924b in poll (__timeout=-1, __nfds=1, __fds=0x8087aeb0) at /usr/include/i386-linux-gnu/bits/poll2.h:46
#3 g_poll (fds=0x8087aeb0, nfds=1, timeout=-1) at /build/buildd/glib2.0-2.35.8/./glib/gpoll.c:132
#4 0xb755a610 in g_main_context_poll (n_fds=1, fds=0x8087aeb0, timeout=<optimised out>, context=0x808334e0,
    priority=<optimised out>) at /build/buildd/glib2.0-2.35.8/./glib/gmain.c:3995
#5 g_main_context_iterate (context=0x808334e0, block=block@entry=1, dispatch=dispatch@entry=1,
    self=<optimised out>) at /build/buildd/glib2.0-2.35.8/./glib/gmain.c:3696
#6 0xb755ab6b in g_main_loop_run (loop=loop@entry=0x80879a98)
    at /build/buildd/glib2.0-2.35.8/./glib/gmain.c:3895
#7 0xb75a0f01 in g_spawn_sync (working_directory=working_directory@entry=0x0, argv=0x80857028,
    envp=envp@entry=0x0, flags=flags@entry=G_SPAWN_SEARCH_PATH, child_setup=child_setup@entry=0x0,
    user_data=user_data@entry=0x0, standard_output=standard_output@entry=0xbfffcb18,
    standard_error=standard_error@entry=0xbfffcb1c, exit_status=exit_status@entry=0x0, error=error@entry=0x0)
    at /build/buildd/glib2.0-2.35.8/./glib/gspawn.c:434
#8 0xb75a1374 in g_spawn_command_line_sync (
    command_line=0xb74cc214 "gsettings get org.gnome.system.proxy mode", standard_output=0xbfffcb18,
    standard_error=0xbfffcb1c, exit_status=0x0, error=0x0) at /build/buildd/glib2.0-2.35.8/./glib/gspawn.c:735
#9 0xb7459e87 in ?? () from /usr/lib/libpurple.so.0
#10 0xb745a6b9 in purple_proxy_get_setup () from /usr/lib/libpurple.so.0
#11 0xb745aca7 in purple_proxy_connect () from /usr/lib/libpurple.so.0
#12 0xb4fea322 in ?? () from /usr/lib/purple-2/libjabber.so.0
#13 0xb4fea401 in ?? () from /usr/lib/purple-2/libjabber.so.0
#14 0xb746cda9 in ?? () from /usr/lib/libpurple.so.0
#15 0x8006dda7 in ?? ()
#16 0xb759edee in g_io_unix_dispatch (source=source@entry=0x8080c540, callback=0x8006dd50, user_data=0x805bf778)
    at /build/buildd/glib2.0-2.35.8/./glib/giounix.c:167
#17 0xb755a2f3 in g_main_dispatch (context=0x8010b200) at /build/buildd/glib2.0-2.35.8/./glib/gmain.c:3054
#18 g_main_context_dispatch (context=context@entry=0x8010b200)
    at /build/buildd/glib2.0-2.35.8/./glib/gmain.c:3630
#19 0xb755a690 in g_main_context_iterate (context=0x8010b200, block=block@entry=1, dispatch=dispatch@entry=1,
    self=<optimised out>) at /build/buildd/glib2.0-2.35.8/./glib/gmain.c:3701
#20 0xb755ab6b in g_main_loop_run (loop=0x807fc028) at /build/buildd/glib2.0-2.35.8/./glib/gmain.c:3895
#21 0xb79ed5c0 in gtk_main () from /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0
#22 0x80028aa2 in main ()

affects: gconf2 (Ubuntu) → glib2.0 (Ubuntu)
Pauli (paniemin) wrote :

Issue is in pidgin way of using depracated signal(2) and threads and forking with a race condition. Fix is commited for pidgin 3.0. See https://hg.pidgin.im/pidgin/main/rev/161320946afd

Robert Hooker (sarvatt) wrote :

I've put up packages with that commit backported here if anyone wants to try it

https://launchpad.net/~sarvatt/+archive/sru1

Robert Hooker (sarvatt) wrote :

It is working like a champ here, I've done ~100 startups and toggled wifi on and off a bunch of times (that also would make it hang) and have had no hangs at all.

Robert Hooker (sarvatt) wrote :

debdiff containing the fix targeting raring-proposed for SRU since we are past final freeze and its seeded in lubuntu.

pidgin (1:2.10.7-0ubuntu4.1) raring-proposed; urgency=low

  * Add hg-remove-SIGCHLD-handler.patch: Fix hanging on startup.
    Backport of upstream commit from 3.0 (LP: #1108056)

 -- Robert Hooker <email address hidden> Sat, 20 Apr 2013 15:40:16 -0400

tags: added: patch

$ sudo gdebi pidgin_2.10.7-0ubuntu5~lp1108056_amd64.deb libpurple0_2.10.7-0ubuntu5~lp1108056_amd64.deb pidgin-dbg_2.10.7-0ubuntu5~lp1108056_amd64.deb
Reading package lists... Done
Building dependency tree
Reading state information... Done
Building data structures... Done
Building data structures... Done
This package is uninstallable
Breaks existing package 'pidgin-dbg' dependency pidgin (= 1:2.10.7-0ubuntu4)

OK, not all packages were available when I tried!
now seems it upgraded fine.
so far it's working!
thanks

Robert Hooker (sarvatt) wrote :

you forgot pidgin-data and libpurple-bin

The attachment "pidgin_2.10.7-0ubuntu4.1.debdiff" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

bwat47 (bwat47) wrote :

@Rober Hooker

You are the man! patched packages from the ppa work great, I appreciate it!

yesterday was fine...
today it started freezing again :(

(23:21:09) util: requesting to fetch a URL
dns[11549]: nobody needs me... =(

Scott Kitterman (kitterman) wrote :

Robert Hooker: Please add the required elements for an SRU bug. I'm going to accept it into -proposed, but leave it there so it can be verified early. http://wiki.ubuntu.com/StableReleaseUpdates

Reed Loden (reed) wrote :

I just installed the new 1:2.10.7-0ubuntu4.1 packages, and I can confirm Pidgin now works for me.

zarquon42 (zarquon42) wrote :

@Rober Hooker
Awesome! No more freezes here :) All hail for the bug fixer. This was the major drawback of 13.04 for me.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pidgin - 1:2.10.7-0ubuntu4.1

---------------
pidgin (1:2.10.7-0ubuntu4.1) raring-proposed; urgency=low

  * Add hg-remove-SIGCHLD-handler.patch: Fix hanging on startup.
    Backport of upstream commit from 3.0 (LP: #1108056)
 -- Robert Hooker <email address hidden> Sat, 20 Apr 2013 15:40:16 -0400

Changed in pidgin (Ubuntu):
status: Confirmed → Fix Released
Robert Hooker (sarvatt) on 2013-04-23
description: updated

although most of my accounts don't cause it to lock, enabling Twitter plugin will *always* cause pidgin to hang

Reed Loden (reed) on 2013-04-25
tags: added: verification-done
nhorvath (nhorvath) wrote :

This issue still occurs to me with
Pidgin 2.10.7 (libpurple 2.10.7)
Installed from pidgin ppa on Ubuntu 13.04.

It may startup and run for a while then hang. If left for any extended period of time when I return it is hung.

bwat47 (bwat47) wrote :

@nhorvath, try using the official package instead of the pidgin developers ppa, I'm not sure if the ppa even has this patch...

it seems to be back
(Pidgin:4222): GLib-GIO-ERROR **: g_menu_item_set_detailed_action: Detailed action name 'im:prpl-irc:FernandoMiguel%40irc.ptnet.org:VIANETWORKS.ptnet.org' has invalid format
dns[4787]: Oops, father has gone, wait for me, wait...!
Trace/breakpoint trap
fernando@Bostro:~$ dns[4784]: Oops, father has gone, wait for me, wait...!
dns[4781]: Oops, father has gone, wait for me, wait...!
dns[4759]: Oops, father has gone, wait for me, wait...!

$ apt-cache policy pidgin
pidgin:
  Installed: 1:2.10.7-0ubuntu5~lp1108056
  Candidate: 1:2.10.7-0ubuntu5~lp1108056
  Version table:
 *** 1:2.10.7-0ubuntu5~lp1108056 0
        500 http://ppa.launchpad.net/sarvatt/sru1/ubuntu/ raring/main amd64 Packages
        100 /var/lib/dpkg/status
     1:2.10.7-0ubuntu4.1 0
        500 http://mirrors.fe.up.pt/pub/ubuntu/ saucy/main amd64 Packages
        500 http://archive.ubuntu.com/ubuntu/ saucy/main amd64 Packages

Ryan Davis (ryan-mokeys) wrote :

I tried the sru1 PPA, but it didn't work for me. I ended up with 2 pidgin processes (one of which was <defunct>), and no UI whatsoever. When I kill -HUP the living pidgin process, I'd get a quick flash of the buddy list window, and then everything would close down. pigden -d logs showed the "nobody needs me" dns message.

I tried ppa:pidgin-developers/ppa, which shows releases after the fix was committed, but I see the same UI freeze and <defunct> gsettings process as others:

$ apt-cache policy pidgin
pidgin:
  Installed: 1:2.10.7-2ubuntu0+pidgin1.13.04
  Candidate: 1:2.10.7-2ubuntu0+pidgin1.13.04
  Version table:
 *** 1:2.10.7-2ubuntu0+pidgin1.13.04 0
        500 http://ppa.launchpad.net/pidgin-developers/ppa/ubuntu/ raring/main amd64 Packages
        100 /var/lib/dpkg/status
     1:2.10.7-0ubuntu4.1 0
        500 http://us.archive.ubuntu.com/ubuntu/ raring/main amd64 Packages

If I run the ppa:pidgin-developers/ppa version of pidgin in an strace, it works fine, so that's a workaround for me.

$ strace pidgin

Changed in glib2.0 (Ubuntu):
status: Confirmed → Invalid
status: Invalid → Confirmed
Changed in glib:
importance: Unknown → Medium
status: Unknown → Fix Released
Changed in glib2.0 (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.