Empathy doesn't show bigbrownchunx-skype-dbus in the protocol list after installing pidgin-skype

Bug #970885 reported by KEIII on 2012-04-01
254
This bug affects 91 people
Affects Status Importance Assigned to Milestone
skype4empathy
Fix Committed
Undecided
Unassigned
empathy (Ubuntu)
Undecided
Unassigned
pidgin-skype (Ubuntu)
Undecided
Unassigned

Bug Description

I'm trying to connect to Skype throught Empathy 3.4 in Ubuntu 12.04 i386 (last update installed) I installed the pidgin-skype plugin, but there is no bigbrownchunx-skype-dbus protocol in list.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: empathy 3.4.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-21.34-generic 3.2.13
Uname: Linux 3.2.0-21-generic i686
ApportVersion: 2.0-0ubuntu2
Architecture: i386
Date: Sun Apr 1 19:30:35 2012
ExecutablePath: /usr/bin/empathy
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta i386 (20120328)
SourcePackage: empathy
UpgradeStatus: No upgrade log present (probably fresh install)

KEIII (cashagent) wrote :
Bilal Shahid (s9iper1) wrote :

i guess not a empathy bug that must be issue with the plugin and i dont think that the empathy supports skype.

Changed in empathy (Ubuntu):
status: New → Incomplete
KEIII (cashagent) wrote :
Vincenzo Mantova (xworld21) wrote :

I traced down the problem to one single call to the function "g_thread_init()" inside the package "pidgin-skype". As of the official glib documentation [1], the function is not needed anymore and it is deprecated from version 2.32 on, and apparently is disabled when telepathy-haze and empathy try to load the plugin.

I'm attaching a patch that comments out the call to g_thread_init. As far as I have tested it seems to work fine.

[1] http://developer.gnome.org/glib/2.31/glib-Deprecated-Thread-APIs.html#g-thread-init

The attachment "Remove call to g_thread_init" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch

How can I fix this in my Ubuntu 12.04, being a dummy user ?

Lee Hyde (anubeon) wrote :

Judging by Vincenzo's comments (and patch) this bug should be filed against pidgin-skype rather than empathy.

affects: empathy (Ubuntu) → pidgin-skype (Ubuntu)
Changed in empathy (Ubuntu):
status: New → Incomplete
Eion Robb (eionrobb) wrote :

I've fixed this in upstream as revision 629 of the Skype plugin.

mmicotti (marco-micotti) wrote :

I am affected too from this bug in Ubuntu Precise. How can I replace the current version of pidgin-skype with the patched one? I checked on the Eion Robb website and I guess I have to compile sources in the ${PIDGIN_SOURCE}/libpurple/plugins/ directory , but I am not able to find it ..

Gtridr (gtridr) wrote :

so should this be coming through the miltiverse release channel soon?

kroq-gar78 (kroq-gar78) wrote :

I marked the status in skype4empathy as "Fix Committed" because of Eion Robb's comment that he fixed it in r629 of upstream. I'll also mark the status of affecting the package "empathy" in Ubuntu as invalid as per Lee Hyde's comment.

Changed in skype4empathy:
status: New → Fix Committed
Changed in empathy (Ubuntu):
status: Incomplete → Invalid
Mark (mark-wege) wrote :

Will the package be updated soon? The bug also affects KDEs telepathy implementation.

George Moutsopoulos (gmoutso) wrote :

This also affects telepathy.

Without commit revision 629 upstream, telepathy cannot create a skype account with telepathy-haze. Actually it shows a skype option under "telepathy create account.. other" but the window is empty and an error is produced on pressing OK.

I installed the libskypeso64.so and make libskype_dbus64.so by:

svn checkout http://skype4pidgin.googlecode.com/svn/trunk/ skype4pidgin-read-only
cd skype4pidgin-read-only/
sudo apt-get install libpurple-dev
kate Makefile
   remove -pc- from compiler in first lines, add
   add the following to the GLIB_CFLAGS in the make file: -I/usr/lib/x86_64-linux-gnu/glib-2.0/include/ -I/usr/lib/x86_64-linux-gnu/dbus-1.0/include/
make libskype64.so
make libskype_dbus64.so
sudo cp
sudo cp *so /usr/lib/purple-2/

Now texting almost works (some lines are missed) and voice/audio cannot be called, but this might be a telepathy bug.

George Moutsopoulos (gmoutso) wrote :

I should add something on my comment #13. All I know is that, before making libskype64.so and libskype_dbus64.so, telepathy would not create a skype account. When I coppied the two files in /usr/lib/purple-2/, there were no such files before, only libskype.so and libskype_dbus.so. Kopete worked ok with skype. So I might have been wrong, and what I did hasn't got to do with this bug. Should I file a new bug?
https://code.google.com/p/skype4pidgin/issues/detail?id=193

Mark (mark-wege) wrote :

Followed the instructions in comment #13. It works. So basically it is a problem of updating the package. I have added the tag needs-packaging.

tags: added: needs-packaging
papukaija (papukaija) on 2012-10-16
summary: - Empathy 3.4 and pidgin-skype
+ Empathy doesn't show bigbrownchunx-skype-dbus in the protocol list after
+ installing pidgin-skype
papukaija (papukaija) wrote :

I opened bug 1067506 to get a newer version of this package to the repositories. I created a new bug as the new version has other changes too. I'm removing the needs-packaging tag since it's not used for package updates. Please see https://wiki.ubuntu.com/Bugs/Tags for more details.

tags: added: quantal
removed: needs-packaging third-party-packages
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pidgin-skype - 20121029+svn639+dfsg-1

---------------
pidgin-skype (20121029+svn639+dfsg-1) unstable; urgency=low

  * New upstream snapshot (LP: #970885, #1067506).
  * Switch to compat 9.
    + Remove hardening-wrapper B-D.
  * Add VCS-* fields.

 -- Gabriele Giacone <email address hidden> Mon, 29 Oct 2012 14:44:59 +0100

Changed in pidgin-skype (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.