Empathy won't let to add new Skype accounts (bigbrownchunx-skype-dbus)

Bug #567248 reported by ng on 2010-04-20
196
This bug affects 38 people
Affects Status Importance Assigned to Milestone
skype
New
Undecided
Unassigned
pidgin-skype (Ubuntu)
Undecided
Unassigned
Nominated for Lucid by aggiemarine07

Bug Description

Binary package hint: pidgin-skype

using:

ubuntu 10.04 (with all updates until today)
empathy 2.30.0.1-0ubuntu3
pidgin-skype 20100121+dfsg-1

problem:

in empathy there is a new option for new accounts, bigbrownchunx-skype-dbus, but i can not create the new account for skype.

(temporary) solution:

i noticed that with the skype4pidgin plugin bigbrownchunx-skype-dbus in empathy works. but i only wanted one program installed, empathy, and the plugin depends on pidgin. i changed the skype4pidgin.deb to install with empathy too, not needing pidgin anymore. it now only needs pidgin or empathy, thats the only thing i changed. now i have skype in empathy.

ng (ng-ngcorp) wrote :

one more information, skype doesn't autostart if empathy ist started.

besides that i wanted to say that i am not really a linux pro. so i am unable to say why it works or why pidgin-skype isn't. i only wanted to share my experience, maybe it is helpful for somebody. same for the solution i posted it is for sure not perfect, but it works for now (at least at my pc).

Elias N Vasylenko (vasylee7) wrote :

Cheers! Very helpful solution :) I can confirm that it works for me.

Marco Lackovic (marco-lackovic) wrote :

It doesn't seem to work here.

After doing the following steps:

- installed the plugin;
- opened Empathy;
- clicked on "Add" button;
- chosed "bigbrownchunx-skype-dbus" protocol;
- entered account name;
- pressed the "Apply" button;
- Skype opened requesting for password;
- signed in Skype successfully;

Empathy still shows a yellow banner with an icon of a pair of scissors, displaying the account name and "Connecting...".

Marc Backes (tuxly) wrote :

Same here... Skype starts, but Empathy keeps connecting with no result.

ng (ng-ngcorp) wrote :

like i said, i'am not really sure why it works. but for me it still works. maybe it works because i had installed skype4pidgin and pidgin-skype first. of course i uninstalled them, but maybe there are some dependencies left over, which are needed by skype4empathyandpidgin. i wish i could help you out more, but i cant...

pvanb (p-vanbreugel) wrote :

For me it works (thanks!), but only after I checked the 'Reject All Auths' in the account in empathy (advanced section).

Cheers

tags: added: patch
Nigel Babu (nigelbabu) wrote :

I've removed the patch tag, you haven't exposed the actual code you used in the temporary fix. If you could do that perhaps we can have it added to the package. Thank you for your contribution

tags: removed: patch
ng (ng-ngcorp) wrote :

o.k., what i did was to rebuild the package. therefor i wanted to change the dependencies of the original skype4pidgin package. those are inside the control file of the package.

original control file:

Package: skype4pidgin
Version: 2010-03-02
Section: net
Priority: optional
Architecture: all
Essential: no
Depends: pidgin (>= 2.1.1)
Maintainer: Eion Robb <email address hidden>
Description: Skype plugin for Pidgin. Requires Skype to be running.

new control file:

Package: skype4empathyandpidgin
Version: 2010-04-20
Section: net
Priority: optional
Architecture: all
Essential: no
Depends: empathy | pidgin (>= 2.1.1)
Maintainer: ng <ng@net>
Description: Skype4EmpathyandPidgin: I changed the Skype plugin for Pidgin (skype4pidgin - http://eion.robbmob.com/ - Eion Robb <email address hidden>) to install with empathy too. Now it needs Pidgin or Empathy. Requires Skype to be running. My Problem was that on Ubuntu 10.04 the pidgin-skype plugin doesn't work (for me) and the skype4pidgin plugin want's pidgin, but i wanted to use empathy in combination with skype without installing pidgin.

besides that i changed nothing else.

edde306 (bumbalo) wrote :

got skype running in empathy, but just with chat functionality. can't make a call!
also i need to start skype first and afterwards empathy to make it work.

i used ng's .deb package and install guide (first installed and removed skype4pidgin and pidgin-skype) on newest ubuntu update.

I made a patch of pidgin-skype to allow the use of X11 version (dbus version does not work for me under amd64) on empathy.
In my ppa: https://launchpad.net/~timothy-redaelli/+archive/drizzt

confirmed that it works for me as well. Wish that you could make/place a call from empathy like in pidgin. Hopefully in the next version I guess.

Peter Wagner (o-petris) wrote :

Managed to run Skype under Empathy afetr installing ng's package, but status was switching from online to can't connect on and on, no matter what Y choose for "Reject all auth's". When Y uncheck "Skypeout online" I become connected permanently, but now without VoIP facility (which is wy I switched to Empathy).

Keep on waiting for bether wheather
Peter

Oreolek (oreolek) wrote :

When I turn the Skype account on, my ICQ account turns off. The plugin is from 10.04 repo.

Zaphod (vilppu777) wrote :

I tried installing skype4pidgin from http://eion.robbmob.com/ but it looks like the site is down. Can someone post the deb file here?

Benjamin Schmid (benbuntu) wrote :

Trying to get Skype in Empathy working in Ubuntu 10.10 Maverick with Skype 2.1Beta. The plugin appears, but does not start skype nor attach to a running Skype instance when I try to add my account. Checked the docs but I did not find any hint about further configuration required.

Hello :-)

@Benjamin Schmid:
I have exactly the same problem. I have just re-installed from scratch a Maverick version, I have firstly tried the pidgin-skype package in the repository, but I have also tried the Skype4Pidgin.deb on the Eion website.

Each time, I see the protocol in the account creation, but no Skype authorisation popup...

Any ideas ?

After a reboot, the Skype have finally asked me the autorisation :-)
Thanks !

jeadorf (jeadorf) wrote :

After creating an account in Empathy connecting to Skype via "bigbrownchunx-skype-dbus"
Empathy repeatedly failed to connect with Skype. I can confirm that the workaround as described
in comment #13 by Peter Wagner solves this problem for me.

Ubuntu 10.10 Maverick Meerkat
Linux 2.6.35-25-generic #44-Ubuntu SMP Fri Jan 21 17:40:44 UTC 2011 x86_64 GNU/Linux
pidgin-skype 20100302+dfsg-1

papukaija (papukaija) on 2011-03-15
Changed in pidgin-skype (Ubuntu):
status: New → Confirmed
tags: added: ubuntu
removed: bigbrownchunx-skype-dbus empathy pidgin pidgin-skype skype4pidgin
Benjamin Schmid (benbuntu) wrote :

Somehow the plugin started to work for me (maybe after a reboot or reinstalling some missing dependency?): It now automatically starts Skype and allows to use text chats with Skype contacts.

Andrew (abryndzak) wrote :

This plugin doesn't work properly after recent Skype update to version 2.2. Incoming messages don't appear in Empathy.

Mattia Guidi (matguidi) wrote :

I manage to set up the account and receive chat messages (haven't yet tried calls), using the last *deb package provided on the developer's website. But one problem that really pisses me off is that in Empathy the plugin called "bigbrownchunck-skype-dbus" does not display an icon.
The plugin does actually have its own icons, but they get installed where pidgin protocols' icons are installed (the path is /usr/share/pixmaps/pidgin/protocols/).
Apparently, Empathy does not know where to find the icons for the Skype protocol, and it ends up assigning no icon to the protocol. The worst consequence of this is that when the mouse passes over Skype contacts in Empathy's main window, an ugly icon with a red "X" on black background shows up.
I'm sure this could be fixed quite easily, but I don't know how.

Andrew (abryndzak) wrote :

@Spaced:
You should put icons named im-bigbrownchunx-skype-dbus.png into /usr/share/empathy/icons/hicolor/.../apps/ directories.
Can you also provide me the latest .deb? The only package I see is from this bug-report.

Andrew (abryndzak) wrote :

Here is my set of icons. Unpack it to /usr/share/empathy/icons and Empathy will show icons for skype contacts.

Mattia Guidi (matguidi) wrote :

@Andrew:
Thanks a lot, now the icons are correctly displayed.
The *.deb I'm using is this one: http://eion.robbmob.com/skype4pidgin.deb
I've had no particular configuration problems with it, except that it requires pidgin to be installed. But then it works normally with Empathy for me.

Mattia Guidi (matguidi) wrote :

Another problem: is there a way to get rid of Skype notifications when receiving new chat messages? In Skype I don't find how to disable them (I can only replace them with the chat window popping up automatically, which is even worse).

Frank (franksouza183) wrote :

The avatars of Skype contacts are not displayed, any solution for this? My OS: Ubuntu 11.10 Amd64.

hans meiser (goat-f) on 2012-08-15
Changed in pidgin-skype (Ubuntu):
assignee: nobody → hans meiser (goat-f)
papukaija (papukaija) on 2012-08-16
Changed in pidgin-skype (Ubuntu):
assignee: hans meiser (goat-f) → nobody
Changed in pidgin-skype (Ubuntu):
assignee: nobody → Mirjeta Bickel (bickelmira)
papukaija (papukaija) wrote :

Please do not assign the bug to yourself unless you're going to fix it. Please use the this bug affects me link at the top of this bug report. Thanks.

Changed in pidgin-skype (Ubuntu):
assignee: Mirjeta Bickel (bickelmira) → nobody
summary: - skype in empathy (bigbrownchunx-skype-dbus) with pidgin-skype
+ Empathy won't let to add new Skype accounts (bigbrownchunx-skype-dbus)
Mark (mark-wege) wrote :

I have marked a newer bug as duplicate, because it contains a workaround.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments