authentication failed

Bug #1488336 reported by Christopher Yeleighton on 2015-08-25
50
This bug affects 10 people
Affects Status Importance Assigned to Milestone
pidgin-sipe (Ubuntu)
Undecided
Unassigned

Bug Description

I am suddenly unable to connect to my Lync account, Pidgin says "Authentication failed".

<URL: http://sourceforge.net/p/sipe/bugs/285/ >

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: pidgin-sipe 1.17.3-1
ProcVersionSignature: Ubuntu 3.13.0-62.102-generic 3.13.11-ckt24
Uname: Linux 3.13.0-62-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.12
Architecture: amd64
CurrentDesktop: Unity
Date: Tue Aug 25 07:58:11 2015
InstallationDate: Installed on 2014-08-20 (369 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
SourcePackage: pidgin-sipe
UpgradeStatus: No upgrade log present (probably fresh install)

description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in pidgin-sipe (Ubuntu):
status: New → Confirmed
Petri Haikonen (petri-haikonen) wrote :

The issue has been fixed, but no patch for 1.17 http://sourceforge.net/p/sipe/bugs/285/

Joe Clifford (joeclifford) wrote :

This bug most likely affects all previous versions of pidgin-sipe, it certainly affects Ubuntu Vivid 15.04 pidgin-sipe-1.18.2.

http://sourceforge.net/p/sipe/bugs/285/?limit=25&page=1#a385 - This patch provided by the maintainer on the Sourceforge forum appears to apply cleanly to Ubuntu Vivid 15.04 pidgin-sipe-1.18.2 sources and I'm now able to log in to MS Lync / Office Communicator successfully (applied by adding patch file to debian/patches/ and including it in debian/patches/series before running dpkg-buildpackage).

LGB [Gábor Lénárt] (lgb) wrote :

Indeed, I have the same problem with Ubuntu 15.04

LGB [Gábor Lénárt] (lgb) wrote :

The mentioned patch by Joe Clifford (joeclifford) seems to be OK. I've downloaded source of pidgin-sipe (with apt-get source), also I applied the patch. After building a deb package and installing everything worked again with Ubuntu 15.04 (32 bit).

Mikko Pesari (mpesari) wrote :

Downloaded source for Ubuntu package version 1.18.2-1, applied the patch, compiled and installed to 14.04 which has version 1.17.3-1. Newer version works fine.

Mikko Pesari (mpesari) wrote :

I think a SRU (for Trusty) might be in order since organizations using Office365 are probably large and stick to LTS (like ours).

Mikko Pesari (mpesari) wrote :

FWIW, Xenial is not affected. Still no fix released for current releases, though...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers