Pidgin buddy icons appear blurred in notification bubbles

Bug #364038 reported by Matthew Paul Thomas on 2009-04-20
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
notify-osd (Ubuntu)
Low
Mirco Müller
pidgin-libnotify (Ubuntu)
Low
Mirco Müller

Bug Description

Binary package hint: pidgin-libnotify

According to comments and a screenshot in bug 338695, custom buddy icons that pidgin-libnotify sends in notifications are blurry. (A similar problem with generic protocol icons has been fixed, bug 333497.)

From Åskar in bug 338695: "The issue with lowresicons in pidgins buddyicons (check here: http://pici.se/396034/ ) is unfixable. That image is the only image we get from MSN and there is no way to make it bigger without upscaling it (and making it look bad). The only way this can be fixed is to use a smaller picture inside the bubbles."

First, we should verify that Åskar's diagnosis is correct.

If it is correct, we should investigate ways in Notify OSD of making icons look less bad when they are smaller than the allocated size, without compromising the consistency of the Notify OSD bubble layout. One possibility would be to never scale up icons, but to center too-small icons inside a subtle grey square outline.

(The equivalent problem in Rhythmbox is bug 360228, and in Banshee is bug 338695.)

description: updated
Åskar (olskar) wrote :

Thanks for cleaning up the bugmess!

The icons seems to be 96x96 from looking in .purple/icons and they should be at least "128 pixels in either width or height, to minimize the appearance of artifacts when it is scaled" according to https://wiki.ubuntu.com/NotificationDevelopmentGuidelines

The icon shown in the screenshot is 46x46 however.
I tried resizing a 96x96 icon from .purple/icons to 46x46 and got these results. Check the attached image.

The image to the left is from the bubble.
The image to the right is an image from .purple/icons resized to 46x46 in GIMP.
As you can see this looks a lot better, so I think we can say that the problem is not, as I said before, that we got no images big enough.

Mirco Müller (macslow) on 2009-05-13
Changed in pidgin-libnotify (Ubuntu):
assignee: nobody → Mirco Müller (macslow)
status: New → Fix Committed
Changed in notify-osd (Ubuntu):
assignee: nobody → Mirco Müller (macslow)
status: New → Fix Committed
Allan Caeg (allancaeg) wrote :

In what version is this fixed?

Ara Pulido (ara) wrote :

Allan, Fix Commited means that the developer has a fix for it, but it does not mean that the fix is in Ubuntu. Wait until the status of the bug is mark as "Fix Released"

Mirco, I guess this is going to be only for Karmic, isn't it?

Changed in pidgin-libnotify (Ubuntu):
importance: Undecided → Low
Changed in notify-osd (Ubuntu):
importance: Undecided → Low
Pedro Villavicencio (pedro) wrote :

this is already fixed on karmic with notify-osd 0.9.16 with : http://bazaar.launchpad.net/~notify-osd-developers/notify-osd/main/revision/314 .

Changed in pidgin-libnotify (Ubuntu):
status: Fix Committed → Fix Released
Changed in notify-osd (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments