pidgin doesn't notify at start of conversation (libnotify)

Bug #351545 reported by David Dean on 2009-03-30
36
This bug affects 5 people
Affects Status Importance Assigned to Milestone
pidgin (Ubuntu)
Low
Unassigned
Jaunty
Undecided
Unassigned
pidgin-libnotify (Ubuntu)
Low
Ted Gould
Jaunty
Low
Ted Gould

Bug Description

Binary package hint: pidgin

I'm running the Jaunty beta, and I cannot get the libnotify plugin to show a notification when a new conversation has started.

Once the conversation is underway, I get the notifications coming up, but they don't show for the first new message in a conversation. In that case, I just get a window popping up showing the conversation (when I would really prefer the notification without a new window).

The libnotify popup (version 0.14) configuration window has 'New Messages', 'Ignore events from blocked users', and 'Buddy signs on' ticked, but the rest are unticked.

The new jaunty notification popups are working for showing when a buddy signs on (as well as wifi sign-on/volume changes/etc) so it is not the notification that is broken.

I have confirmed that this happens for me on a live CD installation, so it doesn't appear to be left-over crud from before the beta upgrade. However, I never did manage to get the libnotify plugin to work properly in previous versions either, but I got motivated due to the new jaunty notification system.

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
Package: pidgin 1:2.5.5-1ubuntu3
ProcEnviron:
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
SourcePackage: pidgin
Uname: Linux 2.6.28-11-generic i686

David Dean (ddean-ieee) wrote :
David Dean (ddean-ieee) wrote :

Additionally, the libnotify plugin doesn't appear to work at all for IRC chat windows.

affects: pidgin (Ubuntu) → pidgin-libnotify (Ubuntu)
Ted Gould (ted) wrote :

Hello,

I would like to get a fix for this as a Jaunty SRU when the Jaunty updates archive opens after the release. I have built a package of a fix, could the reporters on this bug please confirm whether or not this updated package fixes the issue?

  https://launchpad.net/~ted-gould/+archive/bugfix

Thank you.
Ted

David Dean (ddean-ieee) wrote :

Ted, the above package appears to fix the problem. Thanks!

Changed in pidgin-libnotify (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Martin Pitt (pitti) on 2009-04-23
Changed in pidgin-libnotify (Ubuntu Jaunty):
assignee: nobody → Ted Gould (ted-gould)
status: Triaged → Fix Committed
Martin Pitt (pitti) wrote :

Accepted pidgin-libnotify into jaunty-proposed; please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Stanley A (sayz93) wrote :

I have the same problem as the bug report, but the above package doesn't seem to fix it. I've tried uninstalling/reinstalling a few times now with no luck. It still doesn't notify on new conversations, only messages within the conversations.

Krzysiek Slazinski (mallow) wrote :

Same here. I get notifications on new messages, but not new converstations.

Mahesh Kale (maheshkale) wrote :

Yes. it is not responsive for new conversations with the fix provided.

David Dean (ddean-ieee) wrote :

Hmmm.. I thought it had fixed the problem for me, but checked again after all these comments appeared.

Turns out it *didn't* fix the problem. I must have been mistaken when I thought that it had. Sorry.

Martin Pitt (pitti) on 2009-04-27
tags: added: verification-failed
removed: verification-needed
Sebastien Bacher (seb128) wrote :

the issue seems to be a pidgin-libnotify one

Changed in pidgin (Ubuntu):
importance: Undecided → Low
status: New → Invalid
PlayerX (benjamin-hecht) on 2009-04-30
Changed in pidgin-libnotify (Ubuntu):
status: Fix Committed → New
Changed in pidgin-libnotify (Ubuntu Jaunty):
status: Fix Committed → New
Steve Langasek (vorlon) on 2009-04-30
Changed in pidgin-libnotify (Ubuntu):
status: New → Fix Committed
Changed in pidgin-libnotify (Ubuntu Jaunty):
status: New → Fix Committed
Thomas Ohms (tohms) wrote :

Should be invalid for package pidgin as bug is in pidgin-libnotify

Changed in pidgin (Ubuntu Jaunty):
status: New → Invalid
Stanley A (sayz93) wrote :

What's the status on this bug? I see that a fix has been committed, but as for right now it's still not working and it's a pretty annoying bug. I can understand that the developers probably have bigger concerns right now, but I'm just wondering.

Martin Pitt (pitti) wrote :

I removed this from jaunty-proposed. It didn't get any feedback, it is still not fixed in karmic, and is verification-failed.

2009-09-09 09:58:33 INFO Removing candidates:
2009-09-09 09:58:33 INFO pidgin-libnotify 0.14-1ubuntu9 in jaunty
2009-09-09 09:58:33 INFO pidgin-libnotify 0.14-1ubuntu9 in jaunty amd64
2009-09-09 09:58:33 INFO pidgin-libnotify 0.14-1ubuntu9 in jaunty armel
2009-09-09 09:58:33 INFO pidgin-libnotify 0.14-1ubuntu9 in jaunty hppa
2009-09-09 09:58:33 INFO pidgin-libnotify 0.14-1ubuntu9 in jaunty i386
2009-09-09 09:58:33 INFO pidgin-libnotify 0.14-1ubuntu9 in jaunty ia64
2009-09-09 09:58:33 INFO pidgin-libnotify 0.14-1ubuntu9 in jaunty lpia
2009-09-09 09:58:33 INFO pidgin-libnotify 0.14-1ubuntu9 in jaunty powerpc
2009-09-09 09:58:33 INFO pidgin-libnotify 0.14-1ubuntu9 in jaunty sparc
2009-09-09 09:58:33 INFO Removed-by: Martin Pitt
2009-09-09 09:58:33 INFO Comment: unverified/failed SRU
2009-09-09 09:58:33 INFO 9 packages successfully removed.
2009-09-09 09:58:33 INFO Transaction committed.

Changed in pidgin-libnotify (Ubuntu Jaunty):
status: Fix Committed → Won't Fix
abujafar (abujafar) wrote :

This is a serious bug. People often send just one message to know if you are there and you won't get the notification.
I Don't understand why it is marked Low Priority and forgotten.

This bug is a duplicate of #363108

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pidgin-libnotify - 0.14-1ubuntu10

---------------
pidgin-libnotify (0.14-1ubuntu10) karmic; urgency=low

  * Adding in blacklist support
  * Trying to fix IRC first messages by using an idle function
    to wait for the conversation to get built.
  * Changing black list to be a plugin preference.
  * Adding checking for the server
  * /debian/patches/indicate.patch:
    * Updating to use the libindicate v2 interface (LP: #424487 and
      LP: #424491)
    * Merging in Ken Vandine's patch to make the Pidgin window always
      rise on click from the indicator applet. (LP: #354026)
    * Starting a blacklist for common IRC server nicks. (LP: #362660)
    * Making it so that no append hint is sent on connection status
      messages. (LP: #361800)
    * Setting the default icon to match the notify-osd specification
      if there is no better icon available. (LP: #356979)
    * Making the login timeout 60 seconds instead of 15 so that the
      indicator applet doesn't flicker.
    * Changing the logic slightly so that if we don't have a GUI window
      then we don't check for focus. We only block notifications/indicators
      we we both have a GUI and have focus. (LP: #351545)
  * Adding debian/patches/indicate-autotools.patch changes to built
    files from above patch.
  * debian/control:
    * Increasing libindicate dependency to 0.2.0
    * Adding a build dependency on libindicate-gtk-dev

 -- Ted Gould <email address hidden> Wed, 16 Sep 2009 14:10:37 -0500

Changed in pidgin-libnotify (Ubuntu):
status: Fix Committed → Fix Released
Jerry Hao (jerryh) wrote :

Still this bug appears in Raring(13.04) with pidgin ver. 2.10.7 and pidgin-libnotify ver. 0.14-9ubuntu1
This is really annoying, is there any update?

Bachi (m-bachmann) wrote :

@Jerry, this is hardly the same bug as in 2009. But I confirm it does again appear in 13.4, whereas it worked in 12.10 (after white-listing Pidgin notifications).

And I also confirm that this is really annoying.

Deniz Bahadir (bagira80) wrote :

I can confirm that it already exists on Ubuntu 12.04 LTS (Precise Pangolin) with pidgin version 2.10.3-0ubuntu1.3 and pidgin-libnotify version 0.14-4ubuntu10.

And yes, it is really, really annoying.

This bug still appears in Ubuntu 13.10 64bit with pidgin 2.10.7, and it is _very_ annoying. The first message of a conversation does not show up in libnotify. Since many of my contacts start a conversation with a one-liner, this bug caused me many missed messages.

It did not appear in Ubuntu 13.04, 12.04 or 12.10

Any news?

Still happens for me in 14.10

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers