"Error: Protocol incompatible. Please upgrade libpiano."

Bug #807860 reported by meow9th on 2011-07-09
116
This bug affects 28 people
Affects Status Importance Assigned to Milestone
Pithos
Fix Released
High
Kevin Mehall
pianobar (Debian)
Fix Released
Unknown
pianobar (Ubuntu)
High
Luke Faraone
Maverick
High
Luke Faraone
Natty
High
Luke Faraone
pithos (Ubuntu)
High
Luke Faraone
Maverick
Undecided
Unassigned
Natty
High
Luke Faraone

Bug Description

NB: If you came here from a Google search, please see http://faraone.cc/s/pandoraUbuntuBreakage , the tracker for the latest issue with Pandora. What follows is an older, similar bug.

== SRU INFORMATION ==

Pandora changed their API, so here we provide an update to support API v31. The API change rendered pianobar and pithos unusable.

This is low-impact to other apps, because pithos and pianobar have no rev-depends.

=== pithos (gtk) ===
What happens:
On login, "Pandora does not support your client version"

What should happen:
You are logged in and a station loaded.

Diff at http://bazaar.launchpad.net/~kevin-mehall/pithos/trunk/revision/164

=== pianobar (cli) ===
What happens:
    # pianobar
    Welcome to pianobar (2010.10.07)! Press ? for a list of commands.
    [?] Username: <email address hidden>
    [?] Password:
    (i) Login... Error: Protocol incompatible. Please upgrade libpiano.

What should happen:
    # pianobar
    Welcome to pianobar (2010.10.07)! Press ? for a list of commands.
    [?] Username: <email address hidden>
    [?] Password:
    (i) Login... Ok.

Etc.

Ideally, test with your Pandora.com account.

Minimal diff attached.

== END SRU INFORMATION ==

Just received this error a few minutes ago, in the middle of streaming:

(i) Receiving new playlist... Error: Protocol incompatible. Please upgrade libpiano.

I'm using Maverick, pianobar version 2010.10.07-1ubuntu0.2.

Luke Faraone (lfaraone) on 2011-07-09
Changed in pianobar (Ubuntu):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Luke Faraone (lfaraone)
Changed in pianobar (Ubuntu Maverick):
status: New → In Progress
importance: Undecided → High
Changed in pianobar (Ubuntu Natty):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Luke Faraone (lfaraone)
Changed in pianobar (Ubuntu Maverick):
assignee: nobody → Luke Faraone (lfaraone)
Luke Faraone (lfaraone) on 2011-07-09
Changed in pianobar (Ubuntu Maverick):
status: In Progress → Triaged
Changed in pianobar (Ubuntu Natty):
status: In Progress → Triaged
Changed in pithos (Ubuntu Maverick):
status: New → Invalid
Changed in pithos:
status: New → Confirmed
Changed in pithos (Ubuntu):
status: New → Triaged
Changed in pithos (Ubuntu Natty):
status: New → Triaged
Changed in pithos (Ubuntu):
importance: Undecided → High
Changed in pithos (Ubuntu Natty):
importance: Undecided → High
assignee: nobody → Luke Faraone (lfaraone)
Changed in pithos (Ubuntu):
assignee: nobody → Luke Faraone (lfaraone)
description: updated
description: updated
Changed in pithos:
status: Confirmed → Fix Released
importance: Undecided → High
assignee: nobody → Kevin Mehall (kevin-mehall)
Luke Faraone (lfaraone) wrote :
description: updated
Changed in pianobar (Ubuntu):
status: In Progress → Triaged
Chris Halse Rogers (raof) wrote :

Neither of these tasks are ‘fix released’ in Oneiric. Please ensure these bugs are fixed in the development release.

Once that's done the pianobar uploads look good. I'd like the pithos changes to be made as a proper patch rather than as an autogenerated debian-changes patch, however. Since it's a 3.0 (quilt) package that should be as easy as renaming the patch and cleaning up the DEP3 header.

Hello meow9th, or anyone else affected,

Accepted pianobar into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in pianobar (Ubuntu Natty):
status: Triaged → Fix Committed
tags: added: verification-needed
Changed in pianobar (Ubuntu Maverick):
status: Triaged → Fix Committed
Martin Pitt (pitti) wrote :

Hello meow9th, or anyone else affected,

Accepted pianobar into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

meow9th (y-yuan) wrote :

Just tested pianobar version 2010.10.07-1ubuntu0.3 in maverick-proposed. Everything works as expected. Thanks!

Martin Pitt (pitti) on 2011-07-11
tags: added: verification-done-maverick
Rengar (rengar34) wrote :

Confirmed fixed in Pithos 3.10! Thanks for this!

On 07/11/2011 05:34 PM, Rengar wrote:
> Confirmed fixed in Pithos 3.10! Thanks for this!

If you're using Natty, can you test from the official repositories
(natty-proposed) and report your success with that?

--
Luke Faraone;; Debian & Ubuntu Developer; Sugar Labs, Systems
lfaraone on irc.[freenode,oftc].net -- http://luke.faraone.cc
PGP fprint: 5189 2A7D 16D0 49BB 046B DC77 9732 5DD8 F9FD D506

Hello meow9th, or anyone else affected,

Accepted pithos into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in pithos (Ubuntu Natty):
status: Triaged → Fix Committed
Wesley Hammes (whammes2) wrote :

upgraded to natty-proposed for pithos this morning, works for me.

Thanks to all who worked this.

Martin Pitt (pitti) on 2011-07-12
tags: added: verification-done
removed: verification-done-maverick verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pianobar - 2010.10.07-1ubuntu0.3

---------------
pianobar (2010.10.07-1ubuntu0.3) maverick-proposed; urgency=low

  * Support new XMLRPC api (v31) (LP: #807860)
 -- Luke Faraone <email address hidden> Sat, 09 Jul 2011 10:53:27 -0400

Changed in pianobar (Ubuntu Maverick):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pianobar - 2011.01.24-1ubuntu0.2

---------------
pianobar (2011.01.24-1ubuntu0.2) natty-proposed; urgency=low

  * Support new XMLRPC api (v31) (LP: #807860)
 -- Luke Faraone <email address hidden> Sat, 09 Jul 2011 10:41:22 -0400

Changed in pianobar (Ubuntu Natty):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Luke, can you please fix pithos in oneiric, so that this can progress to natty-updates? Thanks!

Martin Pitt (pitti) wrote :

(and pianobar)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pianobar - 2011.07.09-1

---------------
pianobar (2011.07.09-1) unstable; urgency=high

  * New upstream version.
    - XMLRPC api version bump (v31) (closes: #633345, LP: #807860)
  * Update debian/watch for new location.
  * Update symbols file.

pianobar (2011.04.27-1) unstable; urgency=low

  [ Romain Beauxis ]
  * Added libpianobar0 and libpianobar-dev packages.
  * Added myself as uploader.

  [ Luke Faraone ]
  * New upstream version.
  * Drop protocol30.patch, integrated upstream.
  * Bump date in copyright.
 -- Luke Faraone <email address hidden> Tue, 19 Jul 2011 10:08:58 +0000

Changed in pianobar (Ubuntu):
status: Triaged → Fix Released
Luke Faraone (lfaraone) on 2011-07-20
Changed in pithos (Ubuntu):
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pithos - 0.3.9-1~ubuntu2

---------------
pithos (0.3.9-1~ubuntu2) natty-proposed; urgency=low

  * Support protocol 31. (LP: #807860)
 -- Luke Faraone <email address hidden> Sun, 10 Jul 2011 17:01:35 -0400

Changed in pithos (Ubuntu Natty):
status: Fix Committed → Fix Released
sirald66 (sirald66) wrote :

UBUNTU 9.10 +proposed
PITHOS 0.3.9

Using instructions at http://kevinmehall.net/p/pithos/ - I tried to reinstall per bug #814672, but get the same console error:

ERROR:root:fault: org.apache.xmlrpc.XmlRpcException: 000.000.000.000|0|INCOMPATIBLE_VERSION|Pandora does not support your client version.

Nothing in this bug's description makes clear how to install/test a beta version.

The author needs to update the home page to this issue.

Luke Faraone (lfaraone) wrote :

Support for Ubuntu 9.10 was dropped in April 2011. That version of Ubuntu is now more than two years old, please upgrade.

Changed in pianobar (Debian):
status: Unknown → Fix Released
JW (arch0njw) wrote :

It's Baa-aack.

Version:
$ pithos --version
Pithos 0.3.11

Error:
$ pithos
ERROR:root:fault: org.apache.xmlrpc.XmlRpcException: 000.000.000.000|0|INCOMPATIBLE_VERSION|Pandora does not support your client version.

My System:
$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=10.04
DISTRIB_CODENAME=lucid
DISTRIB_DESCRIPTION="Ubuntu 10.04.3 LTS"

Royce King (roycewking) wrote :

I am getting "Pandora does not support your client version" again too. Any fix yet?

$ pithos --version
Pithos 0.3.10

David Robert Lewis (afrodeity) wrote :

pianobar has issues.

protocol incompatible, please upgrade libpiano

meow9th (y-yuan) wrote :

For those of you who don't want to wait for a new Ubuntu package to be released every time there's a protocol update: I recommend simply building from source, available from pianobar's github (github.com/PromyLOPh/pianobar). It seems that the source is updated within a few hours each time the protocol changes. The installation is really straightforward and painless, in my experience. The dependencies are very clearly stated in the INSTALL file, as well as the commands to compile.

Be aware, though, that there is another bug affecting pianobar (after the protocol update - see https://github.com/PromyLOPh/pianobar/issues/174), which has been fixed but the master branch won't be updated until this weekend, according to the developer.

Luke Faraone (lfaraone) on 2011-11-10
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.