[feisty] phpunit depends on php4 which is not supported anymore

Bug #108652 reported by Ralph Janke on 2007-04-21
8
Affects Status Importance Assigned to Milestone
phpunit (Ubuntu)
Undecided
Soren Hansen
Feisty
Medium
Soren Hansen

Bug Description

Binary package hint: phpunit

Trying to install it results in the following error message:

The following packages have unmet dependencies.
  phpunit: Depends: php4 but it is not installable
E: Broken packages

This package should be removed from the feisty repositories since it is replaced by phpunit2 for php5 (the only supported php version in feisty)

Ralph Janke (txwikinger) on 2007-04-21
description: updated
Ralph Janke (txwikinger) on 2007-04-21
Changed in phpunit:
assignee: nobody → motu
Daniel Hahler (blueyed) on 2007-05-23
Changed in phpunit:
status: Unconfirmed → Confirmed
Daniel Hahler (blueyed) wrote :

I had no problem with changing the php-"Depends" in debian/control to "php4|php5".

In fact, e.g. the JanRain php-openid library uses explicitly PHPUnit.php for its unit tests and it does not seem to cause any problems running on PHP5.

So, rather than removing it from the repo, it should "just get fixed".

Dean Sas (dsas) wrote :

It should be noted that debian 425213 says that they plan to merge phpunit and phpunit2....Currently they both depend on php5 and not php4.

Maurizio Moriconi (bugman) wrote :

I check the package in gutsy and its already in repository with description like:

    * gutsy (web): Unit testing suite for PHP5 [universe]
      3.0.6-2: all

This debdiff should fix the problem to feisty.

Changed in phpunit:
status: Confirmed → In Progress
Daniel Holbach (dholbach) wrote :

Søren: can you take a look at this one?

Changed in phpunit:
assignee: motu → shawarma

On Tue, Jul 17, 2007 at 03:42:44PM -0000, Ralph Janke wrote:
 > The following packages have unmet dependencies.
> phpunit: Depends: php4 but it is not installable
> E: Broken packages

Do you know if it works with php5?

--
Soren Hansen
Ubuntu Server Team
http://www.ubuntu.com/

Maurizio Moriconi (bugman) wrote :

In the first comment dAniel hAhler said on 2007-05-25:

In fact, e.g. the JanRain php-openid library uses explicitly PHPUnit.php for its unit tests and it does not seem to cause any problems running on PHP5.

It's sufficient?

On Wed, Jul 18, 2007 at 07:28:02AM -0000, Maurizio Moriconi wrote:
> In the first comment dAniel hAhler said on 2007-05-25:
>
> In fact, e.g. the JanRain php-openid library uses explicitly PHPUnit.php
> for its unit tests and it does not seem to cause any problems running on
> PHP5.
>
> It's sufficient?

Ah, I got lost in my bug mail. Yes, that's quite sufficient. Thanks.

--
Soren Hansen
Ubuntu Server Team
http://www.ubuntu.com/

Soren Hansen (soren) wrote :

Fixed in Gutsy, so marking as fixed released.

Changed in phpunit:
status: In Progress → Fix Released
Soren Hansen (soren) wrote :

Sorry about the delay!

I changed the distribution in the changelog to "feisty-proposed" and have just uploaded it.

Thanks for your work on this!

Changed in phpunit:
assignee: nobody → shawarma
importance: Undecided → Medium
status: New → In Progress
Martin Pitt (pitti) wrote :

Accepted into feisty-proposed, please test.

Changed in phpunit:
status: In Progress → Fix Committed
Maurizio Moriconi (bugman) wrote :

phpunit (1.3.2-2ubuntu1) feisty-proposed; urgency=low

  * Update maintainer field in debian/control
  * Change dependency from php4 to php5 in debian/control (LP: #108652)

 -- Maurizio Moriconi <email address hidden> Tue, 17 Jul 2007 11:52:43 +0200

Changed in phpunit:
status: Fix Committed → Fix Released
Changed in phpunit:
status: Fix Released → Fix Committed
Paolo Naldini (hattory) wrote :

Works for me!

Luca Falavigna (dktrkranz) wrote :

Works for me too.

Minimum aging period of seven days elapsed and two persons confirmed fix is good.
Tagging verification-motu-done as per https://wiki.ubuntu.com/StableReleaseUpdates.

Martin Pitt (pitti) wrote :

Copied to feisty-updates.

Changed in phpunit:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers