data directory (distros.ini) is missing

Bug #567821 reported by Martin Hagelin on 2010-04-21
82
This bug affects 17 people
Affects Status Importance Assigned to Milestone
phpsysinfo (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: phpsysinfo

Running Lucid beta2 & phpsysinfo 3.0.4

The directory /usr/share/phpsysinfo/data is missing in the distribution. It's in the sourceforge release, but not foir Ubuntu.

//Martin

martin@ella:/usr/share/phpsysinfo$ dpkg -s phpsysinfo
Package: phpsysinfo
Status: install ok installed
Priority: optional
Section: web
Installed-Size: 2376
Maintainer: Ubuntu MOTU Developers <email address hidden>
Architecture: all
Version: 3.0.4-0ubuntu2
Depends: apache2 | httpd, php5
Suggests: lm-sensors, hddtemp
Conffiles:
 /etc/phpsysinfo/config.php 7bc207506c882ff23dd1fad436b2041c
Description: PHP based host information
 phpSysInfo is a PHP script that displays information about the
 host being accessed.
 .
 It displays informations on the system like kernel version, uptime,
 network, disk and memory usage, informations on CPU and model,
 attached IDE and SCSI devices and PCI cards and lm-sensors output on
 architectures supporting it.
 .
 It has support for multiple languages and themes.
Homepage: http://phpsysinfo.sourceforge.net/
Original-Maintainer: Frederik Schüler <email address hidden>

martin@ella:/usr/share/phpsysinfo$ ls
gfx index.php js.php phpsysinfo3.xsd plugins xml.php
includes js language phpsysinfo.xslt templates

Jaakan Shorter (jaakanshorter) wrote :

Description: Ubuntu 10.04 LTS
Release: 10.04

Mythbuntu 10.04 x64 final ( clean install )

phpsysinfo:
  Installed: 3.0.4-0ubuntu2
  Candidate: 3.0.4-0ubuntu2
  Version table:
 *** 3.0.4-0ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ lucid/universe Packages
        100 /var/lib/dpkg/status

------------------------------------------------------------------

OH, I'M SORRY. SOMETHING SEEMS TO BE WRONG.
errorHandlerPsi :

PHP throws a error
Level : 2 Message : parse_ini_file(/usr/share/phpsysinfo/data/distros.ini): failed to open stream: No such file or directory File : /usr/share/phpsysinfo/includes/os/class.Linux.inc.php Line : 494

Troy Dack (troydack) wrote :

Copying the /usr/share/phpsysinfo/data directory from the source .tar.gz (available from http://phpsysinfo.sourceforge.net/) to /usr/share/phpsysinfo fixes the error

UndiFineD (k.dejong) wrote :

confirmed Troy Dack's solution, it works. :-)

MartinP (bircoe) wrote :

Confirmed missing files...

This is still an issue 5 months after it was reported.

I`m coding now small script for fix this issue. Releasing soon :P

Toni Lähdekorpi (lahdekorpi) wrote :

Why would you need a script? Just copy the missing file to /usr/share/phpsysinfo/data/distros.ini

Dan Rice (dnrce) wrote :

The needed files are in the source orig.tar.gz but are not included in debian/phpsysinfo.install. A patch against debian/ is attached. (Apologies if it's not in the right format -- this is my first patch submission, and I tried to follow the instructions on the MOTU/Contributing wiki page.)

tags: added: patch
Changed in phpsysinfo (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package phpsysinfo - 3.0.7-0ubuntu1

---------------
phpsysinfo (3.0.7-0ubuntu1) natty; urgency=low

  * New upstream release
  * debian/phpsysinfo.install: install missing data/ dir (LP: #567821),
    thanks to Dan Rice.
  * debian/control: add dependency on php5-xsl (LP: #562121)
  * debian/watch: added
 -- Steve Beattie <email address hidden> Mon, 03 Jan 2011 23:20:35 -0800

Changed in phpsysinfo (Ubuntu):
status: Confirmed → Fix Released
dnmvisser (dnmvisser) wrote :

Great to have it fixed in natty, but the package in lucid is still b0rked...
Any reason why it was never fixed?
Thanks!!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers