phpsysinfo doesn't detect Ubuntu

Bug #2399 reported by Fabio Marzocca
16
Affects Status Importance Assigned to Milestone
phpsysinfo (Ubuntu)
Fix Released
Medium
Adrien Cunin

Bug Description

When running phpsysinfo on Ubuntu, in the Sistem Vital description the Distro Name is reported as Debian unstable/testing and debian's icon is displayed... This is because application is gathering the distro name from the file /etc/debian_version, and in ubuntu that file contains "unstable/testing". I had to manually patch the file /usr/share/phpsysinfo/includes/os/class.Linux.inc.php replacing Debian with Ubuntu Breezy, and loading the correct icon..

Changed in phpsysinfo:
assignee: nobody → motu
Revision history for this message
Stephan Rügamer (sruegamer) wrote :

which version of php? 4 or 5?

Thx,

\sh

Revision history for this message
Fabio Marzocca (thesaltydog) wrote :

Stephan,

php is version 4, but the bug is not related to php. As I reported, the code inside the program looks for the distro name into /etc/debian_version and that file contains "unstable/testing" instead of "05.10" or "Breezy".

Revision history for this message
Andrew Mitchell (ajmitch) wrote :

Which means that the more reliable way might be to use lsb_release

Revision history for this message
Fabio Marzocca (thesaltydog) wrote :

Yor're right, that program line should be changed

Revision history for this message
Vassilis Pandis (pandisv) wrote :

The program appears to have changed. Taking a look at distros.ini, it seems that /etc/lsb-release is used and the distro reported is "Ubunto".

Revision history for this message
Vassilis Pandis (pandisv) wrote :

I'm attaching a debdiff that PROBABLY fixes the issue. I am not sure it does, since I can't test it.

Changed in phpsysinfo:
assignee: motu → motureviewers
Revision history for this message
Vassilis Pandis (pandisv) wrote :

I tested it and it doesn't. Do NOT upload please.

Changed in phpsysinfo:
assignee: motureviewers → motu
Revision history for this message
Vassilis Pandis (pandisv) wrote :
Changed in phpsysinfo:
status: Unconfirmed → Confirmed
Revision history for this message
Vassilis Pandis (pandisv) wrote :

There's a patch upstream. I haven't tested it.

Revision history for this message
Vassilis Pandis (pandisv) wrote :

Upstream have committed fix to CVS head. This has not been fixed in 2.5.2's release.

Changed in phpsysinfo:
status: Confirmed → Fix Committed
Adrien Cunin (adri2000)
Changed in phpsysinfo:
assignee: motu → adri2000
Revision history for this message
Adrien Cunin (adri2000) wrote :

phpsysinfo (2.5.2-0ubuntu1) feisty; urgency=low

  * New upstream release
  * debian/patches:
     - configfile.diff, hddtemp-config.diff, samsung-hd-fix.diff: updated
  * Detect Ubuntu properly (Closes: Malone #2399)
     - Added detect-ubuntu.patch from upstream CVS
     - Converted upstream gif Ubuntu icon to xpm to ship it in the diff.gz
     - Build-Depends on imagemagick to convert the xpm to gif in debian/rules

 -- Adrien Cunin <email address hidden> Sun, 14 Jan 2007 16:00:58 +0100

Changed in phpsysinfo:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Patches