Bad appcharset in Czech localization

Bug #184677 reported by Věroš Kaplan on 2008-01-20
6
Affects Status Importance Assigned to Milestone
phppgadmin (Debian)
Fix Released
Unknown
phppgadmin (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: phppgadmin

There is bad appcharset in Czech localization of phppgadmin, causing PHP warning message on lib.inc.php line 224.

Distribution: Gutsy

Fix:
/usr/share/phppgadmin/lang/czech.php line 11

BAD:
        $lang['appcharset'] = 'utf8';
GOOD:
        $lang['appcharset'] = 'utf-8';

The same applies to /usr/share/phppgadmin/lang/recoded/czech.php

Related branches

description: updated
Daniel T Chen (crimsun) wrote :

Confirmed in jaunty.

Changed in phppgadmin:
importance: Undecided → Low
status: New → Triaged
Radek Zielonka (zielonka-radek) wrote :

I have fixed this bug, so the debdiff file is attached
Because it is my first job with packag I have no idea if I should send this file to
someone or just leave it here.

Changed in phppgadmin:
assignee: nobody → zielonka-radek
status: Triaged → Fix Committed

I've set this bug so a sponsor can look at the patch and hopefully get it included.

Changed in phppgadmin (Ubuntu):
assignee: Radek Zielonka (zielonka-radek) → nobody
status: Fix Committed → Confirmed
Changed in phppgadmin (Debian):
status: Unknown → New
Charlie_Smotherman (cjsmo) wrote :

Setting bug to incomplete, could you please update your patch for karmic? thx

Best regards
Charlie Smotherman

Changed in phppgadmin (Ubuntu):
status: Confirmed → Incomplete

I'll work on getting this bug fixed in karmic since I already have karmic installed.

Changed in phppgadmin (Ubuntu):
assignee: nobody → David Stansby (dstansby)
status: Incomplete → In Progress

Here's the karmic fix.

Charlie_Smotherman (cjsmo) wrote :

Subscribing Universe sponsors

Changed in phppgadmin (Ubuntu):
assignee: David Stansby (dstansby) → nobody
status: In Progress → New
Changed in phppgadmin (Ubuntu):
status: New → Confirmed
Andreas Moog (ampelbein) wrote :

Taking for sponsoring

Changed in phppgadmin (Ubuntu):
assignee: nobody → Andreas Moog (amoog)
status: Confirmed → In Progress
Andreas Moog (ampelbein) wrote :

Thanks for your patch, however:

This package uses quilt as a patchsystem and it is not good to directly patch the source. Could you transform your patch to use quilt? Unsubscribing sponsors for now, please resubscribe when ready. Also, please adhere to https://wiki.ubuntu.com/UbuntuDevelopment/PatchTaggingGuidelines when you create your patch, thanks.

Changed in phppgadmin (Ubuntu):
assignee: Andreas Moog (amoog) → David Stansby (dstansby)
status: In Progress → Incomplete

I don't know if this helps, but a patch has been proposed upstream: http://bugs.debian.org/cgi-bin/bugreport.cgi?msg=5;filename=phppgadmin_czech_UTF-8_fix;att=1;bug=533242 I haven't looked at quilt yet, and figured that if someone has already made a perfectly acceptable patch then there's not much point in me learning a whole new patching system.

Andreas Moog (ampelbein) wrote :

Ok, I will transform it to a quilt patch and upload. But quilt is not that complicated, see https://wiki.ubuntu.com/PackagingGuide/PatchSystems#quilt%20(example%20package:%20xterm) for reference. Thank you for your work.

Changed in phppgadmin (Ubuntu):
assignee: David Stansby (dstansby) → nobody
status: Incomplete → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package phppgadmin - 4.2.2-1ubuntu1

---------------
phppgadmin (4.2.2-1ubuntu1) karmic; urgency=low

  * debian/patches
    - add fix_czech_utf8.patch to fix czech localisation. (LP: #184677)
      Patch by David Stansby

 -- Andreas Moog <email address hidden> Mon, 29 Jun 2009 14:15:28 +0200

Changed in phppgadmin (Ubuntu):
status: Fix Committed → Fix Released
Changed in phppgadmin (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.