phpmyadmin and lighttpd and debian = 404 - Not Found

Bug #179484 reported by Karol Krizka on 2007-12-31
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
lighttpd (Debian)
Fix Released
Unknown
lighttpd (Ubuntu)
Undecided
Unassigned
phpmyadmin (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: phpmyadmin

I first installed lighttpd using aptitude and then I did sudo aptitude install phpmyadmin and selected the option to automatically configure lighttpd. Then I reloaded lighttpd as instructed, and finally pointed my browser to http://localhost/phpmyadmin. There I got the error 404 - Not Found.

I am not sure where the problem lies, because I also manually tried to enable the phpmyadmin on lighttpd by typing it lighty-enable-mod phpmyadmin and I was informed that it was already enabled. The file /etc/lighttpd/conf-enabled/50-phpmyadmin.conf exists and links to /etc/lighttpd/conf-available/50-phpmyadmin.conf which links to /etc/phpmyadmin/lighttpd.conf. Also the problem persists after I restarted my computer, so there wasn't a problem with lighttpd not reloading the configuration.

Is there a logfile that I can look to to see if there are some problems? errors.log and access.log don't show anything out of place.

Karol Krizka (kkrizka) wrote :

I forgot to mention, I am running Hardy Heron and lighttpd 1.4.18-1ubuntu1 and phpmyadmin 2.11.3-1.

Wladston Viana (wladston) wrote :

I'm having the exact same problem, but under gusty.

Wladston Viana (wladston) wrote :

found something - if you run http://yourhost/phpmyadmin/index.php, it works.
Looks like lighttpd is unable to locate index.php, or maybe mod_alias isn't working....

Stephan Ruegamer (sadig) wrote :

Dear reporter,

fun part: lighttpd ships a configuration with this as default:

## files to check for if .../ is requested
index-file.names = ( "index.php", "index.html",
                               "index.htm", "default.htm",
                               "index.lighttpd.html" )

so index.php needs to be recognized...mod_alias is enabled by default.

To get the real bug:

1. Read http://trac.lighttpd.net/trac/wiki/DebugVariables
2. Set them to the highest level...
3. Reproduce it
4. Check /var/log/lighttpd/error.log
5. Attach your error logs in this bug.

Thx for your help,

\sh

Wladston Viana (wladston) wrote :

Stephan,

Did that.

I think most of the debug variables discribed there doesn't work, because of that :

2008-04-03 18:10:27: (server.c.915) WARNING: unknown config-key: debug.dump-unknown-headers (ignored)
2008-04-03 18:10:27: (server.c.915) WARNING: unknown config-key: debug.log-condition-cache-handling (ignored)
2008-04-03 18:10:27: (server.c.915) WARNING: unknown config-key: auth.debug (ignored)
2008-04-03 18:10:27: (server.c.915) WARNING: unknown config-key: proxy.debug (ignored)
2008-04-03 18:10:27: (server.c.915) WARNING: unknown config-key: proxy-core.debug (ignored)
2008-04-03 18:10:27: (server.c.915) WARNING: unknown config-key: simple-vhost.debug (ignored)
2008-04-03 18:10:27: (server.c.915) WARNING: unknown config-key: webdav.log-xml (ignored)

But I think I got a good error log. Can you please take a look at it ?

Wladston Viana (wladston) wrote :

I finally figured out why the bug happens:

http://localhost/phpmyadmin -> no good
http://localhost/phpmyadmin/ -> works!

Chaning my settings to this :

alias.url = ("/phpmyadmin" => "/usr/share/phpmyadmin")

Fully solved the issue. Please, fix it!!

Thanks,

Michal Čihař (nijel) wrote :

Debian package ships with this:

alias.url += (
    "/phpmyadmin" => "/usr/share/phpmyadmin",
)

You need to change it to make it work or Ubuntu uses some different config?

Wladston Viana (wladston) wrote :

if you are 100% sure that the default setting is this one, you can mark the bug as fixed, those are the settings that make it work.

Daniel Hahler (blueyed) wrote :

Yes, the default is "/phpmyadmin" => "/usr/share/phpmyadmin".
Marking "Fix released".

Changed in lighttpd:
status: New → Invalid
Changed in phpmyadmin:
status: New → Fix Released
Paul van Genderen (paulvg) wrote :

It's not a bug in PHPMyAdmin

Changed in phpmyadmin:
status: Fix Released → Invalid
Changed in lighttpd:
status: Invalid → Confirmed
Paul van Genderen (paulvg) wrote :

The title is misleading, it has nothing to do with PHPMyAdmin. I've linked the Debian bug, please read it. If you comment out these lines in /etc/lighttpd/conf-available/10-cgi.conf, aliases will work again:

$HTTP["remoteip"] == "127.0.0.1" {
       alias.url += ( "/cgi-bin/" => "/usr/lib/cgi-bin/" )
       $HTTP["url"] =~ "^/cgi-bin/" {
               cgi.assign = ( "" => "" )
       }
}

Otherwise Lighttpd tries to access files in the document-root directory.

Changed in lighttpd:
status: Unknown → Confirmed
summary: - phpmyadmin and lighttpd = 404 - Not Found
+ phpmyadmin and lighttpd and debian = 404 - Not Found
Changed in lighttpd (Debian):
status: Confirmed → Fix Released
Simon Hirscher (codethief) wrote :

I can't confirm the bug on Ubuntu server 10.04. Installed lighttpd; enabled ssl, simple-vhost and fastcgi; installed php5-cgi and php5-mysql; installed phpmyadmin. Went to "mydomain.com/phpmyadmin" => phpMyAdmin login prompt! :)

Simon Hirscher (codethief) wrote :

Oops, didn't look at the date. I think we can close this now…

Changed in lighttpd (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.