wrong config: mod_php.c instead of mod_php7.c

Bug #1637911 reported by Jan Kellermann on 2016-10-31
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
phpmyadmin (Ubuntu)
Undecided
Unassigned

Bug Description

For PHP7 on Ubuntu 16.04 use
      <IfModule mod_php7.c>
instead of
    <IfModule mod_php.c>

Otherwise phpmyadmin will not work because of open_basedir and other options that will not be set.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in phpmyadmin (Ubuntu):
status: New → Confirmed
Richard Willis-Owen (richardwo) wrote :

I just wasted time trying to increase PHP upload_max_filesize in phpmyadmin.conf and wondering why it wasn't working. Turns out it was the IfModule directive not set for PHP 7. Running Ubuntu 16.04.2 LTS.

Jan Kellermann (jan-kellermann) wrote :

Some Problem on Ubuntu 18.04.

William Desportes (williamdes) wrote :

Should be fixed by next version

Please try our PPA: https://github.com/phpmyadmin/phpmyadmin/issues/15515#issuecomment-549149228

Changed in phpmyadmin (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.