phpmyadmin recommends mysql and doesn't say that mariadb works too.

Bug #1312268 reported by Aminda Suomalainen
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
phpmyadmin (Ubuntu)
Fix Released
Undecided
Unassigned

Bug Description

phpmyadmin supports mariadb, but the package recommends mysql-. I believe there is "OR" for packages which allows packages to recommend on something or something else. Phpmyadmin should recommend mysql-client or mariadb.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: phpmyadmin 4:4.0.10-1
ProcVersionSignature: Ubuntu 3.13.0-24.46-generic 3.13.9
Uname: Linux 3.13.0-24-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.14.1-0ubuntu3
Architecture: amd64
CurrentDesktop: LXDE
Date: Thu Apr 24 18:55:34 2014
InstallationDate: Installed on 2014-02-01 (82 days ago)
InstallationMedia: Lubuntu 13.10 "Saucy Salamander" - Release amd64 (20131016.1)
PackageArchitecture: all
SourcePackage: phpmyadmin
UpgradeStatus: Upgraded to trusty on 2014-04-17 (7 days ago)

Related branches

Revision history for this message
Aminda Suomalainen (mikaela) wrote :
Revision history for this message
Markus F. (digilist) wrote :

I can confirm this bug. I have the same issue with percona-xtradb-cluster-server.

root@server ~ # apt-get install phpmyadmin
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  iproute percona-xtrabackup socat
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  mysql-client mysql-client-5.5 mysql-client-core-5.5 percona-xtradb-cluster-common-5.5
The following packages will be REMOVED:
  percona-xtradb-cluster-client-5.5 percona-xtradb-cluster-server-5.5
The following NEW packages will be installed:
  mysql-client mysql-client-5.5 mysql-client-core-5.5 phpmyadmin
The following packages will be upgraded:
  percona-xtradb-cluster-common-5.5

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in phpmyadmin (Ubuntu):
status: New → Confirmed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package phpmyadmin - 4:4.2.1-1

---------------
phpmyadmin (4:4.2.1-1) unstable; urgency=medium

  * New upstream release.
    - Now includes corresponding OpenLayers source.
  * Explicitly mention MariaDB as supported (LP: #1312268).

 -- Michal Čihař <email address hidden> Wed, 14 May 2014 09:31:21 +0200

Changed in phpmyadmin (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers