phpldapadmin: php class 'LDAPServers' not found when opening web interface

Bug #814123 reported by Rodrigo Campos on 2011-07-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
phpldapadmin (Ubuntu)
Undecided
Unassigned

Bug Description

Hi,

I've upgraded from using the lucid-updates repo.The thing is, now when I go to the web interface I see this error: "php class 'LDAPServers' not found when opening web interface."

And the web interface is unusable.

Searching, it seems the bug is that /etc/phpldapadmin/config.php is not treated as a config file and changes are needed for the upgrade. So if you upgrade your phpmyadmin from lucid and your config.php file is not updated to the new syntax (as it happens, not even a notice is given using "low" debconf priority) then the web interface stops working. This is what is reported in debian's BTS: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=578981 and the conclusion they got.

This is also fixed in Debian since October 2010, so please consider backporting the new package, the fix, or fixing this some other way. Because really, upgrading phpldapadmin renders the package unusable.

Thanks a lot,
Rodrigo

Rodrigo Campos (rodrigocc) wrote :

s/phpmyadmin/phpldapadmin/. I always meant phpldapadmin

Sorry, I'm used to type phpmyadmin :-D

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers