intl.so fails to load with "undefined symbol: spoofchecker_register_constants" on PHP 7.3.1 in Disco

Bug #1813438 reported by Michael Marley on 2019-01-27
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
php7.3 (Ubuntu)
Undecided
Unassigned

Bug Description

When PHP starts, I get:

PHP Warning: PHP Startup: Unable to load dynamic library 'intl.so' (tried: /usr/lib/php/20180731/intl.so (/usr/lib/php/20180731/intl.so: undefined symbol: spoofchecker_register_constants), /usr/lib/php/20180731/intl.so.so (/usr/lib/php/20180731/intl.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 0

I am currently trying to figure out when this started happening and I will update the bug if I am successful.

Michael Marley (mamarley) wrote :

It seems to be caused by the latest release, 7.3.1-2, and its change in how icu is detected. Reverting both that change and the change in icu to not ship icu-config and rebuilding makes the issue go away again.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in php7.3 (Ubuntu):
status: New → Confirmed
Jan I (ifi-jani) wrote :

This appears to be the same bug that was reported to bugs.php.net January 11 by a FreeBSD user:

https://bugs.php.net/bug.php?id=77441

Christian Pieber (euro76) wrote :

Upgrade to php 7.3.1-3 solved the problem for me.

Talion (talion) wrote :

Fixed in php 7.3.1-3

Changed in php7.3 (Ubuntu):
status: Confirmed → Fix Released

Upgrade to php 7.3.2 and fixed

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.