package php7.1-sqlite3 7.1.15-0ubuntu0.17.10.1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 139

Bug #1757344 reported by Daniele Cruciani on 2018-03-21
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
php7.1 (Ubuntu)
Undecided
Unassigned
update-manager (Ubuntu)
Undecided
Unassigned

Bug Description

package do not install, it happens during upgrade process, post-install script, exit code 139. I have nothing to add. I could provide more information I guess, just ask

ProblemType: Package
DistroRelease: Ubuntu 17.10
Package: php7.1-sqlite3 7.1.15-0ubuntu0.17.10.1
ProcVersionSignature: Ubuntu 4.13.0-37.42-generic 4.13.13
Uname: Linux 4.13.0-37-generic x86_64
ApportVersion: 2.20.7-0ubuntu3.7
Architecture: amd64
Date: Wed Mar 21 07:08:07 2018
DuplicateSignature:
 package:php7.1-sqlite3:7.1.15-0ubuntu0.17.10.1
 Setting up php7.1-sqlite3 (7.1.15-0ubuntu0.17.10.1) ...
 Segmentation fault (core dumped)
 dpkg: error processing package php7.1-sqlite3 (--configure):
  subprocess installed post-installation script returned error exit status 139
ErrorMessage: subprocess installed post-installation script returned error exit status 139
InstallationDate: Installed on 2015-07-17 (977 days ago)
InstallationMedia: Xubuntu 15.04 "Vivid Vervet" - Release amd64 (20150422.1)
Python3Details: /usr/bin/python3.6, Python 3.6.3, python3-minimal, 3.6.3-0ubuntu2
PythonDetails: /usr/bin/python2.7, Python 2.7.14, python-minimal, 2.7.14-2ubuntu1
RelatedPackageVersions:
 dpkg 1.18.24ubuntu1
 apt 1.5.1
SourcePackage: php7.1
Title: package php7.1-sqlite3 7.1.15-0ubuntu0.17.10.1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 139
UpgradeStatus: No upgrade log present (probably fresh install)

tags: removed: need-duplicate-check
Nish Aravamudan (nacc) wrote :

Hello and thank you for filing this bug!

Was your update performed from a terminal (e.g., using apt or apt-get) or from a GUI (e.g. update-manager)? If the latter, which GUI?

The segmentation fault reported is actually in the package manager itself (the frontend of it), not with PHP.

A workaround is probably to use apt/apt-get, if you weren't already, to perform the upgrade.

yes, update-manager, actually I find no real problem, it just fire up this crash report and I supposed there was some problem so I filled the bug.
package php7.1-sqlite3 is correctly installed.
`dpkg --configure --pending` is silent, no package unconfigured.

So I can not say what is the problem, looking at postinst script I see php_invoke enmod ... but module was already enabled, I guess.

I do not need assistance, I am just reporting bad ui experience, I think, close if it is the case

Hi,
coming by checking older bugs - unfortunately there wasn't a good idea/log that helps us to continue on understanding this issue.
Due to that for now it is not really actionable and I'll mark it incomplete to reflect that.

Changed in php7.1 (Ubuntu):
status: New → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers