php7.0: update to latest version of packages from Debian unstable

Bug #1553419 reported by Nish Aravamudan on 2016-03-05
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
php-defaults (Ubuntu)
Undecided
Unassigned
php-memcache (Ubuntu)
Undecided
Unassigned
php-memcached (Ubuntu)
Undecided
Unassigned
php-pear (Ubuntu)
Undecided
Unassigned
php-universe-source7.0 (Ubuntu)
Undecided
Unassigned
php7.0 (Ubuntu)
Undecided
Unassigned
xdebug (Ubuntu)
Undecided
Unassigned

Bug Description

php7.0: merge with 7.0.4-5
php-universe-source7.0: merge with 7.0.4-5
php-defaults: sync with 35
php-pear: sync 1:1.10.1+submodules+notgz-4
php-xdebug: sync 2.4.0-1
  Note we are currently carrying a delta here, which can be dropped as it
   was cherry-picked from upstream.
php-memcache: sync 3.0.9~20151130.fdbd46b-2
  We are at -0 in Ubuntu; -1 in Debian is for tracking the same version as Ubuntu and -2 is for forcing the build to use PHP7, which for Ubuntu should be equivalent to a rebuild, however we need to sync as php-common currently breaks php-memcache (< 3.0.9~20151130.fdbd46b-2~).

This will pick up the latest bugfixes and ensure self-consistency.

The attachment "php-defaults_35.35ubuntu1.debdiff" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Nish Aravamudan (nacc) wrote :
Nish Aravamudan (nacc) on 2016-03-05
description: updated
Steve Langasek (vorlon) wrote :

php-pear synced.

Changed in php-pear (Ubuntu):
status: New → Fix Committed
Nish Aravamudan (nacc) on 2016-03-14
description: updated
description: updated
description: updated
Changed in php-defaults (Ubuntu):
status: New → Fix Committed
Nish Aravamudan (nacc) wrote :
Nish Aravamudan (nacc) wrote :
Nish Aravamudan (nacc) wrote :
Nish Aravamudan (nacc) wrote :

php-universe-source7.0_7.0.4.orig.tar.xz is identical to php7.0_7.0.4.orig.tar.xz, so I am not uploading it to this bug.

Nish Aravamudan (nacc) on 2016-03-14
Changed in php-xdebug (Ubuntu):
status: New → Fix Committed
description: updated
description: updated
Steve Langasek (vorlon) wrote :

This bug was fixed in the package php-memcache - 3.0.9~20151130.fdbd46b-2
Sponsored for Nish Aravamudan (nacc)

---------------
php-memcache (3.0.9~20151130.fdbd46b-2) unstable; urgency=medium

  * Remove Sergey from Uploaders per his request and thanks for all his
    work for all these years
  * Force rebuild with dh_php >= 0.7

 -- Ondřej Surý <email address hidden> Mon, 29 Feb 2016 22:18:26 +0100

php-memcache (3.0.9~20151130.fdbd46b-1) unstable; urgency=medium

  * Sync with Ubuntu on package version, so we don't have version clashes
    in the future
  * Imported Upstream version 3.0.9~20151130.fdbd46b

 -- Ondřej Surý <email address hidden> Fri, 19 Feb 2016 14:57:17 +0100

Changed in php-memcache (Ubuntu):
status: New → Fix Released
Steve Langasek (vorlon) wrote :

The php-memcached package in Debian unstable is at a new upstream version. Please confirm that this is not something that should go through the FFe process for updating.

We can also adjust the versioned Breaks: from php-common for Ubuntu's purposes, which may be e

Changed in php-memcached (Ubuntu):
status: New → Incomplete
Nish Aravamudan (nacc) wrote :

I agree that for now, let's keep our version of memcached and update the version comparison.

Steve Langasek (vorlon) wrote :

Changes to the dependencies of php-defaults should be made to debian/control.in, not just debian/control. Adjusted locally.
Also, the version used for php-memcached was subjected to an incomplete replacement (2.2.0-51-ge573a6e+2.2.0-2build1 vs. 2.2.0-95-ge573a6e+2.2.0-2~).

Uploading. Thanks

Steve Langasek (vorlon) on 2016-03-15
Changed in php-memcached (Ubuntu):
status: Incomplete → Won't Fix
Changed in php7.0 (Ubuntu):
status: New → Fix Committed
Changed in php-universe-source7.0 (Ubuntu):
status: New → Fix Committed
Ondřej Surý (ondrej) wrote :

@nacc @vorlon FYI:

php7.0 (7.0.4-6) unstable; urgency=medium

  * Add patch to fix segmentation fault in pcre running twig tests
  * Register libphp@PHP_MAJOR@.so with update-alternatives, so there's no
    dangling symbol in the piuparts
  * Really expand $libdir and $datadir before AC_SUBST to allow passing
    ${prefix} as part of --with-libdir
  * Don't reset module provides at every dsoname, but at every module name

 -- Ondřej Surý <email address hidden> Mon, 14 Mar 2016 16:11:21 +0100

Just building this and uploading to unstable.

Also this might need to be fixed (bad PEAR install path due building PEAR from src:php-pear):
https://github.com/oerdnj/deb.sury.org/issues/304

I'll look into that this week (so feel free to be faster).

Ondřej Surý (ondrej) wrote :

Ok, found the cause to the GH#304, and it's easy to fix, defining PEAR_INSTALLDIR in configure.in even though we are building --without-pear should be enough to get the right PHP define() defined.

Sebastien Bacher (seb128) wrote :

looks like there is nothing left to sponsor, unsubscribing the team then

Nish Aravamudan (nacc) wrote :
Steve Langasek (vorlon) wrote :

--- php-defaults-35ubuntu3/debian/control.in 2016-03-14 21:01:29.000000000 -0700
+++ php-defaults-35ubuntu4/debian/control.in 2016-03-15 16:51:32.000000000 -0700
@@ -114,7 +114,7 @@
         php-mongodb (<< 1.1.2-3~),
         php-msgpack (<< 2.0.0+0.5.7-2~),
         php-radius (<< 1.4.0~b1-2~),
- php-redis (<< 2.2.7-355-g799e0bc+2.2.7-4~),
+ php-redis (<< 2.2.7-389-g2887ad1+2.2.7-1~),
         php-rrd (<< 2.0.0+1.1.3-3~),
         php-smbclient (<< 0.8.0~rc1-2~),
         php-ssh2 (<< 0.12-39-g3dfe336+0.12-1~),

Well, 2.2.7-389-g2887ad1+2.2.7-1 is nowhere to be found in Ubuntu. The existing version check is buggy, but this new one is also buggy. The right version check for Ubuntu appears to be 2.2.7-355-g799e0bc+2.2.7-2.

Steve Langasek (vorlon) wrote :

Ok, correction, php-redis 2.2.7-389-g2887ad1+2.2.7-1 is somewhere to be found in Ubuntu - in xenial-proposed. So the proposed change isn't buggy, it OTOH it also isn't necessary.
The only package still blocking us here is php-zmq. Adjusting and uploading.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package php-defaults - 35ubuntu4

---------------
php-defaults (35ubuntu4) xenial; urgency=medium

  * Adjust versioned breaks for php-zmq as well, based on the actual version
    built for php7 in Ubuntu.

 -- Steve Langasek <email address hidden> Tue, 15 Mar 2016 20:12:18 -0700

Changed in php-defaults (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (3.9 KiB)

This bug was fixed in the package php-universe-source7.0 - 7.0.4-5ubuntu1

---------------
php-universe-source7.0 (7.0.4-5ubuntu1) xenial; urgency=medium

  * Build of universe components to match LP: #1553419 upload of php7.0.
    - d/rules: mark universe as enabled.
    - d/control{,.in}: add Build-Depends on firebird-dev,
      libc-client-dev, libmcrypt-dev, libonig-dev, libqdbm-dev and
      libzip-dev.
    - d/control{,.in}: rename Source: to match this build. [previously
      undocumented]
    - drop Testsuite: autopkgtest since this package has no tests.
    - d/control: remove binary packages that are not built by this
      source package. [previously undocumented]

php7.0 (7.0.4-5ubuntu1) xenial; urgency=medium

  * Merge with Debian unstable (LP: #1553419). Remaining changes:
    - Add support for independent source packages php7.0 and
      php7.0-universe-source (LP #1555843):
      + d/control{,.in}: drop Build-Depends on firebird-dev, libc-client-dev,
        libmcrypt-dev, libonig-dev, libqdbm-dev and libzip-dev.
      + d/control: drop binary packages php7.0-imap, php7.0-interbase,
        php7.0-mcrypt and php7.0-zip and their reverse dependencies.
      + d/control{,.in}: add Build-Depends on dctrl-tools.
      + d/rules.d/ext-interbase.mk: add pdo config to interbase's
        config, as php7.0-universe-common will not use ext-common.mk.
    - d/control{,.in}: switch Build-Depends of netcat-traditional to
      netcat-openbsd as only the latter is in main.
    - d/rules: do not generate debian/tests/control when building for
      universe.
    - d/rules: use grep-dctrl to remove binary packages not generated by
      this source package during the build (dpkg-genchanges complains
      otherwise).
  * Drop:
    - d/rules: use grep{,-dctrl} to filter out makefile snippets and
      binary packages that require universe.
      [ Not present ]
    - Undocumented changes to debian/control.
      [ Prior merge churn]
  * php7.0-interbase: Do not install pdo.so, as it is provided
    by php7.0-common (LP: #1556486).

php7.0 (7.0.4-5) unstable; urgency=medium

  * Apply patch to make opcache lockfile path configurable
    (Courtesy of Gandi)

php7.0 (7.0.4-4) unstable; urgency=medium

  * Also kill old /etc/php/mods-available/zlib.ini
    (Closes: #817205, #817202)

php7.0 (7.0.4-3) unstable; urgency=medium

  * We need php_enable() in prerm script (Closes: #816763)
  * Force ucf and ucfr de-registration of old config files
  * ZLIB needs to be builtin module to support IMAGETYPE_SWC
  * Remove zlib extension from the list of extensions
  * php-common.preinst.extra was missing from d/prepare-files
  * Remove debian/ prefix from @package@ in prepared-files

php7.0 (7.0.4-2) unstable; urgency=medium

  * Replace libvpx-dev with libwebp-dev in ext-gd.mk
  * zlib extension needs to be enable as a module for all SAPIs to support
    IMAGETYPE_SWC

php7.0 (7.0.4-1) unstable; urgency=medium

  * Imported Upstream version 7.0.4
  * Remove two patches already present in upstream
  * Rebase patches on top of 7.0.4 release
  * Remove ucfq part from prerm and postrm script that's not needed
    anymore (it was needed for dual mysql and my...

Read more...

Changed in php-universe-source7.0 (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (3.3 KiB)

This bug was fixed in the package php7.0 - 7.0.4-5ubuntu1

---------------
php7.0 (7.0.4-5ubuntu1) xenial; urgency=medium

  * Merge with Debian unstable (LP: #1553419). Remaining changes:
    - Add support for independent source packages php7.0 and
      php7.0-universe-source (LP #1555843):
      + d/control{,.in}: drop Build-Depends on firebird-dev, libc-client-dev,
        libmcrypt-dev, libonig-dev, libqdbm-dev and libzip-dev.
      + d/control: drop binary packages php7.0-imap, php7.0-interbase,
        php7.0-mcrypt and php7.0-zip and their reverse dependencies.
      + d/control{,.in}: add Build-Depends on dctrl-tools.
      + d/rules.d/ext-interbase.mk: add pdo config to interbase's
        config, as php7.0-universe-common will not use ext-common.mk.
    - d/control{,.in}: switch Build-Depends of netcat-traditional to
      netcat-openbsd as only the latter is in main.
    - d/rules: do not generate debian/tests/control when building for
      universe.
    - d/rules: use grep-dctrl to remove binary packages not generated by
      this source package during the build (dpkg-genchanges complains
      otherwise).
  * Drop:
    - d/rules: use grep{,-dctrl} to filter out makefile snippets and
      binary packages that require universe.
      [ Not present ]
    - Undocumented changes to debian/control.
      [ Prior merge churn]
  * php7.0-interbase: Do not install pdo.so, as it is provided
    by php7.0-common (LP: #1556486).

php7.0 (7.0.4-5) unstable; urgency=medium

  * Apply patch to make opcache lockfile path configurable
    (Courtesy of Gandi)

php7.0 (7.0.4-4) unstable; urgency=medium

  * Also kill old /etc/php/mods-available/zlib.ini
    (Closes: #817205, #817202)

php7.0 (7.0.4-3) unstable; urgency=medium

  * We need php_enable() in prerm script (Closes: #816763)
  * Force ucf and ucfr de-registration of old config files
  * ZLIB needs to be builtin module to support IMAGETYPE_SWC
  * Remove zlib extension from the list of extensions
  * php-common.preinst.extra was missing from d/prepare-files
  * Remove debian/ prefix from @package@ in prepared-files

php7.0 (7.0.4-2) unstable; urgency=medium

  * Replace libvpx-dev with libwebp-dev in ext-gd.mk
  * zlib extension needs to be enable as a module for all SAPIs to support
    IMAGETYPE_SWC

php7.0 (7.0.4-1) unstable; urgency=medium

  * Imported Upstream version 7.0.4
  * Remove two patches already present in upstream
  * Rebase patches on top of 7.0.4 release
  * Remove ucfq part from prerm and postrm script that's not needed
    anymore (it was needed for dual mysql and mysqlnd modules)
  * Move php module deactivation back to postrm remove block
    (Closes: #816465)
  * Reorder SAPI cleanup scripts to properly disable PHP extensions

php7.0 (7.0.3-13) unstable; urgency=medium

  * Check for old inidir existence before removing it (Closes: #816429)

php7.0 (7.0.3-12) unstable; urgency=medium

  * Turn comma into pipe to make fpm alternative to other web SAPIs

php7.0 (7.0.3-11) unstable; urgency=medium

  * Move mods-available directories to /etc/php/X.Y/mods-available
  * Install missing php-module.preinst scripts

php7.0 (7.0.3-10) unstable; urgency=medium

  * Don't e...

Read more...

Changed in php7.0 (Ubuntu):
status: Fix Committed → Fix Released
Steve Langasek (vorlon) wrote :

xdebug 2.4.0-1 is in xenial now.

affects: php-xdebug (Ubuntu) → xdebug (Ubuntu)
Changed in xdebug (Ubuntu):
status: Fix Committed → Fix Released
Steve Langasek (vorlon) wrote :

php-pear 1:1.10.1+submodules+notgz-4 has also made it to xenial.

Changed in php-pear (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers