Comment 21 for bug 875262

Steve Langasek (vorlon) wrote :

This was fixed in 5.3.10-1ubuntu2. Changelog:

php5 (5.3.10-1ubuntu2) precise; urgency=low

  * Pre-Depend on a new enough version of dpkg for dpkg-maintscript-helper
    rather than checking whether it exists at run-time, leading to more
    predictable behaviour on upgrades.

The preinst should be cleaned up to drop the '[ -x /usr/bin/dpkg-maintscript-helper ] && ' check as well, but that's not critical, as with the pre-dep it should always be present and executable.