Comment 0 for bug 74647

Package: php5-gd
Version: 5.0.4-3
Severity: wishlist

gd seems to build with an external gd library,
php5 has it's own gd library shipped with it.

One functions that isn't available when gd is build with an external lib
is ImageRotate();

This function is probably used a lot (I use it) and there is no real
reason to not use the gd library bundled with php I think.

So It would be nice if the bundeled gd lib is used instead of the
external debian one. If this is not possible try to patch it maybe so
php still knows about the ImageRotate() function.

-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing'), (500, 'stable')
Architecture: i386 (i686)
Shell: /bin/sh linked to /bin/bash
Kernel: Linux 2.6.11-1-686
Locale: LANG=nl_NL.UTF-8@euro, LC_CTYPE=nl_NL.UTF-8@euro (charmap=UTF-8)

Versions of packages php5-gd depends on:
ii debconf [debconf-2.0] 1.4.54 Debian configuration management sy
ii libapache-mod-php5 [phpap 5.0.4-3 server-side, HTML-embedded scripti
ii libapache2-mod-php5 [phpa 5.0.4-3 server-side, HTML-embedded scripti
ii libc6 2.3.2.ds1-22 GNU C Library: Shared libraries an
ii libfreetype6 2.1.10-1 FreeType 2 font engine, shared lib
ii libgd2-xpm 2.0.33-2 GD Graphics Library version 2
ii libjpeg62 6b-10 The Independent JPEG Group's JPEG
ii libpng12-0 1.2.8rel-1 PNG library - runtime
ii libt1-5 5.0.2-3 Type 1 font rasterizer library - r
ii libx11-6 6.8.2.dfsg.1-4 X Window System protocol client li
ii libxpm4 6.8.2.dfsg.1-4 X pixmap library
ii php5-cgi [phpapi-20041030 5.0.4-3 server-side, HTML-embedded scripti
ii php5-cli [phpapi-20041030 5.0.4-3 command-line interpreter for the p
ii php5-common 5.0.4-3 Common files for packages built fr
ii xlibs 6.8.2.dfsg.1-4 X Window System client libraries m
ii zlib1g 1:1.2.3-1 compression library - runtime

php5-gd recommends no packages.

-- debconf information:
  php5/extension_gd_apache2: true
  php5/extension_gd_cli: true
  php5/remove_extension: true
  php5/add_extension: true
  php5/extension_gd_apache: true
  php5/extension_gd_cgi: true