zlib extension missing in php5 karmic

Bug #451405 reported by Martin Bogomolni
98
This bug affects 18 people
Affects Status Importance Assigned to Milestone
php5 (Ubuntu)
Undecided
Unassigned
Nominated for Karmic by Andreas Otto

Bug Description

Binary package hint: php5

On 9.10 Karmic beta, tested on x86/x86_64/armel :

php5 is missing extension zlib.so even though php5 has been compiled with zlib support. This can be reproduced by installing a php package that depends on zlib such as Wordpress (uses zlib to unpack .zip files).

the error generated is:

Abort class-pclzip.php : Missing zlib extensions

A bug may have been misfiled under zlib for this error - Launchpad reference is https://bugs.launchpad.net/ubuntu/+source/zlib/+bug/439407

Revision history for this message
Chuck Burgess (ashnazg) wrote :

Another possible symptom of this can be seen on Bug #451314...

Revision history for this message
Till Klampaeckel (till-php) wrote :

This is not a bug. When an extension is not build shared, there is no .so file.

zlib is included in the latest php install:

till@till-laptop:~$ php -r 'var_dump(function_exists("gzfile"));'
bool(true)

gzfile is one of the functions provided by the zlib extension.

Changed in php5 (Ubuntu):
status: New → Invalid
Revision history for this message
Martin Bogomolni (martinbogo) wrote :

What then, is the valid package to file this bug against? Having zlib built into PHP, rather than as an extension, breaks various other php plugins that seem to require zlib to be built as such.

Scott Evans (vk7hse)
Changed in php5 (Ubuntu):
status: Invalid → Incomplete
Revision history for this message
Scott Evans (vk7hse) wrote :

Why is it when a bug is filed it is never a bug? I had functionality of the zlib package in Jaunty, but after updating to Karmic its broken. So how is this not a bug? TIME TO REVIEW CODE and fix! instead of disregarding a valid bug.

$ php -r 'var_dump(function_exists("gzfile"));'
bool(true)

$ php -r 'var_dump(function_exists("gzopen"));'
bool(false)

Refer to my notes from bug #439407

this is for... i386

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu karmic (development branch)
Release: 9.10
Codename: karmic

Linux 2.6.31-14-generic #47-Ubuntu SMP Thu Oct 15 02:08:08 UTC 2009 i686 GNU/Linux

Revision history for this message
James M. Cooper (jmichc) wrote :

I am experiencing issues with this BUG as well.

In my case, this is also for:

i386
Ubuntu Karmic, Server (Beta)
2.6.31-14-generic

Changed in php5 (Ubuntu):
status: Incomplete → Confirmed
Revision history for this message
Andreas Otto (andreas-otto) wrote :

A lot of bug reports regarding this issue can be found at bugs.launchpad.net now.

Reports I have found so far are:

#439407
#432291

Revision history for this message
Martin Bogomolni (martinbogo) wrote :

We are a couple days from the release of Karmic Koala ... this is a critical bug that _will_ affect everyone using ubuntu-server. Is anyone with commit access looking at solutions to this issue?

Revision history for this message
Chuck Short (zulcss) wrote :

@martinbogo:

Yes this will probably make it in to updates.

Thanks
chuck

Revision history for this message
bellbind (bellbind) wrote :

I'm aware the problem from more than 1 month ago (and rejected).
Then, I posted my solution to https://bugs.launchpad.net/ubuntu/+source/php5/+bug/432291/comments/4

Revision history for this message
Alan Bratteson (abratteson) wrote :

I replaced gzopen with gzopen64 in the class-pclzip.php and that fixed the issues for me on x86 and x86_64 platforms.

Revision history for this message
Scott Evans (vk7hse) wrote : Re: [Bug 451405] Re: zlib extension missing in php5 karmic

But you will need to manually do this, as each update will over write
"class-pclzip.php" thus returning it back to "gzopen" so yes it it
works by doing this but it's still not addressing the actual issue to
the call to "gzopen" and I'm sure that even if the code was changed to
refer to "gzopen64" this will not work for other distros!

On Thu, 2009-10-29 at 18:44 +0000, Alan Bratteson wrote:

> I replaced gzopen with gzopen64 in the class-pclzip.php and that fixed
> the issues for me on x86 and x86_64 platforms.

--
Scott Evans <email address hidden>

--
This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed.
If you have received this email in error please notify the system manager. This message contains confidential information and is intended only for the
individual named. If you are not the named addressee you should not disseminate, distribute or copy this e-mail. Please notify the sender immediately
by e-mail if you have received this e-mail by mistake and delete this e-mail from your system. If you are not the intended recipient you are notified
that disclosing, copying, distributing or taking any action in reliance on the contents of this information is strictly prohibited.

Revision history for this message
Beto (es-beto) wrote :

This bug affects me I can't publish or export in sugar crm
Also, I can't find the class-pclzip.php file
Is that file on the system? or is it on the source code of php before compiling? I don't understand

Revision history for this message
Scott Evans (vk7hse) wrote :

Hi,

The class-pclzip.php file is part of WordPress blog not part of zlib...

On Fri, 2009-10-30 at 05:41 +0000, Beto wrote:

> This bug affects me I can't publish or export in sugar crm
> Also, I can't find the class-pclzip.php file
> Is that file on the system? or is it on the source code of php before compiling? I don't understand
>

--
Scott Evans VK7HSE
Phone: +61362291658
Mobile: +61417586157
Skype: vk7hse
<email address hidden>
http://www.vk7hse.hobby-site.org
PGP/GPG Key ID 437E00F9

--
This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed.
If you have received this email in error please notify the system manager. This message contains confidential information and is intended only for the
individual named. If you are not the named addressee you should not disseminate, distribute or copy this e-mail. Please notify the sender immediately
by e-mail if you have received this e-mail by mistake and delete this e-mail from your system. If you are not the intended recipient you are notified
that disclosing, copying, distributing or taking any action in reliance on the contents of this information is strictly prohibited.

Revision history for this message
jollyr0ger (jollyr0ger) wrote :

I've go this problem too. Someone said that is beacusee the zlib is not activated by default. But this means that I can't use MySqlDumper!

Revision history for this message
bellbind (bellbind) wrote :

The problem is that the PHP standard function "gzopen" is renamed as "gzopen64".
It may be just a bug at build system.

I think it is caused by macro "#define gzopen gzopen64" in /usr/include/zlib.h (zlib1g-dev :1.2.3.3.dfsg-13ubuntu3).

The unapplyed patch "019-z_off_t_as_long.patch" generates old version zlib.h into ext/zlib.
If the patch is applyed, PHP "gzopen" function is defined beacuse it does not contain the gzopen macro.

Revision history for this message
Chuck Short (zulcss) wrote :

This is fixed in karmic-proposed please enable it in your /etc/apt/sources.list and test.

Thanks
chuck

Revision history for this message
Dan Fornika (dfornika) wrote :

I enabled karmic-proposed and ran a Software Update.

I can confirm that after the update, I am able to install new themes in Wordpress without getting the "Abort class-pclzip.php : Missing zlib extensions" error message.

Revision history for this message
Scott Evans (vk7hse) wrote :

Hi...

I've just ran the XML Sitemap Generator for WordPress 3.1.7 (sitemap.gz)
and it worked! have yet to run the autoupdate in WordPress, but if the
sitemap generator worked then I'm certain that WP will too!

Thanks for actioning this issue ;)

On Sat, 2009-10-31 at 00:06 +0000, Chuck Short wrote:

> This is fixed in karmic-proposed please enable it in your
> /etc/apt/sources.list and test.
>
> Thanks
> chuck
>

--
Scott Evans VK7HSE
Phone: +61362291658
Mobile: +61417586157
Skype: vk7hse
<email address hidden>
http://www.vk7hse.hobby-site.org
PGP/GPG Key ID 437E00F9

--
This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed.
If you have received this email in error please notify the system manager. This message contains confidential information and is intended only for the
individual named. If you are not the named addressee you should not disseminate, distribute or copy this e-mail. Please notify the sender immediately
by e-mail if you have received this e-mail by mistake and delete this e-mail from your system. If you are not the intended recipient you are notified
that disclosing, copying, distributing or taking any action in reliance on the contents of this information is strictly prohibited.

Revision history for this message
re5et (re5etsmyth) wrote :

Sorry, what is it that i need to enable / uncomment in my /etc/apt/source.list for this to work?

Revision history for this message
Scott Evans (vk7hse) wrote :

look for... (/etc/apt/sources.list)

deb http://au.archive.ubuntu.com/ubuntu/ karmic-proposed restricted main
multiverse universe

if its not there then add it ;) note that the source server will need
to match for you particular area...

On Sat, 2009-10-31 at 05:09 +0000, re5et wrote:

> Sorry, what is it that i need to enable / uncomment in my
> /etc/apt/source.list for this to work?
>

--
Scott Evans VK7HSE
Phone: +61362291658
Mobile: +61417586157
Skype: vk7hse
<email address hidden>
http://www.vk7hse.hobby-site.org
PGP/GPG Key ID 437E00F9

--
This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed.
If you have received this email in error please notify the system manager. This message contains confidential information and is intended only for the
individual named. If you are not the named addressee you should not disseminate, distribute or copy this e-mail. Please notify the sender immediately
by e-mail if you have received this e-mail by mistake and delete this e-mail from your system. If you are not the intended recipient you are notified
that disclosing, copying, distributing or taking any action in reliance on the contents of this information is strictly prohibited.

Revision history for this message
Scott Evans (vk7hse) wrote :

Just completed an auto update for WordPress, so yes, this is now fixed
and working again as it should!

Thanks again... ;-)

--
Scott Evans <email address hidden>

--
This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed.
If you have received this email in error please notify the system manager. This message contains confidential information and is intended only for the
individual named. If you are not the named addressee you should not disseminate, distribute or copy this e-mail. Please notify the sender immediately
by e-mail if you have received this e-mail by mistake and delete this e-mail from your system. If you are not the intended recipient you are notified
that disclosing, copying, distributing or taking any action in reliance on the contents of this information is strictly prohibited.

Revision history for this message
Hugues Fournier (hugues-fournier) wrote :

I can confirm pecl / pear install do not hang silently anymore (silently because of the @ before gzopen).

Revision history for this message
mlhshino (shino) wrote :

Thanks all! It works for me too!

Revision history for this message
suniyo (suniyo) wrote :

some modules disabled may be .... because of this new upstart thing at boot/startup we have in karmic. affected too with this bug. need a solution. really

Revision history for this message
Samuel Aguilera (agamum) wrote :

It works for me too :)

After adding proposed repository, I executed this:

apt-get install php5-mysql php5-common php5-suhosin libapache2-mod-php5 php5-tidy php5-xmlrpc php5-mcrypt php5-curl php5-gd php5-mhash php5-cli

Because I think is better to have all php installed modules in the same version...

And after that, it works :)

I hope to see this pushed to stable pretty soon.

Revision history for this message
Samuel Aguilera (agamum) wrote :

By the way... I'm running 32bit karmic

Revision history for this message
Steve Langasek (vorlon) wrote :

upstart has nothing to do with this.

Revision history for this message
Nabeel (nabeel) wrote :

Did the debian update with adding to apt-get sources list, did sudo apt-get update and then upgrade, upgraded a bunch of packages.

I show:

zlib
ZLib Support enabled
Stream Wrapper support compress.zlib://
Stream Filter support zlib.inflate, zlib.deflate
Compiled Version 1.2.3.3
Linked Version 1.2.3.3

Directive Local Value Master Value
zlib.output_compression Off Off
zlib.output_compression_level -1 -1
zlib.output_handler no value no value

Seemed to have gone ok, though Wordpress is still throwing the error...

Revision history for this message
suniyo (suniyo) wrote :

Solved. But upstart thing has made the life bit more difficult for sure.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers