php5 crashed with SIGSEGV in clone()

Bug #441406 reported by tobias_t on 2009-10-03
134
This bug affects 21 people
Affects Status Importance Assigned to Milestone
php5 (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: php5

Ubuntu reports a crash of PHP, but I do not Know what Programm used PHP, There was no Http request.

ProblemType: Crash
Architecture: i386
Date: Sat Oct 3 15:59:04 2009
Disassembly: 0x7937170: Cannot access memory at address 0x7937170
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/php5
Package: php5-cli 5.2.10.dfsg.1-2ubuntu4
ProcCmdline: /usr/bin/php -q /usr/share/horde3/kronolith/scripts/reminders.php
ProcEnviron:
 PATH=(custom, no user)
 SHELL=/bin/sh
ProcVersionSignature: Ubuntu 2.6.31-11.36-generic
SegvAnalysis:
 Segfault happened at: 0x7937170: Cannot access memory at address 0x7937170
 PC (0x07937170) not located in a known VMA region (needed executable region)!
SegvReason: executing unknown VMA
Signal: 11
SourcePackage: php5
Stacktrace:
 #0 0x07937170 in ?? ()
 No symbol table info available.
 #1 0x009937ee in clone () from /lib/tls/i686/cmov/libc.so.6
 No symbol table info available.
StacktraceTop:
 ?? ()
 clone () from /lib/tls/i686/cmov/libc.so.6
Title: php5 crashed with SIGSEGV in clone()
Uname: Linux 2.6.31-11-generic i686
UserGroups:

tobias_t (linuxert) wrote :
tobias_t (linuxert) on 2009-10-03
visibility: private → public
Andreas Olsson (andol) wrote :

As /usr/share/horde3/kronolith/scripts/reminders.php was the script being called I guess the program calling php is kronolith2?

Chuck Short (zulcss) on 2009-10-05
Changed in php5 (Ubuntu):
importance: Undecided → Low
status: New → Triaged
tags: removed: need-i386-retrace
Ben Melluish (ben-melluish) wrote :

Yeah this is the php5-cli package I think. Mine crashed when starting Komodo Edit 5.2.1, never had it before. Komodo loads it for code intelligence/auto-complete stuff. Hope this helps.

Paul Huygen (paul-huygen) wrote :

Me too. I get mail messages at regular times, stating:

PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20060613+lfs/gd.so' - /usr/lib/php5/20060613+lfs/gd.so: cannot open shared object file: No such file or directory in Unknown on line 0

Chuck Short (zulcss) wrote :

I am not able to reproduce this on natty so I am going to consider this fixed.

@ben and @paul please open new bugs if you are still having problems.

Regards
chuck

Changed in php5 (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers