php5 source packages announces Debian SVN repo

Bug #323731 reported by Andreas Olsson on 2009-01-31
4
Affects Status Importance Assigned to Milestone
php5 (Ubuntu)
Low
Chuck Short

Bug Description

Binary package hint: php5

This deals with the PHP5 version in Intrepid (5.2.6-2ubuntu4) and Jaunty (5.2.6-2ubuntu5).

debian/control contains these two lines:
  Vcs-Svn: svn://svn.debian.org/pkg-php/php5/trunk
  Vcs-Browser: http://svn.debian.org/wsvn/pkg-php/php5/trunk

Running the command: "apt-get source php5" among other things will show you this:
  NOTICE: 'php5' packaging is maintained in the 'Svn' version control system at:
  svn://svn.debian.org/pkg-php/php5/trunk

From what I've understood Ubuntu maintains a php5 package which might be synced from the Debian package but otherwise is maintained independently?

Andreas Olsson (andol) wrote :

By the way, the MySQL package, for example, uses this syntax

 XS-Original-Vcs-Browser: ...
XS-Original-Vcs-Svn: ..

Chuck Short (zulcss) wrote :

This is not a bug we sync our php packages from debian.

Changed in php5:
status: New → Invalid
Daniel Hahler (blueyed) wrote :

Reopening, since I think you are not correct here, Chuck.
php5 is not synced, but merged, and therefore it's maintained by/in Ubuntu and not Debian's SVN.
I cannot find any documentation about (XS-)?Original-Vcs-* though, so I might be wrong, of course.

Changed in php5 (Ubuntu):
assignee: nobody → Chuck Short (zulcss)
importance: Undecided → Low
status: Invalid → New
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package php5 - 5.2.9.dfsg.1-4ubuntu1

---------------
php5 (5.2.9.dfsg.1-4ubuntu1) karmic; urgency=low

  * Merge from debian unstable, remaining changes:
    - debian/control, debian/rules: Disable a few build dependencies and
      accompanying binary packages which we do not want to support in main:
      + firebird2-dev/php5-interbase (we have a seperate php-interbase source)
      + libc-client/php5-imap (we have a seperate php-imap source)
      + libmcrypt-dev/php5-mcrypt (seperate php-mycrpt source)
      + readline support again, now that the libedit issue is fixed.
    - debian/control: Add build dependency: libdedit-dev (>= 2.9.cvs.20050518-1)
      CLI readline support
    - debian/rules:
      - Correctly mangle PHP5_* macros for lpia
    - debian/patches/use-specific-libdb-version.patch (LP: #165247), mangle
      version ordering in patch to match code for clean application.
    - debian/patches/119-sybase-alias.patch:
      + Fix sybase regression since change to mssql. (LP: #240519)
    - debian/patches/fix-autoconf-ftbfs.patch:
      + Fixes FTBFS
    - debian/control: Use libdb-4.6-dev
  * Dropped changes:
    - debian/patches/fix-pecl-libtool.dpatch:
      + included in debian/patches/libtool2.2.patch
    - debian/patches/fix-segfault-in-openssl.patch:
      + gentoo/010_ext-openssl-utf8-conversion-crash.patch includes it from Debian
    - debian/patches/CVE-2009-0754.patch
     + Included upstream
  * debian/control: Rename Vcs-Browser & Vcs-Git to XS-Original-Vcs-Browser &
    XS-Original-Vcs-Git (LP: #323731)

 -- Andrew Mitchell <email address hidden> Tue, 02 Jun 2009 13:11:34 +1200

Changed in php5 (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers