php5-gd failed to install due to unmet dependencies

Bug #273888 reported by bhatdv on 2008-09-24
4
Affects Status Importance Assigned to Milestone
php5 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: php5

When I tried to install php5-gd with command
 apt-get install php5-gd

I get following response -

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  php5-gd: Depends: php5-common (= 5.2.1-0ubuntu1.6) but 5.2.3-1ubuntu6.4 is to be installed
E: Broken packages

Details of my machine and OS are as below-
OS: GNU/Linux Ubuntu 7.10 - the Gutsy Gibbon
php5 installed version:5.2.3-lubuntu6.4
machine: i686

Mathias Gug (mathiaz) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Could you post your /etc/apt/sources.list file? Did you try to install the php5-gd package by hand using the version provided in feisty?

5.2.1-0ubuntu1.6 refers the php version in feisty-updates while 5.2.3-1ubuntu6.4 refers to the version in gutsy-updates.

Changed in php5:
status: New → Incomplete

Thank you for taking time to look at the bug.

I am attaching my /etc/apt/sources.list file herewith.

I attempted to install php5-common=5.2.1-0ubuntu1.6. I got a response that
some packages will be removed, some will be downgraded and some packages
will be changed. Being new to LAMP, I was not sure whether I could
reinstall the removed, downgraded packages. So, I aborted the installation.
My command and response are as below:

root@cmk-ossd-bhatdv:/home/bhatdv/Desktop# apt-get install
php5-common=5.2.1-0ubuntu1.6

Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be REMOVED:
  libapache2-mod-php5 php5 php5-mysql
The following held packages will be changed:
  php5-common
The following packages will be DOWNGRADED:
  php5-common
0 upgraded, 0 newly installed, 1 downgraded, 3 to remove and 2 not upgraded.
Need to get 224kB of archives.
After unpacking 5988kB disk space will be freed.
Do you want to continue [Y/n]? n
Abort.

Regards.

Datta
(D V Bhat)

On Tue, Oct 14, 2008 at 7:51 AM, Mathias Gug <email address hidden> wrote:

> Thank you for taking the time to report this bug and helping to make
> Ubuntu better. Could you post your /etc/apt/sources.list file? Did you
> try to install the php5-gd package by hand using the version provided in
> feisty?
>
> 5.2.1-0ubuntu1.6 refers the php version in feisty-updates while
> 5.2.3-1ubuntu6.4 refers to the version in gutsy-updates.
>
> ** Changed in: php5 (Ubuntu)
> Status: New => Incomplete
>
> --
> php5-gd failed to install due to unmet dependencies
> https://bugs.launchpad.net/bugs/273888
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in "php5" source package in Ubuntu: Incomplete
>
> Bug description:
> Binary package hint: php5
>
> When I tried to install php5-gd with command
> apt-get install php5-gd
>
> I get following response -
>
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
>
> Since you only requested a single operation it is extremely likely that
> the package is simply not installable and a bug report against
> that package should be filed.
> The following information may help to resolve the situation:
>
> The following packages have unmet dependencies:
> php5-gd: Depends: php5-common (= 5.2.1-0ubuntu1.6) but 5.2.3-1ubuntu6.4 is
> to be installed
> E: Broken packages
>
> Details of my machine and OS are as below-
> OS: GNU/Linux Ubuntu 7.10 - the Gutsy Gibbon
> php5 installed version:5.2.3-lubuntu6.4
> machine: i686
>

On Tue, Oct 14, 2008 at 04:23:34AM -0000, bhatdv wrote:
> Thank you for taking time to look at the bug.
>
> I am attaching my /etc/apt/sources.list file herewith.

Why are all the entries set to feisty (7.04) while you're running gutsy
(7.10)?

> I attempted to install php5-common=5.2.1-0ubuntu1.6. I got a response that
> some packages will be removed, some will be downgraded and some packages
> will be changed. Being new to LAMP, I was not sure whether I could

Why are you trying to install php5-common=5.2.1-0ubuntu1.6? This is not
a version that is supported on gutsy (7.10) since it's a version that is
built for feisty (7.04).

--
Mathias Gug
Ubuntu Developer http://www.ubuntu.com

Chuck Short (zulcss) wrote :

No response from user.

Changed in php5:
status: Incomplete → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments