phpize: configure:8184: error: possibly undefined macro: _LT_SET_OPTIONS

Bug #262251 reported by ehcpdeveloper on 2008-08-28
70
This bug affects 12 people
Affects Status Importance Assigned to Milestone
php5 (Ubuntu)
Undecided
Unassigned
Declined for Intrepid by Mathias Gug
Declined for Karmic by Mathias Gug
Declined for Lucid by Mathias Gug

Bug Description

Binary package hint: php5

this may also a bug of phpize or php5 or soemthing like that

i use ubuntu 8.10 ,

i tried to install php -ssh2 extenasion from pcl.php.net
i downloaded 0.10 or 0.9 - i tried both.. -
then i run phpize as said in documentation..

here is output..

root@bvidinli-desktop:/download/ssh2-0.9# phpize
Configuring for:
PHP Api Version: 20041225
Zend Module Api No: 20060613
Zend Extension Api No: 220060519
configure.in:77: warning: LTOPTIONS_VERSION is m4_require'd but not m4_defun'd
aclocal.m4:2912: LT_INIT is expanded from...
aclocal.m4:2947: AC_PROG_LIBTOOL is expanded from...
configure.in:77: the top level
configure.in:77: warning: LTSUGAR_VERSION is m4_require'd but not m4_defun'd
configure.in:77: warning: LTVERSION_VERSION is m4_require'd but not m4_defun'd
configure.in:77: warning: LTOBSOLETE_VERSION is m4_require'd but not m4_defun'd
configure:5174: error: possibly undefined macro: m4_ifval
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.
configure:8184: error: possibly undefined macro: _LT_SET_OPTIONS
configure:8184: error: possibly undefined macro: LT_INIT

Related branches

Chuck Short (zulcss) wrote :

This is due to the recent libtool changes. You will have to copy ltsugar.m4, ltversion.m4, lt~obselete.m4, and ltoptions from /usr/share/aclocal to their respective places.

Regards
chuck

Changed in php5:
status: New → Invalid
ehcpdeveloper (ehcpdeveloper) wrote :

what are their respective places ?
where should i copy them ?

ehcpdeveloper (ehcpdeveloper) wrote :

i copied to where i run phpize, but nothing changed... same error.

jnRaptor (jnraptor) wrote :

Hi, could i know where to copy the files too as well? I'm trying to install htscanner and getting the same issue as well. OS is Ubuntu 8.10 as well. I tried linking the files at /usr/lib/php5/build but it did not work.

Changed in php5:
status: Invalid → Confirmed

This patch worked for me http://cvs.pld-linux.org/cgi-bin/cvsweb.cgi/SOURCES/php4-libtool.patch?r1=1.4&r2=1.5&f=u
Except i used absolute path instead of ./build

It seems that libtool.m4 from the old libtool version was split into several files: libtool.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4
I think it also works if you temporarily cat lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4 into libtool.m4

Popa Adrian Marius (mapopa) wrote :

seems that it affects other extensions too

http://pecl.php.net/bugs/bug.php?id=14609

also i have tried to build ffmpeg-php extension from source and got the same error
so is impossible to build extensions like is now

Pyry (pyry) wrote :

I had a problem in installing the pdflib extension and I finally got the phpize working by following Bogdan's advice

cd /usr/share/aclocal
cat lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4 >> libtool.m4

After that pecl install worked without a glich :)

Popa Adrian Marius (mapopa) wrote :

i can confirm that works for me now for compiling php extensions

root@cloudbook:/opt/build# cd ffmpeg-php-0.5.3.1
root@cloudbook:/opt/build/ffmpeg-php-0.5.3.1# phpize
Configuring for:
PHP Api Version: 20041225
Zend Module Api No: 20060613
Zend Extension Api No: 220060519
root@cloudbook:/opt/build/ffmpeg-php-0.5.3.1# ./config
config.guess config.nice config.sub configure
root@cloudbook:/opt/build/ffmpeg-php-0.5.3.1# ./configure
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for a sed that does not truncate output... /bin/sed
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes

Sergey Avseyev (avsej) wrote :

Thank you, Pyry and Bogdan

I have same problem when I want to build WSO2 WSF/PHP 2.0 from sources under ubuntu 8.10

checking Whether to enable WSF/PHP Support... yes, shared
./configure: line 5420: LTOPTIONS_VERSION: command not found
./configure: line 5421: LTSUGAR_VERSION: command not found
./configure: line 5422: LTVERSION_VERSION: command not found
./configure: line 5423: LTOBSOLETE_VERSION: command not found
checking for a sed that does not truncate output... (cached) /bin/sed
./configure: line 5513: syntax error near unexpected token `lt_decl_varnames,'
./configure: line 5513: `lt_if_append_uniq(lt_decl_varnames, SED, , ,'
configure: error: /bin/bash './configure' failed for src

Now its work!

Norm 2782 (j-stutterheim) wrote :

The suggested workarounds fail for me for some reason... This issue makes a dist-upgrade to Intrepid a no-go for my server. I would like to suggest that this issue's importance is upped to Critical.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package php5 - 5.2.6-2ubuntu4

---------------
php5 (5.2.6-2ubuntu4) intrepid; urgency=low

  * debian/patches/fix-pecl-libtool.dpatch: fix libtool brokenness
    with pecl. (LP: #262251)

 -- Chuck Short <email address hidden> Tue, 14 Oct 2008 15:16:36 -0400

Changed in php5:
status: Confirmed → Fix Released
mklebel (mklebel) wrote :

im running php - 5.2.6-2ubuntu4, and I still get this error. Even after doing:

cd /usr/share/aclocal
cat lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4 >> libtool.m4

no luck......

mklebel (mklebel) wrote :

sorry, forgot to mention I'm trying to compile php-gtk2

Cédric Belin (cedx) wrote :

I'm using php5 5.2.6-2ubuntu4 package. I get the same errors when I try to compile PHP-GTK 2.0.1.

Alessandro Biasi (envysoft) wrote :

Same error for me compiling PHP-GTK 2.0.1 on ubuntu 8.10
2.6.27-7-generic x86_64 GNU/Linux
php5 5.2.6-2ubuntu4

Daniel Stoyanov (dankh) wrote :

I'm on Intrepid up to date, and while trying to compile PHP-GTK I have the same error. My version of php5 package is 5.2.6-2ubuntu4. The fix :

cd /usr/share/aclocal
cat lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4 >> libtool.m4

Didn't make a difference. I think this bug should be reopened.

Thank you in advance.

Alessandro Biasi (envysoft) wrote :

it works for me with Pyry fix with some changes

cd /usr/share/aclocal
chmod 777 libtool.m4
cat lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4 >> libtool.m4
chmod 644 libtool.m4

In original I don't have permission to change the file

Status seems to be "Fix released". Where it is? I have tried what Alessandro wrote above, but still buildconf fails with same error?

Leo Milano (lmilano) wrote :

Where was the fix released? For 9.04? I just tried installing php-gtk-2.0.1 from source in 8.10 kept current, and I needed to apply the same workaround as Alessandro (it worked for me, thanks!). If it was fixed in 9.04, shouldn;t a patch be applied in all the supported distributions?

I think the status should be reverted to "Confirmed" for now.

Thanks!

I also had this problem, and Alessandro's fix seems to have done the trick!

Leo Milano (lmilano) wrote :

This has not been fixed yet, people are still applying a workaround two releases later.

Changed in php5 (Ubuntu):
status: Fix Released → Confirmed
Lenar (lenar) wrote :

Fix was released by Debian packagers in php5 5.2.9.dfsg.1-3.
So anything based on that or later version should work out of the box.

Seth Hikari (sethhikari) wrote :

Using PHP 5.2.10-2ubuntu5 and tried work around with no luck.

Seth Hikari (sethhikari) wrote :

PHP 5.2.11-1ubuntu1 still not working, been more then a year. Will a fix every be out?

Ryan Reynolds (ryan-reynolds) wrote :

Still having trouble with this on Ubuntu 9.10 with php5 5.2.10.dfsg.1-2ubuntu6.3. Workaround was no help.

./buildconf works but ./configure fails like so:

creating main/php_gtk_ext.c
./configure: line 11960: LTOPTIONS_VERSION: command not found
./configure: line 11961: LTSUGAR_VERSION: command not found
./configure: line 11962: LTVERSION_VERSION: command not found
./configure: line 11963: LTOBSOLETE_VERSION: command not found
checking for a sed that does not truncate output... (cached) /bin/sed
./configure: line 12038: syntax error near unexpected token `lt_decl_varnames,'
./configure: line 12038: `lt_if_append_uniq(lt_decl_varnames, SED, , ,'

This seems to have been around a while. Is there any hope for a fix?

I am also having the same problem preventing me from installing php-gtk.

Kerry (java-avionicengineers) wrote :

I had this problem when trying to install Cairo extension for php with PECL. this workaround does worked for me i.e. cat all the old files, but you have to include the NEW libtools.m4 file to !

First copy all the files incase of error !

** my files are located in /usr/share/aclocal. I'm on ubuntu 8.10 **

cd /usr/share/aclocal
mkdir ~/libtoolsbackup
cp lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4 libtool.m4 ~/libtoolsbackup

cd ~/libtoolsbackup
cp libtool.m4 libtool.m4.backup
rm libtool.m4

cat lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4 libtool.m4.bakup >> libtool.m4

before this next step, make sure you have the above files backed-up !

sudo cp libtool.m4 /usr/share/aclocal/

Shein Alexey (confik) wrote :

Got the same problem as Ryan Reynolds, trick from http://ubuntuforums.org/showthread.php?t=1377395 did its work :
run this one from php-gtk directory
$ cat /usr/share/aclocal/ltoptions.m4 /usr/share/aclocal/ltversion.m4 /usr/share/aclocal/ltsugar.m4 /usr/share/aclocal/lt~obsolete.m4 >> aclocal.m4
after that run ./buildconf and etc.

Selmo Pessoa (selmopessoa-pt) wrote :

Shein's post worked like a charm. Thanks!

Chuck Short (zulcss) wrote :

This shouldnt be a problem in lucid anymore. Please re-open if it still is.

Thanks
chuck

Changed in php5 (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions