Ubuntu

[needs-packaging] php-Fileinfo package

Reported by ramorrismorris on 2008-01-18
8
Affects Status Importance Assigned to Milestone
Debian
Fix Released
Unknown
php5 (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: php5

Per #93603, this is a separate request for the php Fileinfo package.

Fileinfo manages the mime-types of files. It is (optionally) used by the MIT DSpace app to control file upload types based on a blacklist instead of a whitelist, thereby easing management.

There may be dependencies. When I downloaded http://pecl.php.net/get/Fileinfo-1.0.4.tgz and executed pear Fileinfo-1.0.4.tgz pear filed with:

3 files building
running: phpize
sh: phpize: not found
ERROR: `phpize' failed

ramorrismorris (morris-bob) wrote :

Oops, I meant I executed

pear install Fileinfo-1.0.4.tgz

Changed in php5:
importance: Undecided → Wishlist
ramorrismorris (morris-bob) wrote :

OK, using pear directly on the file requires the php5-dev and libmagic-dev ubuntu packages, and then pear install from a local file succeeds.

But was this a good idea? I would have been more comfortable if this were an included package in the distro.
This dependency was less than obvious to a php/ubuntu newbie, and I am nervous about whether the consequent rebuild of the php support has left me in uncharted waters. (And how I would know?)

--Bob

Roy Jamison (xteejx) wrote :

Is this still a problem in Intrepid?
Marking as Incomplete.

Yep. I can confirm that the Fileinfo package is not available in Intrepid without building it manually.

Roy Jamison (xteejx) on 2009-05-13
Changed in php5 (Ubuntu):
status: Incomplete → Confirmed
Micah Gersten (micahg) wrote :

Just wanted to note that this will be a core extension in PHP 5.3.0

Changed in debian:
status: New → Fix Released
Thomas Ward (teward) wrote :

According to the Debian Bug Report (http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=492442), the PHP team included fileinfo as part of 5.3.x. This is included in 5.3.0-1 and beyond. As such, I am marking this as "Fix Released" because of the inclusion of fileinfo as part of 5.3.x upstream (which was included when 5.3.x was put in Debian sid).

Changed in php5 (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.