php5-fpm init.d script does not return any output when php5-fpm is started or stopped

Bug #1059272 reported by Thomas Ward on 2012-09-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
php5 (Debian)
Fix Released
Unknown
php5 (Ubuntu)
Low
Unassigned

Bug Description

Apport information is missing, because I am reporting this on a non-networked location. I will pull apport information after I get the system onto a networked area (installation was via a local repository on a secured subnet of this area).

php5-fpm when using /etc/init.d/php5-fpm stop or /etc/init.d/php5-fpm start, as well as when using 'service' similarly, does not report that the php process was started or stopped. This makes server administration a tad confusing. `pidof php5-fpm` shows it is running, but there's no notification thereof that it was started or stopped (from the start/stop script).

Thomas Ward (teward) wrote :

Update: The 'restart' command does give output similar to this:

[orion]# service php5-fpm restart
 * Restarting PHP5 FastCGI Process Manager php5-fpm

I'd expect similar stuff for 'stop' and 'start' as well, saying "Starting" or "Stopping" accordingly.

Thomas Ward (teward) on 2012-10-09
summary: - php5-fpm init.d script does not return when php5-fpm is started or
- stopped
+ php5-fpm init.d script does not return any output when php5-fpm is
+ started or stopped
Serge Hallyn (serge-hallyn) wrote :

The /etc/init.d/php5-fpm script has checks for $VERBOSE inverted. It has several lines looking like:

[ "$VERBOSE" != no ] && log_daemon_msg "Starting $DESC" "$NAME"

which should read

[ "$VERBOSE" = no ] && log_daemon_msg "Starting $DESC" "$NAME"

Changed in php5 (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Serge Hallyn (serge-hallyn) wrote :

Note my previous comment was wrong and backwards. php5-fpm is doing the right thing, and basically the same thing as for instance /etc/init.d/lprng does. The question is, is verbose as a default what we want from /lib/init/vars.sh?

Serge Hallyn (serge-hallyn) wrote :

That is, is verbose=no as a default what we want.

Thomas Ward (teward) wrote :

This is closed in Debian as "Not a Bug", but rather a "By Design" thing. This should be discussed, whether we want to change what the default verbose setting is in /lib/init/vars.sh. That should be decided upon in future, but in the mean time this isn't a bug according to the PHP maintainers.

Changed in php5 (Debian):
status: Unknown → Fix Released
Neal Gompa (ngompa13) wrote :

This is not a valid bug anymore (if it ever was), as with the move to systemd, sysv calls redirect to systemd, and systemd captures the information in the journal, which can be viewed by looking at /var/log/syslog, using "journalctl -u php5-fpm" (php7.0-fpm for Xenial), or any other mechanism for reading the syslog/journal.

Changed in php5 (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.