PHP Startup: Unable to load dynamic library '/usr/lib/php5/20060613+lfs/sqlite3.so'

Bug #281714 reported by Freak on 2008-10-11
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
php-sqlite3 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: php5-sqlite3

Hello,
I've upgraded to 8.10 and it reinstalled my php5, now somewhy in the Synaptic there are some packages which names are shown but the description is unavailable; one of the happened to be php5-sqlite3, i found it out when i was trying to check a php script for syntax errors or run it (considering it worked perfectly before the upgrade).
It keeps printing the following warning, though this warning is alternative to a fatal error for php, because php won't do a thing :

$ php -l test.php
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20060613+lfs/sqlite3.so' - /usr/lib/php5/20060613+lfs/sqlite3.so: cannot open shared object file: No such file or directory in Unknown on line 0
No syntax errors detected in test.php

$ php -r test.php
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20060613+lfs/sqlite3.so' - /usr/lib/php5/20060613+lfs/sqlite3.so: cannot open shared object file: No such file or directory in Unknown on line 0

Parse error: syntax error, unexpected $end in Command line code on line 1

I tried downloading php5-sqlite3 manually but i wasn't able to install it due to some dependency problems :

Selecting previously deselected package php5-sqlite3.
(Reading database ... 204062 files and directories currently installed.)
Unpacking php5-sqlite3 (from php5-sqlite3_0.4-4ubuntu1_i386.deb) ...
dpkg: dependency problems prevent configuration of php5-sqlite3:
 php5-sqlite3 depends on php-sqlite3; however:
  Package php-sqlite3 is not installed.
dpkg: error processing php5-sqlite3 (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 php5-sqlite3

please help me because i can't work without php... it seriously stucks me.

Jim (info-zoidb) wrote :

I have the exact same problem. Upgraded to intrepid from hardy, now PHP complains about sqlite everytime i run a script...

Keith Hughitt (keith-hughitt) wrote :

Same Here.

Ubuntu 8.10 2.6.27-9-generic
php5 5.2.6-2ubuntu4
php5-sqlite 5.2.6-2ubuntu4

mrfelton (tkp) wrote :

Same problem for me. Anybody manage to fix this?

wschalle (wschalle) wrote :

attempting to install the modules through pecl didn't work... any news on this bug?

help!

evilhamsterman (evilhamsterman) wrote :

/etc/php5/conf.d has two sqlite files one named sqlite3.ini and one named sqlite.ini. I am assuming the sqlite3.ini is a remainder from hardy. I removed the sqlite3.ini file and it no longer complains.

Rocky Road (m-baert) wrote :

Thanks evilhamsterman, it worked also for me :-)

Akiva Levy (deselect-gmail) wrote :

This fix may not be working for me. It seems when I make these changes, upon restarting, certain programs that I assume have the sqlite3 as a dependency do not work. Some examples: evolution, hamster-applet, etc. As a Web developer, these things are crucial for me. Does anyone else know of a solution?

Jay Deiman (jay-splitstreams) wrote :

Ok. This is kind of ridiculous. Sqlite 2 hasn't really been encouraged/supported for a long, long time. Before my recent upgrade to 10.04, I had compiled a php5 friendly version of sqlite 3 (3.0.6) that I found and installed and that worked just fine. It appears that the php api version changed from 20060613 to 20090626 with the upgrade to 10.04 and the 3.0.6 version of sqlite3 will no longer compile under the new api.

The main thing that really irks me here is that the source for php 5.3.0 *includes* source for sqlite3 in it: http://us.php.net/manual/en/sqlite3.installation.php. Can this finally get fixed since, I think, the last working version of sqlite3 was in Hardy?

octopocky (mheartwood) wrote :

I'm using apache2 and php5 and I have an SQLite3 database I'm trying to use. PHP crashes at the line that says:
$db = new SQLite3("dbOpus.sqlite");

papukaija (papukaija) on 2011-05-21
Changed in php-sqlite3 (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers