East-Saskatchewan timezone removed in latest tzdata

Bug #1744166 reported by Nish Aravamudan on 2018-01-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
php-sabre-vobject-3 (Debian)
Fix Committed
Unknown
php-sabre-vobject-3 (Ubuntu)
Undecided
Unassigned
Xenial
Medium
Nish Aravamudan
Artful
Undecided
Nish Aravamudan

Bug Description

[Impact]

* DEP8 tests for php-sabre-vobject-3 currently fail in 16.04 because the 2017c version of tzdata dropped the East-Saskatchewan timezone, which is hardcoded in the package.

* This in turn blocks SRUs of new PHP7.0 microreleases.

[Test Case]

* Run the autopkgtests for this source package before and after the change. They should pass after.

[Regression Potential]

* None, this timezone is no longer valid in 16.04.

Nish Aravamudan (nacc) on 2018-01-18
Changed in php-sabre-vobject-3 (Ubuntu Xenial):
status: New → Confirmed
assignee: nobody → Nish Aravamudan (nacc)
importance: Undecided → Medium
Changed in php-sabre-vobject-3 (Debian):
status: Unknown → Fix Committed
Nish Aravamudan (nacc) wrote :

Fixed in bionic: 3.5.2-1ubuntu1

summary: - East/Saskatchewan timezone removed in latest tzdata
+ East-Saskatchewan timezone removed in latest tzdata
description: updated
Changed in php-sabre-vobject-3 (Ubuntu):
status: New → Fix Released
Changed in php-sabre-vobject-3 (Ubuntu Xenial):
status: Confirmed → In Progress
status: In Progress → Fix Committed
Łukasz Zemczak (sil2100) wrote :

Seeing the change, it looks to me that the same issue would be present in artful as the patch has only been added in bionic. Could you please prepare an artful upload for this source as well?

Since this is essentially test-related change, I will be accepting xenial without blocking on artful. But to keep things in-sync I would still request a fix being uploaded to the next valid upgrade path.

tags: added: verification-needed verification-needed-xenial

Hello Nish, or anyone else affected,

Accepted php-sabre-vobject-3 into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/php-sabre-vobject-3/3.5.0-1ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Yep will do it today.

On Jan 26, 2018 02:00, "Łukasz Zemczak" <email address hidden> wrote:

> Seeing the change, it looks to me that the same issue would be present
> in artful as the patch has only been added in bionic. Could you please
> prepare an artful upload for this source as well?
>
> Since this is essentially test-related change, I will be accepting
> xenial without blocking on artful. But to keep things in-sync I would
> still request a fix being uploaded to the next valid upgrade path.
>
> ** Tags added: verification-needed verification-needed-xenial
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1744166
>
> Title:
> East-Saskatchewan timezone removed in latest tzdata
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/php-sabre-
> vobject-3/+bug/1744166/+subscriptions
>

Nish Aravamudan (nacc) wrote :

FYI, dep8 test passed for this upload in xenial. Marking verified.

tags: added: verification-done-xenial
removed: verification-needed-xenial
Changed in php-sabre-vobject-3 (Ubuntu Artful):
status: New → In Progress
assignee: nobody → Nish Aravamudan (nacc)
Nish Aravamudan (nacc) wrote :

Uploaded to artful as well.

Hello Nish, or anyone else affected,

Accepted php-sabre-vobject-3 into artful-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/php-sabre-vobject-3/3.5.2-1ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-artful to verification-done-artful. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-artful. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in php-sabre-vobject-3 (Ubuntu Artful):
status: In Progress → Fix Committed
tags: added: verification-needed-artful
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package php-sabre-vobject-3 - 3.5.0-1ubuntu1.1

---------------
php-sabre-vobject-3 (3.5.0-1ubuntu1.1) xenial; urgency=medium

  * debian/patches/tzdata_remove_east_saskatchewan.patch: Remove the
    Canada/East-Saskatchewan timezone. Closes #880337, LP: #1744166.

 -- Nishanth Aravamudan <email address hidden> Thu, 18 Jan 2018 15:30:41 -0800

Changed in php-sabre-vobject-3 (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for php-sabre-vobject-3 has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

The fix for this bug has been awaiting testing feedback in the -proposed repository for artful for more than 90 days. Please test this fix and update the bug appropriately with the results. In the event that the fix for this bug is still not verified 15 days from now, the package will be removed from the -proposed repository.

tags: added: removal-candidate

The version of php-sabre-vobject-3 in the proposed pocket of Artful that was purported to fix this bug report has been removed because the bugs that were to be fixed by the upload were not verified in a timely (105 days) fashion.

tags: removed: verification-needed-artful
Changed in php-sabre-vobject-3 (Ubuntu Artful):
status: Fix Committed → Won't Fix
tags: removed: verification-needed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.