[SRU] Integer parsing failure on armhf blocks autopkgtests on focal

Bug #1895878 reported by Bryce Harrington
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
php-parser (Ubuntu)
High
Bryce Harrington
Focal
High
Bryce Harrington
Groovy
High
Bryce Harrington

Bug Description

[Impact]

Other PHP SRUs are being blocked due to test failures in php-parser. The test case failures appear to be due to irregularities with integer parsing particular to the test framework rather than identifying actual bugs.

[Test Case]
1. Create lxc container for ubuntu-focal
2. Install php-parser
3. Run autopkgtest php-parser -- null

The testsuite should pass but it does not, and fails with several invalid token lexer cases starting with and similar to this one:

1) PhpParser\CodeParsingTest::testParse with data set "tmp/autopkgtest.eZ6NuZ/build.Ar8/src/test/code/parser/errorHandling/lexerErrors.test#1" ('Lexer errors (/tmp/autopkgtes....test)', Binary String: 0x3c3f7068700a0...032343b, Binary String: 0x556e657870656...0290a29, null)
RangeException: The lexer returned an invalid token (id=320, value=)

/usr/share/php/PhpParser/ParserAbstract.php:216
/usr/share/php/PhpParser/ParserAbstract.php:158
/tmp/autopkgtest.eZ6NuZ/build.Ar8/src/test/PhpParser/CodeParsingTest.php:58
/tmp/autopkgtest.eZ6NuZ/build.Ar8/src/test/PhpParser/CodeParsingTest.php:21

The build system also runs the test suite, so an alternative way to reproduce the failure is to do a package build of php-parser in lxc.

[Regression Potential]

Since this is a testsuite fix for integer parsing, the two things to watch for would be a) issues relating to the testsuite, or b) issues particular to integer parsing behavior. However, in the first case, the testsuite's behavior would crop up only during building / migrating in the archive and would not produce user-visible effects. In the second case, integer parsing issues already exist in released code so would not be a true regression, the test case only exposes them - by preventing other php packages from migrating.

[Discussion]

php-parser's autopkgtest has been failing in focal on armhf for some time:

    http://autopkgtest.ubuntu.com/packages/p/php-parser/focal/armhf

The test failure is due to an integer format mismatch. We spotted this issue on groovy and flagged it for upstream:

    https://github.com/nikic/PHP-Parser/issues/662

There doesn't appear to be a fix identified yet. We addressed it in groovy by disabling the faulty tests (the one listed in this bug, and the one in LP: #1878102), and that may be a low-risk way to address it for focal, too.

    https://launchpad.net/ubuntu/+source/php-parser/4.4.0-1ubuntu2

Related branches

Bryce Harrington (bryce)
Changed in php-parser (Ubuntu):
importance: Undecided → High
status: New → Triaged
assignee: nobody → Bryce Harrington (bryce)
tags: added: server-next
summary: - Integer parsing failure on armhf blocks autopkgtests on focal
+ [SRU] Integer parsing failure on armhf blocks autopkgtests on focal
description: updated
description: updated
Bryce Harrington (bryce)
description: updated
Changed in php-parser (Ubuntu Focal):
assignee: nobody → Bryce Harrington (bryce)
importance: Undecided → High
status: New → Triaged
Changed in php-parser (Ubuntu Groovy):
status: Triaged → Fix Released
Bryce Harrington (bryce)
description: updated
Bryce Harrington (bryce)
description: updated
Revision history for this message
Robie Basak (racb) wrote :

Marking block-proposed-focal as this is an autopkgtest fix only, should be sufficient to just be in proposed, and there's no need to make users download this update.

tags: added: block-proposed-focal
Changed in php-parser (Ubuntu Focal):
status: Triaged → Fix Committed
tags: added: verification-needed verification-needed-focal
Revision history for this message
Robie Basak (racb) wrote : Please test proposed package

Hello Bryce, or anyone else affected,

Accepted php-parser into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/php-parser/4.2.2-2ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Revision history for this message
Bryce Harrington (bryce) wrote :

I've verified that the package in -proposed builds and autopkgtest shows it as passing. I believe that should be entirely sufficient for purposes of this issue, since this is not being fully migrated to users.

tags: added: verification-done verification-done-focal
removed: verification-needed verification-needed-focal
Changed in php-parser (Ubuntu Focal):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers